Ubuntu

LightDM fails to start/stop after adding script parameter (lightdm.conf)

Reported by Thaddäus Tintenfisch on 2013-02-17
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Undecided
Unassigned
lightdm (Ubuntu)
High
Unassigned

Bug Description

Adding the display-setup-script parameter to /etc/lightdm/lightdm.conf results in LightDM not being started correctly (black screen, X-cursor). Did some test runs to confirm that any value specified for the parameter triggers the described behavior.

$ cat /etc/lightdm/lightdm.conf
[SeatDefaults]
greeter-session=lightdm-gtk-greeter
greeter-hide-users=false
user-session=xubuntu
display-setup-script=sh -c 'echo 123 > /dev/null'
$
$ apt-cache policy lightdm
lightdm:
  Installed: 1.4.0-0ubuntu4
  Candidate: 1.4.0-0ubuntu4
  Version table:
 *** 1.4.0-0ubuntu4 0
        500 http://de.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
$

description: updated
tags: added: raring
Glen Shrubsall (stinkeye) wrote :

Can confirm this happens to me when intalling numlockx
and adding
greeter-setup-script=/usr/bin/numlockx on
to /etc/lightdm/lightdm.conf

$ cat /etc/lightdm/lightdm.conf
[SeatDefaults]
user-session=ubuntu
greeter-session=unity-greeter
greeter-setup-script=/usr/bin/numlockx on

$ apt-cache policy lightdm
lightdm:
  Installed: 1.4.0-0ubuntu4
  Candidate: 1.4.0-0ubuntu4
  Version table:
 *** 1.4.0-0ubuntu4 0
        500 http://au.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

Booting to the greeter sometimes fails and sends me to a black screen and x-cursor.
Once booted, any subsequent logout always goes to a black screen and x-cursor.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
summary: - lightdm crashes on startup display-setup-script
+ LightDM fails to start/stop after adding script parameter (lightdm.conf)
affects: lightdm → glib
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
affects: glib → glib2.0 (Ubuntu)
Robert Ancell (robert-ancell) wrote :

I think this was caused by a change in glib that picked up us using the API wrongly. Regression tests picked this up and should be fixed in this commit:
http://bazaar.launchpad.net/~lightdm-team/lightdm/trunk/revision/1601

Changed in lightdm (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
status: Triaged → Fix Committed
Changed in glib2.0 (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightdm - 1.5.1-0ubuntu1

---------------
lightdm (1.5.1-0ubuntu1) raring; urgency=low

  * New upstream release:
    [ 1.5.0 ]
    - Add man page for lightdm-set-defaults (LP: #1044485)
    - Use xzip for distribution, don't distribute old metadata
    - Correctly check if display is active when session quits
    - Relicense liblightdm to LGPL-2/LGPL-3 so GPL-2 code can link against it
    - Selectively lock memory rather than calling mlockall for main daemon
    [ 1.5.1 ]
    - QLightDM: Add Qt5 version of the library: liblightdm-qt5-2 (LP: #1117355)
    - QLightDM: Add some missing role names in UsersModel
    - QLightDM: Add a backgroundPath role to UsersModel
    - QLightDM: Fix potential crash in QLightDM::UsersModel closedown.
    - Improve guest session apparmor
    - Run each test in its own /tmp dir so they can't interfere with eachother
    - Fix script hooks no longer working with latest glib (LP: #1128474)
    - Fix display clean up code
  * debian/control:
    - Use standards version 3.9.4
    - Drop bzr branch
    - Build-depend on qtbase5-dev
    - Add new Qt 5 packages
  * debian/patches/08_lp1059510.patch:
  * debian/patches/09_lp577919-fix-chromium-launch.patch:
  * debian/patches/10_selective_mlock.patch:
  * debian/patches/11_runtime_dir_access.patch:
     - Applied upstream
  * debian/source/format:
    - Use 3.0
 -- Robert Ancell <email address hidden> Fri, 08 Mar 2013 11:06:52 +1300

Changed in lightdm (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments