Two processes attempt to mount blank optical discs

Bug #1069964 reported by Marco Scannadinari on 2012-10-22
412
This bug affects 108 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
glib2.0 (Ubuntu)
Low
Unassigned
unity-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

This behavior can be reproduced using either a live USB or an installed version of the effected flavors. Simply insert a blank optical disc in the drive.

The behavior differs slightly in Ubuntu GNOME as the notification to either Open with CD/DVD Creator or Eject is displayed twice - that is after simply clicking on the X to close that notification it closes but a new duplicate notification appaers immediately. The GNOME Classic session is not effected at all.

In all other effected flavors and/or desktop environments a notification appears stating "Unable to mount Blank disc. Location is already mounted". Effected flavors and DE's include Ubuntu w/Unity, gnome-session-flashback, and Ubuntu MATE.

Versions effected include Trusty, Utopic, and Vivid. I assume that two separate processes are actually attempting to mount the blank optical media, rather than just the file manager attemting to do so, because both Nautilus and Caja are effected (based on some of the comments below possibly also Nemo).

While purely cosmetic in nature I'd certainly be willing to try and troubleshoot this if someone more tech savvy would provide some debugging instructions.

Original content begins below:

This error message comes up, while still able to burn, read/write etc. It occurs in quantal when inserting a CD/DVD into the drive, but it did not happen in precice.
Screenshot:
http://i47.tinypic.com/4v0aj6.png

Burner: LG HL-DT-ST DVDRAM GH24NS90

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-settings-daemon 3.4.2-0ubuntu14
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Mon Oct 22 19:50:35 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-fallback-mount-helper
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-settings-daemon
UpgradeStatus: No upgrade log present (probably fresh install)

Marco Scannadinari (zheoffec) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Nathan Heafner (nathan1465-5) wrote :

ive been experiencing this issue for quite some time on 12.10.

gloonie (gloonie) wrote :

i also am experiencing this.

Patrick Craenen (bootpanic) wrote :

I'm also experiencing this problem on 3 different machines running Linux Mint 14. Both 32 and 64 bit releases are affected.

Pieter (stimpeh) wrote :

me too, burning multiple cd's with brasero, every new cd gives the error, brasero keeps on going none the less...

Linux Mint 14 64bit

Meowsus (tooblies) wrote :

I, too, have this issue. I'm running Ubuntu 12.10 64-bit. I can get around the issue by reinserting the blank media after I have it all ready to burn. Not a terrible workaround, but slightly annoying.

Veikko Mäkelä (veikk0.ma) wrote :

I also have this problem. While the error doesn't prevent burning, but you have to click the message to make it go away every time you insert a blank disc. It's especially annoying when burning multiple discs.

Running Linux Mint 14 64-bit.

Marco Iannaccone (m-iannaccone) wrote :

It happens with CD-R, DVD-R, DVD-RW and on so. I always experience this on both Ubuntu 12.10 and 13.04 (I only tested on 64 bit versions).

Brian Barrett (bbarrett909) wrote :

This also happens to me on 13.04 (64 bit). I don't consider it to be a huge problem, but it would be nice if it didnt happen.

Steve Davis (myglaren) wrote :

Same here, been like it for well over a year.

I have worked around it with USB dongles but have a (Windows) machine here that is virused (locked) and need to get my friend's wedding photos off it - but it destroyed two dongles.

A disc would have helped greatly - fortunately I have an 11.10 disk but a more recent one would have been preferable.

wayward4now (wayward4now) wrote :

It's now September 17, 2013
I still have this exact same problem. I can burn just fine, but I get this annoying popup that mentions that the "Location is already mounted". Running 13.04 Xubuntu. Thanks. Ric

Mike (bild85) wrote :

Upgraded from 12.04 to 13.04 last month and never saw this message before now. Also installed KDE but in Unity right now.

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
Max Barry (max-maxbarry) wrote :

I have this problem with an iPhone.

When connecting my iPhone via USB for the first time after boot, everything works fine.

But if I unplug the phone and plug it back in later, I get the effect described here: a message box pops up saying "Unable to mount Max's iPhone | Location is already mounted".

This message box cannot be closed. If I click "OK", literally nothing happens. It's like it's not even a button. If I click the "X" in the top-left corner, the button visibly depresses, but the message box doesn't close.

There are no other effects; the iPhone always mounts normally and can be navigated via the file manager.

On Ubuntu 13.10 with an iPhone 4S, but this has occurred for a very long time, maybe since 12.10.

The2ndGrim (s4eve) wrote :

I have this problem. I'm using 13.10 64-bit with Unity.

Same here. Using Trusty Tahr 64-bit.

Henry (whblakey) wrote :

This problem only started when I installed 14.04 64-Bit, not a problem when I was using 10.04 64-Bit

Same for me, currently using 14.04 64bit, but I have this bug since a LONG time ago.
And still unassigned?

tags: added: trusty ubuntu-gnome
Omadas (bsperger) wrote :

I submit that this is the same bug as Bug #1071739 with 180 bug-heat. This bug has 276 heat. Posted second here. Please mark duplicates, elevate the bug, and assign a maintainer. Thanks.

Sam Miller (sampub) wrote :

I have the same issue with Ubuntu 14.04 64bit, with the latest updates, on an Inspiron 1525 Dell laptop. In addition to the "a;ready mounted" error message, I am unable to record any DVD. Even after Brasero says the recording session is completed, the DVD remains blanc. I've tried other programs as well. As it stands now, I am unable to burn any DVDs on the Dell laptop I am using.

Erick Brunzell (lbsolost) wrote :

I'm going to ask a friend that's a whole lot smarter than I am to give this a look so I want to make a few observations.

(a) I get this in Ubuntu running Unity, Ubuntu GNOME running either GNOME Shell or GNOME Classic, and the Flashback sessions whether installed in Ubuntu or Ubuntu GNOME.

(b) I've had no problem with Brasero creating data discs or burning iso images so I think any problem with Brasero is not particularly related to this bug.

(c) I just performed a fresh install of Ubuntu Trusty using the 20140701 i386 daily image, fully updated it, and inserted a blank DVD which did reproduce this bug, but you can see from the attached screenshot that 'gnome-settings-daemon' is NOT installed in a default Ubuntu installation so this is either NOT a 'gnome-settings-daemon' bug or it also effects 'unity-settings-daemon'.

Tim Lunn (darkxst) wrote :

Unity and flashback use "unity-fallback-mount-helper" which is part of unity-settings-daemon.
gnome-shell (and classic) uses built in code that is part of the shell. That is separate code, however was probably based on the same code as the above helper when originally ported to JS.

The closest common demoninator would be the GIO Volume monitor

affects: gnome-settings-daemon (Ubuntu) → unity-settings-daemon (Ubuntu)
Tim Lunn (darkxst) wrote :

I wasn't able to reliably reproduce this however the one time I did (under Unity) I ended up with 2 "blank DVD" entries in nautilus. One had the correct burn:/// mount path and the other one was a normal /media/ mount the path for which happened to be the last ISO I had previously mounted. I think the latter is what causing the problems, the automount helpers are just doing what they are supposed to, but they are getting sent an invalid gVolume for some reason.

Perhaps this goes deeper than Glib and is actually a bug in gvfs?

Omadas (bsperger) wrote :

Running latest stable today, I can still confirm this bug, if this is a problem with gvfs, the importance should be elevated and the maintainer for that package notified, since that could be a critical issue. I dont know myself, I need someone far more experienced to take a look at this bug.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1069964

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
zzarko (zzarko-gmail) wrote :

I just made a fresh install of 14.04.1 64bit and I can confirm that the bug is present.

Howy (howy1979) on 2014-08-08
no longer affects: unity-settings-daemon
Kent Lin (kent-jclin) on 2014-08-11
Changed in oem-priority:
importance: Undecided → High
Changed in glib2.0 (Ubuntu):
importance: Undecided → Low
Erick Brunzell (lbsolost) wrote :

Also effects Ubuntu Utopic so I added the utopic tag and removed quantal tag since Quantal is EOL.

tags: added: utopic
tags: removed: quantal
Nathaniel W. Turner (nturner) wrote :

This bug is pretty embarrassing for anyone trying to show parents or friends how easy Ubuntu is to use.

Note: A workaround for the "cannot burn any .iso files" aspect of this issue (which doesn't require installing extra software) is to use wodim at the command line:

wodim foo.iso

Lee Revell (rlrevell-k) wrote :

Agree with last comment, it's a high visibility cosmetic bug that will discourage new users.

Erick Brunzell (lbsolost) wrote :

Actually a variant of this still exists in Ubuntu GNOME Vivid (as of 20150318) the difference being that, instead of getting the "already mounted" warning as you do in a flashback session, in a GNOME Shell session if you click the close button on the Open with CD/DVD creator or Eject notification as soon as it closes it pops right back up until you click it a second time.

I haven't checked the flashback session in Vivid yet but I will in the next few days. I suspect that more than one process is attempting to handle this, one being Nautilus ............. I'm clueless what the other might be.

summary: - Unable to mount Blank CD-R disc. Location is already mounted.
+ Two processes attempt to mount blank optical discs
description: updated
effell (effell) wrote :

This bug may be also impeding the rw mounting of dvd-ram discs.
(Yeah, they are still useful.)

tags: added: caja ubuntu-mate wily
Erick Brunzell (lbsolost) wrote :

This does still effect Ubuntu & Ubuntu Mate Wily as well as Debian Mate Jessie. I'll try to file a Debian bug report ASAP (it'll be my first).

Anyone that has suggestions might find my forum post useful:

http://ubuntuforums.org/showthread.php?t=2280658

The challenge is trying to figure out what process in addition to the file manager is mounting the blank media.

Tim Lunn (darkxst) wrote :

Lance,
  I think I mentioned this before, Nautilus does not handle the mounting, I don't think its some other process causing the additional mount.

Nautilus just displays the mounted gVolume's, those themeselves come from GIO Volume Monitor.
GIO Volume Monitor is basically a wrapper around the gvfs udisks2 volume monitor.

When you insert a disc, udisks2 will signal gvfs that disc was inserted, gvfs will look at the disc, add it to the volume monitor. and decide if it should be automounted (possibly with help from gio), mount it and add it to the volume monitor.

so I would guess the bug is most likely in gvfs or GIO

Erick Brunzell (lbsolost) wrote :

Hi Tim, I assume that Nautilus (or Caja in the case of Ubuntu Mate) is actually responsible for the "media already mounted" warning because if you open dconf-editor and go to "org/gnome/desktop/media-handling" (or "org/mate/desktop/media-handling") and change both "automount" and "automount-open" to false then the "media already mounted" warning goes away. The downside is that doing so interferes with mounting usb drives, cameras, etc so it's not a truly viable workaround.

The descriptions in dconf certainly mention Nautilus and Caja specifically:

If set to true, then Nautilus will automatically mount media such as user-visible hard disks and removable media on start-up and media insertion.

If set to true, then Nautilus will automatically open a folder when media is automounted. This only applies to media where no known x-content/* type was detected; for media where a known x-content type is detected, the user configurable action will be taken instead.

If set to true, then Caja will automatically mount media such as user-visible hard disks and removable media on start-up and media insertion.

If set to true, then Caja will automatically open a folder when media is automounted. This only applies to media where no known x-content/* type was detected; for media where a known x-content type is detected, the user configurable action will be taken instead.

So I really assume that some file managers (Nautilus, Caja, and possibly Nemo) attempt to mount the blank media after gvfs has already mounted it and therefore produce that warning. I'll grant you that it's only a cosmetic issue but it's certainly one of those bugs that just shouts "not ready for prime time" and sends users looking elsewhere for a reliable distro.

I'd think there'd be a way to have Nautilus and Caja just see if media is already mounted by gvfs and if so say nothing rather than displaying a useless and meaningless warning.

Since this does also effect the Mate DE I took the liberty of subscribing Martin Wimpress, so apologies in advance to Martin. My intention is not to be pushy but only to inform.

Tim Lunn (darkxst) wrote :

Probably the descriptions are a little obsolete, or otherwise gloss over the technical details the end users wont understand.

nautilus has never managed the automounts afaik, the automount helpers (i.e the auto-run actions) did live in nautilus in GNOME2, moved to gnome-settings-daemon in 3.0 and these days live within gnome-shell (Since 3.12 or something).

My best guess (and its only that causesince I could never reliably reproduce this bug and poke around with gdb), is that somehow a stale volume ends up stored (possibly due to unclean ejection of cd or just a plain leak) within the volume monitor, there is an update_mounts function in gvfs that is probably triggered by the insertion of the new CD and gvfs/GIO run through this an mount that old leaked volume. Of course it could also be a race or any other number of things, however I don't think its the filemanagers, they are just doing what they are told by the lower level software. I just don't have time to dig into this, especially when I can't reproduce.

Now if you were to poke into the GIO volume monitor, you could possibly confirm that, however afaik there is no easy way to do that other than writing code.

tags: added: rls-w-incoming
Doug McMahon (mc3man) wrote :

2 things here -
This never occurs on the 1st. insertion of blank optical media in an internal cd/dvd drive but happens on all subsequent insertions in that session

This never occurs when automount is disabled (org.gnome.desktop.media-handling

There is likely no tie in to the above 2 but does beg the question of why does gnome/gvfs connect blank media to org.gnome.desktop.media-handling automount at all?? It should have nothing to do with it & as far as usability of inserted blank media, automount 'false' has no effect. (other than prevent spurious warning

The same could/should be said for audio cd's, org.gnome.desktop.media-handling automount should not be involved. In the case of audio cd's there is an effect of automount 'false' - auto run on audio cd insertion is not possible. Again this is wrong behavior, a prompt on audio cd's or a user set action on audio cd insertion should always occur independent of org.gnome.desktop.media-handling automount true/false

tags: added: gnome-media-handling
Tim Lunn (darkxst) wrote :

Doug, blank cd's don't really get mounted (not in a filesystem sense), but are mounted to a special prefix (atelast within the volume monitor) purely so the autorun helpers can work (pop up a dialog what do you want do, launch brasero, or what not). Same would apply to audio CD's.

tags: added: rls-x-incoming
removed: rls-w-incoming

I had this problem (when inserting a blank dvd-r) on 15.10 Ubuntu 64 bit. I use Gnome-fallback-session and use Nemo file manager. I loaded up dconf-editor and searched for "mount". I deselected all of the automount features and the annoying message has gone away (for now at least).

tags: added: xenial
tags: added: gvfs
Ara Pulido (ara) on 2016-05-17
Changed in oem-priority:
status: New → Incomplete
Ara Pulido (ara) on 2016-05-19
Changed in oem-priority:
status: Incomplete → Won't Fix
tags: removed: rls-x-incoming
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers