indicator-messages-service crashed with assert in g_menu_exporter_name_vanished()

Bug #1044322 reported by Arie
146
This bug affects 29 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Critical
glib2.0 (Ubuntu)
Medium
Unassigned
Quantal
Medium
Iain Lane

Bug Description

[Test Case]
This bug is a top crasher on errors.ubuntu.com. Verify that no new instances of this bug are reported on https://errors.ubuntu.com/bucket/?id=%2Fusr%2Flib%2Findicator-messages%2Findicator-messages-service%3A6%3Ag_assertion_message%3Ag_assertion_message_expr%3Ag_menu_exporter_name_vanished%3Ag_menu_exporter_name_vanished%3Ado_call with the new version.

no details available

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: indicator-messages 12.10.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
ApportVersion: 2.5.1-0ubuntu4
Architecture: amd64
Date: Fri Aug 31 12:56:04 2012
ExecutablePath: /usr/lib/indicator-messages/indicator-messages-service
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120213)
ProcCmdline: /usr/lib/indicator-messages/indicator-messages-service
Signal: 6
SourcePackage: indicator-messages
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: indicator-messages-service crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Arie (boerties) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceTop.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in indicator-messages (Ubuntu):
importance: Undecided → Medium
summary: - indicator-messages-service crashed with SIGABRT in raise()
+ indicator-messages-service crashed with SIGABRT in g_assertion_message()
tags: removed: need-amd64-retrace
visibility: private → public
Lars Karlitski (larsu)
Changed in indicator-messages:
assignee: nobody → Lars Uebernickel (larsu)
milestone: none → 12.10.3
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: indicator-messages-service crashed with SIGABRT in g_assertion_message()

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Changed in indicator-messages:
status: New → Confirmed
importance: Undecided → Medium
Lars Karlitski (larsu)
Changed in indicator-messages:
milestone: 12.10.3 → 12.10.4
Lars Karlitski (larsu)
Changed in indicator-messages:
milestone: 12.10.4 → none
Revision history for this message
Ademir Giraldelli (ademireagiraldelli) wrote :

It happens only after boot

Revision history for this message
Michael Terry (mterry) wrote :

This crash seems completely internal to glib. It's because of an assert that an internal callback is called with the same connection it was started with.

I don't see another bug about this to dup, so I'm switching tasks to glib.

affects: indicator-messages (Ubuntu) → glib2.0 (Ubuntu)
affects: indicator-messages → glib
Changed in glib:
assignee: Lars Uebernickel (larsu) → nobody
importance: Medium → Unknown
status: Confirmed → Unknown
summary: - indicator-messages-service crashed with SIGABRT in g_assertion_message()
+ indicator-messages-service crashed with assert in
+ g_menu_exporter_name_vanished()
Changed in glib:
importance: Unknown → Medium
status: Unknown → New
Changed in glib:
importance: Medium → Critical
Revision history for this message
desrt (desrt) wrote :
Changed in glib:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.34.1-1

---------------
glib2.0 (2.34.1-1) experimental; urgency=low

  [ Josselin Mouette ]
  * Require libelfg0-dev, not libelf-dev which has nothing to do with
    it.

  [ Iain Lane ]
  * New upstream release
    + GTimeZone support for zoneinfo version 1
    + Leak in glib-compile-resources
    + g_settings_bind: use canonical property name
    + Port gio tests from pygobject to pygi
  * Switch python-gobject-2 BD to python-gi, folowing porting of tests.
  * debian/patches/50_git_gmenuexporter_allow_null_bus_on_name_vanished.patch:
    Cherry-pick upstream patch to fix crash when GBusNameVanishedCallback is
    called with a NULL GDBusConnection. (LP: #1044322)

 -- Iain Lane <email address hidden> Wed, 17 Oct 2012 11:51:14 +0100

Changed in glib2.0 (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

This bug is missing an SRU test case. Note that this is not covered by the GNOME MRE, because this change isn't part of the upstream release.

Changed in glib2.0 (Ubuntu Quantal):
status: New → In Progress
importance: Undecided → Medium
Steve Langasek (vorlon)
Changed in glib2.0 (Ubuntu Quantal):
assignee: nobody → Iain Lane (laney)
status: In Progress → Incomplete
Revision history for this message
Steve Langasek (vorlon) wrote : Please test proposed package

Hello Arie, or anyone else affected,

Accepted glib2.0 into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/glib2.0/2.34.1-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in glib2.0 (Ubuntu Quantal):
status: Incomplete → Fix Committed
tags: added: verification-needed
description: updated
Revision history for this message
Steve Langasek (vorlon) wrote :

Unfortunately, I've just noticed the errors.u.c entry reports against the indicator-messages package, and not against glib2.0; this means we can't easily verify that the crashes have stopped with the new version of glib2.0. Can someone please provide a reproducible test case?

Revision history for this message
Iain Lane (laney) wrote :

This becomes more urgent to release now that banshee was accidently released into quantal-updates with a dependency on this newer glib.

I checked a lot of reports on the linked e.u.c page and none had the proposed glib installed. Given the sheer number though, and the absence of any way to programatically query the error tracker, I can only hope to look at a tiny fraction manually.

I'll call this v-done and someone on the SRU team can disagree and do something else (remove) about banshee if they like.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Colin Watson (cjwatson) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.34.1-1ubuntu1

---------------
glib2.0 (2.34.1-1ubuntu1) quantal-proposed; urgency=low

  * Rebase on Debian experimental. (LP: #1067763)
  * Add back 91_revert_pcre_8.31_test.patch and lower the pcre dependency back
    to >= 8.30. This needs to be kept until we get pcre 8.31 into Ubuntu.
  * Restore dependency on libelf-dev. Following Debian entails a dependency on
    libelfg0 which will break multi-arch glib as this library is not
    multi-arched yet.

glib2.0 (2.34.1-1) experimental; urgency=low

  [ Josselin Mouette ]
  * Require libelfg0-dev, not libelf-dev which has nothing to do with
    it.

  [ Iain Lane ]
  * New upstream release
    + GTimeZone support for zoneinfo version 1
    + Leak in glib-compile-resources
    + g_settings_bind: use canonical property name
    + Port gio tests from pygobject to pygi
  * Switch python-gobject-2 BD to python-gi, folowing porting of tests.
  * debian/patches/50_git_gmenuexporter_allow_null_bus_on_name_vanished.patch:
    Cherry-pick upstream patch to fix crash when GBusNameVanishedCallback is
    called with a NULL GDBusConnection. (LP: #1044322)
 -- Iain Lane <email address hidden> Wed, 17 Oct 2012 15:47:20 +0100

Changed in glib2.0 (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.