https://bugs.launchpad.net/ubuntu/+source/glib-networking/+bug/1873777

Bug #1882636 reported by Marcus Urso-Bernick
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glib-networking (Ubuntu)
Invalid
Low
Unassigned

Bug Description

OS: Pop!_OS 20.04 LTS x86_64
Host: XPS 13 9370
Kernel: 5.4.0-7634-generic
Uptime: 2 hours, 50 mins
Packages: 1817 (dpkg), 20 (snap)
Shell: bash 5.0.16
Resolution: 1920x1080
DE: GNOME
WM: Mutter
WM Theme: Pop
Theme: Pop-dark [GTK2/3]
Icons: Pop [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i5-8250U (8) @ 3.400GHz
GPU: Intel UHD Graphics 620
Memory: 3322MiB / 15729MiB

Summary(cont) - Attempt to input Google account info into online account util and get error--> TLS/SSL support not available; install glib-networking.

<Tag> https://bugs.launchpad.net/ubuntu/+source/glib-networking/+bug/1873777<Tag/>
Referenced this BUG REPORT

##Downloaded Deb build but I'm having an issue applying appropriate inputs in the provided documentation. Please help!##

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and help make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read 'How to report bugs effectively' http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).

Thanks!

Changed in glib-networking (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

glib-networking is installed by default on Ubuntu, if the issue is that it was missing for you then you should report it to the popOS team and not on launchpad

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

Glib-networking is installed I'm getting an error that it's not installed from the accounts app in settings

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

I'll follow up after work tonight work more specifics

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

So I'm following up after a long time away from my laptop. I'm currently experiencing an error which says: TLS/SSL support not available; install glib-networking. I'm not sure why this is happening but I'm willing to poke around if you are able to help me. I"m hoping together we can ID the cause. I'm sorry to say that I haven't been willing to even open my laptop because of this issue.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Could you add the 'journalctl -b 0' log from the system after getting the error?

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

No problem, I'm away from my laptop now but will be able to send you`journalctl -b 0` by 2230 UTC

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

Jul 07 00:08:37 betty io.elementary.a[3348]: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 17
Jul 07 00:08:40 betty io.elementary.a[3348]: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 17
Jul 07 00:08:41 betty gnome-shell[1966]: pop-shell: [INFO] making above
Jul 07 00:08:41 betty gnome-shell[1966]: pop-shell: [DEBUG] xprop -id 0x2a07177 _MOTIF_WM_HINTS
Jul 07 00:08:41 betty gnome-shell[1966]: pop-shell: [DEBUG] _MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x2, 0x0, 0x0, 0x0, 0x0
Jul 07 00:08:41 betty WebKitWebProces[6490]: Failed to load module "appmenu-gtk-module"
Jul 07 00:08:48 betty systemd[1669]: Started VTE child process 6523 launched by gnome-terminal-server process 2448.
Jul 07 00:10:38 betty systemd[1669]: Started VTE child process 6538 launched by gnome-terminal-server process 2448.
Jul 07 00:10:44 betty gnome-shell[1966]: pop-shell: [INFO] making above
Jul 07 00:10:44 betty gnome-shell[1966]: pop-shell: [DEBUG] xprop -id 0x2a07177 _MOTIF_WM_HINTS
Jul 07 00:10:44 betty gnome-shell[1966]: pop-shell: [DEBUG] _MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x2, 0x0, 0x0, 0x0, 0x0
Jul 07 00:10:44 betty WebKitWebProces[6547]: Failed to load module "appmenu-gtk-module"
Jul 07 00:10:56 betty geoclue[1460]: Failed to query location: TLS/SSL support not available; install glib-networking

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

I have a better log file which I have compressed with zip but dont feel comfortable printing it to this bug page. Do you mind if I send it to your email?

Revision history for this message
Sebastien Bacher (seb128) wrote :

email is alright, but the log there seems to have useful information

geoclue[1460]: Failed to query location: TLS/SSL support not available; install glib-networking

what's the output of

$ dpkg -l | grep glib-networking ?

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

emms@betty:~$ dpkg -l | grep glib-networking
ii glib-networking:amd64 2.64.2-1ubuntu0.1 amd64 network-related giomodules for GLib
ii glib-networking-common 2.64.2-1ubuntu0.1 all network-related giomodules for GLib - data files
ii glib-networking-services 2.64.2-1ubuntu0.1 amd64 network-related giomodules for GLib - D-Bus services
ii glib-networking-tests 2.64.2-1ubuntu0.1 amd64 network-related giomodules for GLib - installed tests

Revision history for this message
Sebastien Bacher (seb128) wrote :

Weird, unsure what's wrong but you should report the issue to the distribution you are using (PopOS)

Changed in glib-networking (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers