Update to 2.64.2

Bug #1873777 reported by Sebastien Bacher
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
glib-networking (Ubuntu)
High
Unassigned
Focal
High
Unassigned

Bug Description

* Impact
That's the current GNOME stable update, including some fixes
https://gitlab.gnome.org/GNOME/glib-networking/-/blob/master/NEWS

* Test case

The update is part of GNOME stable updates
https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

Check that GNOME web still works correctly

* Regression potential

The update restore the TLS 1.0/1.1 protocols due to COVID-19, try to browse one of those websites from the GNOME browser

Changed in glib-networking (Ubuntu):
importance: Undecided → High
status: New → Confirmed
status: Confirmed → In Progress
Revision history for this message
Sebastien Bacher (seb128) wrote :

The update has been synced to g-serie now

description: updated
Changed in glib-networking (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote :

How is TLS1.0/1.1 related to Covid-19? I didn't see any explanation upstream.

Changed in glib-networking (Ubuntu Focal):
status: New → Incomplete
Revision history for this message
Chris Halse Rogers (raof) wrote :

The same reason that Mozilla, Google, and Microsoft reverted disabling TLS 1.0/1.1: government websites which don't support TLS 1.2 (see also: https://www.mozilla.org/en-US/firefox/74.0/releasenotes/)

Changed in glib-networking (Ubuntu Focal):
status: Incomplete → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Sebastien, or anyone else affected,

Accepted glib-networking into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/glib-networking/2.64.2-1build1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Mathew Hodson (mhodson)
tags: added: upgrade-software-version
Changed in glib-networking (Ubuntu Focal):
importance: Undecided → High
Revision history for this message
Sebastien Bacher (seb128) wrote :

Using 2.64.2-1build1 it works without issue, epiphany-broser loads webpage as expected, the desktop work without issue including connectivity checking, marking as verified

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib-networking - 2.64.2-1build1

---------------
glib-networking (2.64.2-1build1) focal; urgency=medium

  * New upstream release, reenable TLS 1.0/1.1 protocols due to COVID-19
    Upload to Ubuntu as build1 revision to include a bug reference
    (lp: #1873777)

 -- Sebastien Bacher <email address hidden> Mon, 20 Apr 2020 12:17:36 +0200

Changed in glib-networking (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for glib-networking has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

I need help!!! I'm trying to build this repair but having a hard time running the build. I'm not very good at building from the provided fix. Please help.

Revision history for this message
Marcus Urso-Bernick (emmdeeyoo) wrote :

Jul 07 00:08:37 betty io.elementary.a[3348]: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 17
Jul 07 00:08:40 betty io.elementary.a[3348]: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 17
Jul 07 00:08:41 betty gnome-shell[1966]: pop-shell: [INFO] making above
Jul 07 00:08:41 betty gnome-shell[1966]: pop-shell: [DEBUG] xprop -id 0x2a07177 _MOTIF_WM_HINTS
Jul 07 00:08:41 betty gnome-shell[1966]: pop-shell: [DEBUG] _MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x2, 0x0, 0x0, 0x0, 0x0
Jul 07 00:08:41 betty WebKitWebProces[6490]: Failed to load module "appmenu-gtk-module"
Jul 07 00:08:48 betty systemd[1669]: Started VTE child process 6523 launched by gnome-terminal-server process 2448.
Jul 07 00:10:38 betty systemd[1669]: Started VTE child process 6538 launched by gnome-terminal-server process 2448.
Jul 07 00:10:44 betty gnome-shell[1966]: pop-shell: [INFO] making above
Jul 07 00:10:44 betty gnome-shell[1966]: pop-shell: [DEBUG] xprop -id 0x2a07177 _MOTIF_WM_HINTS
Jul 07 00:10:44 betty gnome-shell[1966]: pop-shell: [DEBUG] _MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x2, 0x0, 0x0, 0x0, 0x0
Jul 07 00:10:44 betty WebKitWebProces[6547]: Failed to load module "appmenu-gtk-module"
Jul 07 00:10:56 betty geoclue[1460]: Failed to query location: TLS/SSL support not available; install glib-networking

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers