glew 1.7.0 transition

Bug #930111 reported by Alessio Treglia on 2012-02-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
avogadro (Ubuntu)
Undecided
Philip Muškovac
calligra (Ubuntu)
Undecided
Philip Muškovac
glew (Debian)
Fix Released
Unknown
glew (Ubuntu)
Wishlist
Unassigned
kalzium (Ubuntu)
Undecided
Philip Muškovac

Bug Description

After almost two months in experimental, the new upstream stable release of glew has now joined Debian unstable.
The changelog follows:

1.7.0 [08-26-11]
        New features:
- Support for OpenGL 4.2

        New extensions:
- GL_AMD_multi_draw_indirect
- GL_ARB_base_instance
- GL_ARB_compressed_texture_pixel_storage
- GL_ARB_conservative_depth
- GL_ARB_internalformat_query
- GL_ARB_map_buffer_alignment
- GL_ARB_shader_atomic_counters
- GL_ARB_shader_image_load_store
- GL_ARB_shading_language_420pack
- GL_ARB_shading_language_packing
- GL_ARB_texture_storage
- GL_ARB_transform_feedback_instanced
- GL_EXT_framebuffer_multisample_blit_scaled
- GL_NV_path_rendering
- GL_NV_path_rendering
- GLX_MESA_swap_control

        Bug fixes:
- const qualifiers for GL 1.4 MultiDrawArrays, MultiDrawElements
- Add glGetGraphicsResetStatusARB to GL_ARB_robustness
- Remove EXT suffix from GL_KTX_buffer_region entry points
- Solaris needs inttypes.h
- Add ERROR_INVALID_VERSION_ARB and ERROR_INVALID_PROFILE_ARB to WGL_ARB_create_context
- Add GLX_MESA_swap_control
- Set -install_name for OSX
- Add 64-bit darwin build option (SYSTEM=darwin_x86-64)
- Add GL_NV_path_rendering

Since there is no API/ABI breakage, I would like to start merging those changes into Ubuntu Precise prior to enter FF and use this report to track the status of the rebuilds.
Dear release managers, what do you think about this?

(Please note that the same transition's going on in Debian too.)

Changed in glew (Ubuntu):
importance: Undecided → Wishlist
Changed in glew (Debian):
status: Unknown → Fix Committed
Alessio Treglia (quadrispro) wrote :

I've been marking the other affected packages, but stopped at avogadro because I'd like to get a feedback from the release team before going on.

Martin Pitt (pitti) wrote :

It would be great if you could try a local build with current nux/unity. We should avoid knowingly breaking precise with this transition. Otherwise, no objections from me.

Changed in glew (Debian):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in avogadro (Ubuntu):
status: New → Confirmed
Changed in glew (Ubuntu):
status: New → Confirmed
Stefano Rivera (stefanor) wrote :

Do you still have any intentoin of doing this?

Alessio Treglia (quadrispro) wrote :

Hi guys,

sorry for the terrific delay.

Now that Precise is out I think we could start this transition. However I'll wait for other opinions before going ahead.

Changed in glew (Ubuntu):
status: Confirmed → Fix Released
Philip Muškovac (yofel) on 2012-05-20
Changed in avogadro (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
Changed in kalzium (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avogadro - 1.0.3-1ubuntu5

---------------
avogadro (1.0.3-1ubuntu5) quantal; urgency=low

  * Use libglew-dev instead of libglew1.5-dev as build-dep for glew 1.7
    (LP: #930111)
  * Make libavogadro-dev depend on libglew-dev as it's required by the cmake
    config file.
  * Explicitely build-depend on libboost-python1.46-dev as current avogadro
    doesn't build against boost 1.49
  * Don't use simple-patchsys.mk in rules, it's deprecated
 -- Philip Muskovac <email address hidden> Sun, 20 May 2012 18:30:23 +0200

Changed in avogadro (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package kalzium - 4:4.8.2-0ubuntu2

---------------
kalzium (4:4.8.2-0ubuntu2) quantal; urgency=low

  * Drop libglew1.5-dev from build-depends and instead build-depend on
    libavogadro-dev >= 1.0.3-1ubuntu5 (LP: #930111)
  * Switch libboost-python build-dep to 1.49
 -- Philip Muskovac <email address hidden> Sun, 20 May 2012 12:33:02 +0200

Changed in kalzium (Ubuntu):
status: New → Fix Released
Philip Muškovac (yofel) on 2012-06-08
Changed in calligra (Ubuntu):
assignee: nobody → Philip Muškovac (yofel)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package calligra - 1:2.4.90-0ubuntu1

---------------
calligra (1:2.4.90-0ubuntu1) quantal; urgency=low

  * Merge with debian unstable (LP: #930111), remaining changes:
    - calligra-libs suggests, not recommends fonts-lyx (universe)
    - enable calligraactive and calligra-dev packages
    - calligra recommends create-resources

  * New upstream alpha release (LP: #1009159)
    - add libwps-dev and libqtgtl-dev to build-depends
    - drop DIHAVEPATCHEDQT=true, not needed anymore now that we have Qt 4.8.2
    - cherry pick upstream commits 47f4796e2f5d3524646237387b08b362c2bd6bc8,
      8acefd1ce11ee5c39d02ca47569d416f98b3d161 and
      5f8b61514e71ac6964ae01bd0007646f1bf821db as marble_buildfix.diff
      to fix compilation with marble.
    - drop kthesaurus, calligra-map-shape and calligramobile packages,
      removed upstream
    - update install files (mostly dropping removed plugins)
 -- Philip Muskovac <email address hidden> Thu, 07 Jun 2012 18:05:24 +0200

Changed in calligra (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.