Glance missing dependency: python-routes python-eventlet python-sqlalchemy python-migrate

Bug #899970 reported by Francisco Gimeno on 2011-12-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
glance (Ubuntu)
High
Adam Gandelman

Bug Description

The problem is that python-routes dependency has been forgotten.
----

Configurando glance (2012.1~e2~20111201.1123-0ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/glance-manage", line 47, in <module>
    import glance.registry.db
  File "/usr/lib/python2.7/dist-packages/glance/registry/__init__.py", line 26, in <module>
    from glance.registry import client
  File "/usr/lib/python2.7/dist-packages/glance/registry/client.py", line 28, in <module>
    from glance.registry.api.v1 import images
  File "/usr/lib/python2.7/dist-packages/glance/registry/api/v1/__init__.py", line 18, in <module>
    import routes
ImportError: No module named routes
dpkg: error al procesar glance (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1
-----
After installing "python-routes":
-----
Configurando glance (2012.1~e2~20111201.1123-0ubuntu1) ...
Traceback (most recent call last):
  File "/usr/bin/glance-manage", line 47, in <module>
    import glance.registry.db
  File "/usr/lib/python2.7/dist-packages/glance/registry/__init__.py", line 26, in <module>
    from glance.registry import client
  File "/usr/lib/python2.7/dist-packages/glance/registry/client.py", line 28, in <module>
    from glance.registry.api.v1 import images
  File "/usr/lib/python2.7/dist-packages/glance/registry/api/v1/__init__.py", line 20, in <module>
    from glance.registry.api.v1 import images
  File "/usr/lib/python2.7/dist-packages/glance/registry/api/v1/images.py", line 28, in <module>
    from glance.common import wsgi
  File "/usr/lib/python2.7/dist-packages/glance/common/wsgi.py", line 31, in <module>
    import eventlet
ImportError: No module named eventlet
dpkg: error al procesar glance (--configure):
 el subproceso instalado el script post-installation devolvió el código de salida de error 1
Se encontraron errores al procesar:
 glance
-----
After installing "python-eventlet", then "python-migrate"...

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: glance 2012.1~e2~20111201.1123-0ubuntu1
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic-pae 3.1.0
Uname: Linux 3.1.0-2-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.90-0ubuntu1
Architecture: i386
CheckboxSubmission: b5976ec70cedde5d3d7e18f32f4be3db
CheckboxSystem: ed86e29ffba809c116a39e33fa9fc45c
Date: Sun Dec 4 14:44:59 2011
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=es_DO.UTF-8
 SHELL=/bin/bash
SourcePackage: glance
UpgradeStatus: Upgraded to precise on 2010-06-12 (540 days ago)
modified.conffile..etc.glance.glance.api.conf: [deleted]
modified.conffile..etc.glance.glance.cache.conf: [deleted]
modified.conffile..etc.glance.glance.registry.conf: [deleted]
modified.conffile..etc.glance.glance.scrubber.conf: [deleted]
modified.conffile..etc.glance.logging.cnf.sample: [deleted]

Related branches

Francisco Gimeno (kikov79) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glance (Ubuntu):
status: New → Confirmed
summary: - Missing dependency: python-routes python-eventlet python-sqlalchemy
- python-migrate
+ Glance missing dependency: python-routes python-eventlet python-
+ sqlalchemy python-migrate
Changed in glance (Ubuntu):
assignee: nobody → Adam Gandelman (gandelman-a)
status: Confirmed → In Progress
Changed in glance (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glance - 2012.1~e2~20111201.1123-0ubuntu2

---------------
glance (2012.1~e2~20111201.1123-0ubuntu2) precise; urgency=low

  * debian/control: Add dependencies previously removed from python-glance
    to glance package where they are actually required. (LP: #899970)
 -- Adam Gandelman <email address hidden> Mon, 05 Dec 2011 15:10:04 +0100

Changed in glance (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers