package glance-registry 2012.1.3+stable~20120821-120fcf-0ubuntu1 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 1

Bug #1049305 reported by Guilherme Russi on 2012-09-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glance (Ubuntu)
High
Unassigned

Bug Description

When I try to install glance an error is returned to me, I've looked out through the internet but haven't found anything. Anyone can help me?

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: glance-registry 2012.1.3+stable~20120821-120fcf-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Tue Sep 11 15:34:31 2012
ErrorMessage: sub-processo script post-installation instalado retornou estado de saída de erro 1
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
SourcePackage: glance
Title: package glance-registry 2012.1.3+stable~20120821-120fcf-0ubuntu1 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 1
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Walker (davewalker) on 2012-09-12
Changed in glance (Ubuntu):
importance: Undecided → High
Adam Gandelman (gandelman-a) wrote :

Hi Guilherme-

Thanks for taking the time to report this. I'm having a difficult time reproducing this. I can't seem to trigger any migration error when installing any of the glance packages that have been mentioned in this report. I'm curious, was this being installed on a fresh system, or had there been a previous installation of glance running there? I'm mostly curious to know if there was already some sqlite database sitting in /var/lib/glance/glance.sqlite from an existing or previous installation.

If you did not have a glance-registry server on this system, you can try:

$ apt-get remove --purge glance-registry
$ mv /var/lib/glance/glance.sqlite /var/lib/glance/glance.sqlite.old
$ apt-get install glance-registry

Hope that helps,
Adam

Hey Adam,

 Thank you for returning, I've been trying to install in a fresh system. I've tried the commands you sent me, and i'm still getting the same error.

Regards.

Guilherme.

James Page (james-page) wrote :

I'm unable to reproduce this problem either; as this bug has not be progressed for at least 12 months, marking as incomplete; its probably some sort of local configuration issue, but we have not had any duplicates.

Changed in glance (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for glance (Ubuntu) because there has been no activity for 60 days.]

Changed in glance (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers