glade crashed with signal 5 in _gdk_x11_display_error_event()

Bug #823506 reported by Michael Terry on 2011-08-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glade (Ubuntu)
Undecided
Unassigned

Bug Description

This reliably happens when running glade on the attached .ui file.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: glade 3.10.0-3ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
Architecture: i386
Date: Tue Aug 9 15:20:44 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/glade
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110422)
ProcCmdline: glade ./gui/gtk/ubiquity.ui
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
Signal: 5
SourcePackage: glade
StacktraceTop:
 _gdk_x11_display_error_event (display=0x940a000, error=0xbfdfb9ec) at /build/buildd/gtk+3.0-3.1.10/./gdk/x11/gdkdisplay-x11.c:2374
 gdk_x_error (error=0xbfdfb9ec, xdisplay=0x93ff1f0) at /build/buildd/gtk+3.0-3.1.10/./gdk/x11/gdkmain-x11.c:312
 gdk_x_error (xdisplay=0x93ff1f0, error=0xbfdfb9ec) at /build/buildd/gtk+3.0-3.1.10/./gdk/x11/gdkmain-x11.c:275
 _XError () from /usr/lib/i386-linux-gnu/libX11.so.6
 ?? () from /usr/lib/i386-linux-gnu/libX11.so.6
Title: glade crashed with signal 5 in _gdk_x11_display_error_event()
UpgradeStatus: Upgraded to oneiric on 2011-07-27 (13 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

Michael Terry (mterry) wrote :
visibility: private → public

StacktraceTop:
 g_log_default_handler (log_domain=0x7fa3c0 "", log_level=-1075858200, message=0x70b4d9 "E\334\203}\340\377\017EE\340\211E\340\351\035\377\377\377\220\215t&", unused_data=0x48) at /build/buildd/glib2.0-2.29.16/./glib/gmessages.c:994
 ?? ()

Changed in glade (Ubuntu):
status: New → Invalid
Download full text (4.8 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1 version 1:4.6.1-6ubuntu2 required, but 1:4.6.1-7ubuntu2 is available
outdated debug symbol package for libavahi-common3: package version 0.6.30-4ubuntu1 dbgsym version 0.6.30-0ubuntu2
libglapi-mesa version 7.11-0ubuntu2 required, but 7.11-0ubuntu3 is available
outdated debug symbol package for libtiff4: package version 3.9.5-1ubuntu1 dbgsym version 3.9.4-5ubuntu6
python2.7 version 2.7.2-4 required, but 2.7.2-5 is available
libx11-xcb1 version 2:1.4.3-2ubuntu1 required, but 2:1.4.4-1ubuntu1 is available
fontconfig version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
outdated debug symbol package for dpkg: package version 1.16.0.3ubuntu3 dbgsym version 1.16.0~ubuntu7.1
libjpeg62 version 6b1-1ubuntu1 required, but 6b1-1ubuntu2 is available
libgtk-3-common version 3.1.10-0ubuntu2 required, but 3.1.12-0ubuntu1 is available
outdated debug symbol package for libgpg-error0: package version 1.10-0.3ubuntu1 dbgsym version 1.10-0.2ubuntu1
libfontconfig1 version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
libssl1.0.0 version 1.0.0d-2ubuntu1 required, but 1.0.0d-2ubuntu2 is available
outdated debug symbol package for libk5crypto3: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
libpng12-0 version 1.2.44-2ubuntu1 required, but 1.2.46-3ubuntu1 is available
python2.7-minimal version 2.7.2-4 required, but 2.7.2-5 is available
libudev0 version 172-0ubuntu5 required, but 173-0ubuntu3 is available
outdated debug symbol package for libavahi-client3: package version 0.6.30-4ubuntu1 dbgsym version 0.6.30-0ubuntu2
outdated debug symbol package for libkrb5-3: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
libllvm2.9 version 2.9+dfsg-3ubuntu1 required, but 2.9+dfsg-3ubuntu2 is available
outdated debug symbol package for libdatrie1: package version 0.2.4-3 dbgsym version 0.2.4-1
outdated debug symbol package for glade: package version 3.10.0-3ubuntu1 dbgsym version 3.8.0-0ubuntu1
libcairo-gobject2 version 1.10.2-6ubuntu2 required, but 1.10.2-6ubuntu3 is available
libglib2.0-0 version 2.29.14-0ubuntu1 required, but 2.29.16-0ubuntu2 is available
outdated debug symbol package for libdbus-1-3: package version 1.4.12-4ubuntu2 dbgsym version 1.4.6-1ubuntu6.1
libcups2 version 1.5.0-1 required, but 1.5.0-5 is available
libc-bin version 2.13-9ubuntu3 required, but 2.13-17ubuntu2 is available
libffi6 version 3.0.10~rc8-6 required, but 3.0.11~rc1-1 is available
libcairo2 version 1.10.2-6ubuntu2 required, but 1.10.2-6ubuntu3 is available
libgbm1 version 7.11-0ubuntu2 required, but 7.11-0ubuntu3 is available
gcc-4.6-base version 4.6.1-6ubuntu2 required, but 4.6.1-7ubuntu2 is available
outdated debug symbol package for libgssapi-krb5-2: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
ttf-dejavu-core version 2.33-1 required, but 2.33-1ubuntu1 is available
libx11-data version 2:1.4.3-2ubuntu1 require...

Read more...

tags: removed: need-i386-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers