Glade is out of date on Ubuntu Dapper - please update to 3.0.2

Bug #60538 reported by Mantas Kriaučiūnas on 2006-09-15
4
Affects Status Importance Assigned to Milestone
Dapper Backports
Undecided
Unassigned
Baltix
Medium
Mantas Kriaučiūnas
glade (Ubuntu)
Undecided
Unassigned

Bug Description

Glade is out of date on Ubuntu Dapper - Glade 3.0 was released several month ago !

Get it at http://ftp.gnome.org/pub/GNOME/sources/glade3/3.0/

From changelog:

3.0.1 is a follow up bugfix release to 3.0 and includes alot of misc fixes.

New features and fixes:

    * Pasting a widget does not paste the packing options (bug 345604) (Juan Pablo Ugarte)
    * Now you can paste widgets to your hearts content (bug 345603)
    * Fixed expander widgets (they were missing placeholders).
    * Adjustments are saved without floating point precision in the glade file (reports of glade-- code generator disliking the decimal points).
    * Fixed an embarrassing segfault when removing items using the menu/toolbar editor (Juan Pablo)
    * Interface signals are now properly introspected + alphabetically sorted (Juan Pablo)
    * Removed some properties on children internal to composite widgets, properties that we're controlled by style properties on the GtkDialog widget (bug 352018).
    * Enhancements to the "Projects" menu + minor UI enhancements (Vincent Geddes)
    * Palette items can be locked down with CNTL-click matching glade-2 behaviour (bug 303679)

     Aug 11 2006 Glade 3.0 released !

NOTE - Glade 3.0 Requires GTK+ 2.8 and libxml2, Glade 3.0 will expose properties, signals and widgets from GTK+ 2.8, remember that you need an up to date version of GTK+ to support those widgets.

Here is an overview of the changes made since the last development snapshot:

    * DevHelp integration for a contextual help system
    * GnomeUI and GnomeCanvas plugin (Juan Pablo Ugarte)
    * New "Editor skeleton" provided by the core to ease the plugin's creation of custom editors for toolbars and menus and such. (Juan Pablo Ugarte)
    * Toolbar and popup menu support (Juan Pablo Ugarte)
    * Added accelerators property dialog
    * Drag/Resize support extended to GtkTable and GtkBox subclasses (and GnomeCanvas) from only GtkFixed and GtkLayout.
    * Reverted "View" menu to match the Glade 2 style (Yevgen Muntyan)
    * Now glade has 2 icon sets (16x16 & 22x22), all icons available (Vincent Geddes)
    * New awesome palette (Vincent Geddes)
    * Cute cursor when adding widgets (Vincent Geddes)
    * General UI enhancements and desktop integration work (Vincent Geddes)
    * Duplicated widgets id's are unique (Yevgen Muntyan)
    * Spelling mistake fixes from Thierry Moisan and Clytie Siddall
    * Many Many Many misc fixes by Juan Pablo Ugarte, Vincent Geddes, Yevgen Muntyan and myself.
    * Much core/gtk+ backend refactoring done by Juan Pablo and myself.

Mantas Kriaučiūnas (mantas) wrote :

Btw, Glade 3.0.1 is in Debian experimental already - I think it would be wise to test it and put into Baltix GNU/Linux 2.0

Sebastien Bacher (seb128) wrote :

glade-3 is available to edgy for almost one month now, install the glade-gnome-3 or glade-3 package for universe

Changed in glade:
status: Unconfirmed → Fix Released
description: updated
zenrox (kergan) wrote :

 -> Considering dpkg-dev (>= 1.13.19)
      Tried versions: 1.13.11ubuntu6
   -> Does not satisfy version, not trying
E: Could not satisfy build-dependency.
Copying back the cached apt archive contents
 -> unmounting dev/pts filesystem
 -> unmounting proc filesystem
 -> unmounting /var/cache/prevu/dapper-debs filesystem
 -> unmounting /var/cache/prevu/src/17186 filesystem
 -> cleaning the build env
    -> removing directory /var/cache/prevu/builds/17293 and its subdirectories
Traceback (most recent call last):
  File "/usr/bin/prevu", line 142, in ?
    BackportFromAPT(sys.argv[1],DIST).backport()
  File "/usr/bin/prevu", line 82, in backport
    self.do_compile()
  File "/usr/bin/prevu", line 67, in do_compile
    raise ValueError("Build failed.")
ValueError: Build failed.

Changed in dapper-backports:
status: Unconfirmed → Rejected

I tried to update it but it tells me that the archive doesn't support it. What do I do know?

----- Original Message ----
From: zenrox <email address hidden>
To: <email address hidden>
Sent: Wednesday, November 8, 2006 8:57:55 PM
Subject: [Bug 60538] Re: Glade is out of date on Ubuntu Dapper - please update to 3.0.2

 -> Considering dpkg-dev (>= 1.13.19)
      Tried versions: 1.13.11ubuntu6
   -> Does not satisfy version, not trying
E: Could not satisfy build-dependency.
Copying back the cached apt archive contents
 -> unmounting dev/pts filesystem
 -> unmounting proc filesystem
 -> unmounting /var/cache/prevu/dapper-debs filesystem
 -> unmounting /var/cache/prevu/src/17186 filesystem
 -> cleaning the build env
    -> removing directory /var/cache/prevu/builds/17293 and its subdirectories
Traceback (most recent call last):
  File "/usr/bin/prevu", line 142, in ?
    BackportFromAPT(sys.argv[1],DIST).backport()
  File "/usr/bin/prevu", line 82, in backport
    self.do_compile()
  File "/usr/bin/prevu", line 67, in do_compile
    raise ValueError("Build failed.")
ValueError: Build failed.

** Changed in: dapper-backports (upstream)
       Status: Unconfirmed => Rejected

--
Glade is out of date on Ubuntu Dapper - please update to 3.0.2
https://launchpad.net/bugs/60538

--
desktop-bugs mailing list
<email address hidden>
https://lists.ubuntu.com/mailman/listinfo/desktop-bugs

zenrox (kergan) wrote :

its related to the newer dpkg python central installers thats is in edgy

On 11/8/06, Paul Padilla <email address hidden> wrote:
> I tried to update it but it tells me that the archive doesn't support
> it. What do I do know?
>
> ----- Original Message ----
> From: zenrox <email address hidden>
> To: <email address hidden>
> Sent: Wednesday, November 8, 2006 8:57:55 PM
> Subject: [Bug 60538] Re: Glade is out of date on Ubuntu Dapper - please update to 3.0.2
>
> -> Considering dpkg-dev (>= 1.13.19)
> Tried versions: 1.13.11ubuntu6
> -> Does not satisfy version, not trying
> E: Could not satisfy build-dependency.
> Copying back the cached apt archive contents
> -> unmounting dev/pts filesystem
> -> unmounting proc filesystem
> -> unmounting /var/cache/prevu/dapper-debs filesystem
> -> unmounting /var/cache/prevu/src/17186 filesystem
> -> cleaning the build env
> -> removing directory /var/cache/prevu/builds/17293 and its subdirectories
> Traceback (most recent call last):
> File "/usr/bin/prevu", line 142, in ?
> BackportFromAPT(sys.argv[1],DIST).backport()
> File "/usr/bin/prevu", line 82, in backport
> self.do_compile()
> File "/usr/bin/prevu", line 67, in do_compile
> raise ValueError("Build failed.")
> ValueError: Build failed.
>
>
> ** Changed in: dapper-backports (upstream)
> Status: Unconfirmed => Rejected
>
> --
> Glade is out of date on Ubuntu Dapper - please update to 3.0.2
> https://launchpad.net/bugs/60538
>
> --
> desktop-bugs mailing list
> <email address hidden>
> https://lists.ubuntu.com/mailman/listinfo/desktop-bugs
>
> --
> Glade is out of date on Ubuntu Dapper - please update to 3.0.2
> https://launchpad.net/bugs/60538
>

Przemek K. (azrael) on 2009-11-20
Changed in baltix:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers