Displays vbox as hbox

Bug #425221 reported by Stuart Langridge on 2009-09-06
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Glade
Invalid
Undecided
Unassigned
glade (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: glade-3

glade-3 is displaying a vbox as an hbox when editing some glade files. Example (taken from transmageddon git master) attached. It displays correctly in the application itself.

(Debian had http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=526030 which seems to be the same problem, but that was reported fixed in 3.6.2; I am running 3.6.7.)

ProblemType: Bug
Architecture: i386
Date: Sun Sep 6 15:29:19 2009
DistroRelease: Ubuntu 9.10
Package: glade 3.6.7-1ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
SourcePackage: glade-3
Uname: Linux 2.6.31-9-generic i686

Stuart Langridge (sil) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in glade-3 (Ubuntu):
importance: Undecided → Low
Stuart Langridge (sil) wrote :

Linking to upstream bug in gnome bugzilla

Changed in glade-3:
importance: Undecided → Unknown
status: New → Unknown
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in glade-3 (Ubuntu):
status: New → Triaged
Changed in glade-3:
status: Unknown → New
costales (costales) wrote :

I confirm this bug.
I think is a High Importance, because I can't work with Glade :S
Best regards.

NicoInattendu (nico-inattendu) wrote :

I confirm also this problem .
In my UI xml file I add the line : <property name="orientation">vertical</property> in each <object> tag who have the class attribute = "GtkVBox"
Example :
  <object class="GtkVBox" id="vbox10">
                            <property name="visible">True</property>
                            <property name="orientation">vertical</property>
                            <child>
                           ......
                            </child>
                           <child>
                           ......
                            </child>
                           <child>
                           ......
                            </child>
  </object >

NicoInattendu (nico-inattendu) wrote :

I think also is a high importance bug. When with glade we open an "old" , i.e from jaunty, glade file, the rendering in glade window is messy and glade looks like unusable.

costales (costales) wrote :

Hi! For fixed a wrong .glade:
           - Open your .glade file in Glade.
           - In all VBOX containers used (you can see all in the right tree), change in the Properties / Tab General / Orientation to "Vertical".
           - Save it.

You can see here the Property to change: http://tinyurl.com/yb6edkh
Cheers!

Javier Jardón (jjardon) on 2010-01-19
affects: glade-3 (Ubuntu) → glade (Ubuntu)
Javier Jardón (jjardon) on 2010-01-19
Changed in glade-3:
importance: Unknown → Undecided
status: New → Invalid
Changed in glade (Ubuntu):
status: Triaged → Fix Committed
Changed in glade (Ubuntu):
status: Fix Committed → Fix Released
Changed in glade-2.old:
status: Unknown → Fix Released
Changed in glade-2.old:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.