Glade can't work with dialog windows

Bug #1242865 reported by Sergio Costas on 2013-10-21
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Glade
Fix Released
Medium
glade (Ubuntu)
Undecided
Unassigned

Bug Description

If I try to open a glade file made with the previous Ubuntu system, that contains a Dialog window, glade exits with a core dump.

If I open glade and start a new project, if I choose a Dialog window, it is shown empty, but glade doesn't allow to add new widgets inside.

With glade-gtk2 occurs the same when opening a glade file.

Maybe the problem is in other library, because I downloaded Glade 3.14.2 from the oficial page, compiled it in my system, and it also failed.

Currently using Ubuntu 13.10 64 bits.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glade (Ubuntu):
status: New → Confirmed
Lubos Janica (janicalubos) wrote :

I am using Kubuntu 13.10 64-bits and I have the same problem.

This bug is making glade unusable for real work.

It seems that (K)Ubuntu 13.10 has pretty old version of glade (see https://glade.gnome.org/).

13.10 uses Glade 3.14.2 because it's the last version compatible with GTK 3.8. I tried to compile Glade 3.16 but requires GTK 3.10.

I also tried (on the virtual machine) to uninstall the liboverlay package, to check if it was a problem with it (in Ubuntu 13.04 there was a rendering problem with Glade when having the liboverlay library installed). But no, it still fails.

Sorry, forgot to specify: I'm using Ubuntu 13.10 64 bits.

Lubos Janica (janicalubos) wrote :

After writting my comment I tried to compile newer version. But without success. As you wrote, Glade 3.16 requires GTK 3.10 and Glade 3.15 requires GTK 3.9.11.

Ubuntu/Kubuntu is sleeping on old GTK 3.8.4.

Therefore the newest version is 3.14.2 released 26 November 2012.

I replaced the libgtk-3 and libgtk-3-common packages with the ones in Debian SID, but still fails, so it seems to not be a problem with GTK itself.

I'm trying to change the GTK theme to see if it has something to do with this, but I'm unable to install a new theme :?

Ok, changed the GTK theme and the bug still is there, so it's another thing :(

Also, in Debian SID Glade works fine.

Lubos Janica (janicalubos) wrote :

I checked differencies among glade sources from sid and ubuntu. Here is list of modified files:

--- /usr/src/glade-3.14.2/debian/changelog 2013-02-06 22:00:28.000000000 +0100
--- /usr/src/glade-3.14.2/debian/control 2013-02-06 22:00:46.000000000 +0100
--- /usr/src/glade-3.14.2/debian/control.in 2013-02-06 21:47:55.000000000 +0100
--- /usr/src/glade-3.14.2/debian/copyright 2012-05-29 12:50:09.000000000 +0200
--- /usr/src/glade-3.14.2/debian/libgladeui-2-4.symbols 2013-02-06 21:25:08.000000000 +0100
--- /usr/src/glade-3.14.2/debian/patches/series 2013-02-06 21:25:08.000000000 +0100
--- /usr/src/glade-3.14.2/debian/watch 2013-02-06 21:25:08.000000000 +0100
--- /usr/src/glade-3.14.2/gladeui/glade-widget.c 2013-10-25 10:06:04.000000000 +0200
--- /usr/src/glade-3.14.2/.pc/applied-patches 2013-10-25 10:06:04.476888740 +0200
--- /usr/src/glade-3.14.2/plugins/gtk+/gtk+.xml 2013-10-25 10:11:10.267222309 +0200
--- /usr/src/glade-3.14.2/plugins/gtk+/gtk+.xml.in 2013-10-25 10:06:04.000000000 +0200

After quick scan in glade=widget.c and gtk+.xml I think that is not direct error in glade. It is some incompatibility between glade and used libraries (libgtk, libgir, ...)

Jean-Philippe Orsini (jfi) wrote :

- Core dump when using any .glade file containing a dialog box.
- Impossible to design a dialog box (more exactly to add something in it)
- Even the glade example at https://developer.gnome.org/gtk3/unstable/GtkDialog.html is producing a core dump when loading it with glade

Here is the stack:
==27993== Process terminating with default action of signal 5 (SIGTRAP)
==27993== at 0x62473C9: g_logv (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3800.0)
==27993== by 0x6247511: g_log (in /lib/x86_64-linux-gnu/libglib-2.0.so.0.3800.0)
==27993== by 0x4E66FC4: glade_widget_read (in /usr/lib/libgladeui-2.so.4.0.2)
==27993== by 0x4E5D9AD: ??? (in /usr/lib/libgladeui-2.so.4.0.2)
==27993== by 0x181E5050: glade_gtk_dialog_read_child (in /usr/lib/glade/modules/libgladegtk.so)
==27993== by 0x4E5B099: ??? (in /usr/lib/libgladeui-2.so.4.0.2)
==27993== by 0x181DE5E2: glade_gtk_widget_read_widget (in /usr/lib/glade/modules/libgladegtk.so)
==27993== by 0x181E49A0: glade_gtk_window_read_widget (in /usr/lib/glade/modules/libgladegtk.so)
==27993== by 0x4E66F28: glade_widget_read (in /usr/lib/libgladeui-2.so.4.0.2)
==27993== by 0x4E974F9: ??? (in /usr/lib/libgladeui-2.so.4.0.2)
==27993== by 0x4E9800E: glade_project_load_from_file (in /usr/lib/libgladeui-2.so.4.0.2)
==27993== by 0x40BC66: ??? (in /usr/bin/glade)

The actual glade package in debian unstable is working fine and is the same version than the one in ubuntu package. I did not investigate yet, but maybe there is something wrong in ubuntu specific patches or a dependency.

Jean-Philippe Orsini (jfi) wrote :

I tried 2 others DEs (gnome and enlightment), same issue for glade.

Jean-Philippe Orsini (jfi) wrote :

rebuilt the debian unstable package on ubuntu saucy, same issue which is not surprising as mentionned by #11 the differences between the 2 packages do not sound related to the bug.

Tried replacing libgladeui and libgladeui-common with the ones from Debian SID. Still fails.

Lubos Janica (janicalubos) wrote :

When I created Dialog widget in empty project, following meassages appeared in log on terminal:

(glade:23698): GladeUI-CRITICAL **: glade_widget_adaptor_get_object_type: assertion 'GLADE_IS_WIDGET_ADAPTOR (adaptor)' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_set_object: assertion 'new_object == NULL || g_type_is_a (G_OBJECT_TYPE (new_object), glade_widget_adaptor_get_object_type (gwidget->priv->adaptor))' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_adaptor_create_internal: assertion 'GLADE_IS_WIDGET (parent)' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_remove_property: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_remove_property: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_remove_property: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_property_set: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_property_set: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_property_set: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23698): GladeUI-CRITICAL **: glade_widget_property_set: assertion 'GLADE_IS_WIDGET (widget)' failed

Before SEGFAULT when glade open project with dialog box are in log following messages:
glade:23722): GladeUI-CRITICAL **: glade_widget_adaptor_get_object_type: assertion 'GLADE_IS_WIDGET_ADAPTOR (adaptor)' failed
(glade:23722): GladeUI-CRITICAL **: glade_widget_set_object: assertion 'new_object == NULL || g_type_is_a (G_OBJECT_TYPE (new_object), glade_widget_adaptor_get_object_type (gwidget->priv->adaptor))' failed
(glade:23722): GladeUI-CRITICAL **: glade_widget_adaptor_create_internal: assertion 'GLADE_IS_WIDGET (parent)' failed
(glade:23722): GladeUI-CRITICAL **: glade_widget_remove_property: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23722): GladeUI-CRITICAL **: glade_widget_remove_property: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23722): GladeUI-CRITICAL **: glade_widget_remove_property: assertion 'GLADE_IS_WIDGET (widget)' failed
(glade:23722): GladeUI-ERROR **: Unable to get GladeWidget for internal child vbox
Trace/breakpoint trap (core dumped)

It seems, that there is problem with creating "widget adaptor" and therefore is not possible to open project with dialog or after creating Dialog widget is not possible to add other widgets to dialog.

Jean-Philippe Orsini (jfi) wrote :

Sounds like there is already a registered report on the glade bugs database:
https://bugzilla.gnome.org/show_bug.cgi?id=705745

Dimitri John Ledkov (xnox) wrote :

I was guessing that it maybe related to gtk libraries transitioning to multiarch.

I installed the GTK libraries from Debian SID in Ubuntu 13.10, and still failed, while in Debian SID the same version of Glade works fine, so I suspect that the bug is not in GTK itself.

Changed in glade:
importance: Unknown → Medium
status: Unknown → New

Seems to have been fixed in a branch:

https://bugzilla.gnome.org/show_bug.cgi?id=705745

I'll try to get it and test.

Ok, tested in a virtual machine. And works!!!!!

Jean-Philippe Orsini (jfi) wrote :

debdiff fix for LP#1242865

Only contains changes for the fix, from glade author: https://git.gnome.org/browse/glade/patch/?id=d2c8e008e1b81d501b30c070d492959da6922992

Changed in glade:
status: New → Fix Released

The attachment "lp1242865.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Jean-Philippe Orsini (jfi) wrote :

I have uploaded .deb with the fix to a PPA: ppa:jfi/test

This problem also happens with Glade 3.8.0 (the version which works with GTK 2.0 ... I know.... but it works with pygtk)
The ppa fix seems to work with Glade 3.14.2 but has not fixed Glade 3.8.0

Lubos Janica (janicalubos) wrote :

Package from ppa:jfi/test is working. Great. Thank you.

Jean-Philippe Orsini (jfi) wrote :

@Simon, yes, I have only patched the glade 3.14.2. I am going to check whether the same fix can be applied to the 3.8.0 package (in fact that's glade-gtk2) too and upload to my ppa if it works.

Jean-Philippe Orsini (jfi) wrote :

Unfortunely, the fix is not working for glade-gtk2. Guess it depends on another changes that is in glade 3.14.2 but not glade 3.8.0.
You should probably open a separate bug report.

Glade 3.8.4 fixed this bug for GTK2.

Martin Pitt (pitti) wrote :
Changed in glade (Ubuntu):
status: Confirmed → Fix Released
Siarhei (ieh9eac1ei) on 2014-02-09
information type: Public → Public Security
information type: Public Security → Public
Erik B. Andersen (azendale) wrote :

Package from ppa:jfi/test is working for me on Saucy. I had installed the latest available from the repositories and ran into this issue. So, it appears that this was marked as fixed released in reference to Trusty.

Mike Dennis (reachingmike) wrote :

I had this same issue on Xubuntu 13.10. The fix supplied worked for me.

Jorge Niedbalski (niedbalski) wrote :

The proposed 3.14.2-3ubuntu2 fix, fixes this issue.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.