Authenticate dialog sometimes does not close after entering password

Bug #490850 reported by Captain Chaos on 2009-12-01
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Undecided
Unassigned
policykit (Ubuntu)
Undecided
Unassigned
policykit-gnome (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: software-center

Sometimes, after entering the password in the Authenticate dialog and pressing Enter, the dialog does not close. Instead just the Password field disappears. The rest of the dialog remains visible, but the Cancel and Authenticate buttons do nothing. The close button in the titlebar does work though, and if you close the dialog using that the Software Center proceeds to install the selected software, so the password was obviously still accepted.

Unfortunately I have not yet discovered a pattern to this, so I can't give definite instructions to reproduce. The best I can do is say that it happens now and again. Say once every five times. I will add more information if and when I do discover a pattern.

This is in karmic 64-bits. Version of software center is 1.0.2.

Dave Walker (dogatemycomputer) wrote :

I am sorry but I cannot confirm this bug without reproducing it.

You indicate the password field "disappears". Would it be possible to attach a screen-print of the dialog box with the missing password field? If you are comfortable installing/removing software from the command line then could you try that and update the bug report with any errors or warnings you see during the installation/removal process?

If you cannot reproduce the problem we will have a hard time getting it resolved but I think we can confirm the bug with a missing password field. Hopefully one of the developers can theorize a reason for the missing field and hopefully a code review will help track down the bug.

Changed in software-center (Ubuntu):
status: New → Incomplete
Captain Chaos (launchpad-chaos) wrote :

Of course now I *want* it to happen it refuses to...

Please bear with me for a few weeks. If it happens again I'll take a screenshot of it. If it doesn't then perhaps it was fixed by some other update in the mean time...

Captain Chaos (launchpad-chaos) wrote :

By the way, I regularly install software from the command line using apt-get, and I have yet to see any errors or warnings there.

Captain Chaos (launchpad-chaos) wrote :

Yes! I did it. Here's the screenshot.

Clicking on Cancel or Authenticate did nothing. Clicking on Details worked normally (showing and hiding the details). When I clicked the close button in the top right corner the dialog was closed and the installation proceeded normally.

This was while installing the "Avahi Zeroconf Browser". I tried uninstalling it and installing it again, but then the problem did not occur, so it does not appear to be related to specific packages.

Dave Walker (dogatemycomputer) wrote :

I am marking this bug as complete because you can obviously reproduce it and there is evidence the bug exists. This does not mean someone will not come along and mark it incomplete because they cannot reproduce it anywhere else. If additional information is required to help diagnose the problem then I am sure someone will contact you.

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Captain Chaos (launchpad-chaos) wrote :

It just happened again, but this time not in the software-center. I wanted to mount my Windows partition from the Places menu. It asks for my password using the same Authenticate dialog as the software-center uses, and it just did the same thing. I entered my password, and the password field disappeared but the dialog did not. Once again the Cancel and Authenticate buttons did nothing and after closing the dialog the partition was mounted

I can't believe I'm the only once seeing this. Perhaps I should list my hardware in some detail in case it has to do with that:

Intel Core2 Extreme Q6850 3 GHz CPU (quad core)
4 GB RAM
2 x NVidia Geforce 8800 GTX with 768 MB RAM each
NVidia binary driver (from repository)
three monitors (one on the first card, two on the second) with Xinerama

If there's some kind of debug logging I can activate in the hopes of catching some relevant information next time it happens then please let me know!

Since it looks like this bug is broader than just the software-center, but instead is in whichever component it is that displays the Authenticate dialog, perhaps this bug should be reassigned?

Dave Walker (dogatemycomputer) wrote :

I agree it should be reassigned but I am new and I do not know enough about how the software center authenticates to understand where it should go. I will try to find the correct package this afternoon.

Jac-Ni (jnventer) wrote :

So far, I've only experienced it with Software Center.

Jared (jaredv) wrote :

I've been having the same problem in just Software Centre so far but like others it only happens some of the time. If it will help at all the next time it happens I will upload a screenshot as proof.

Jared (jaredv) wrote :

I'm now sure its not Software Centre's fault as the same thing has happened when Ubuntu needed my password for mounting a hard drive.

David (davidboy) on 2010-01-01
affects: software-center (Ubuntu) → gksu (Ubuntu)
nikitakit (nikitakit) wrote :

Cross-posting what I said on one of the duplicates --

Steps to reproduce:
1. Run "gnome-network-properties"
2. Change the location.
3. Press close
4. Press "Apply System-Wide" on the dialog that pops up.
5. Bring focus to the authentication window by clicking on the window header: (important - click the window header and NOT the password box)
6. Type password, press enter

EricDHH (ericdhh) wrote :

Try user & groups or computer-janitor or softwarecenter, this produce the described problem here. All ubuntu progs with post legitimation seems to be affected. The dialogue box stays until it was closed by hand, no action occurs in the programs until the box was clicked away

Description: Ubuntu 10.10
Release: 10.10
amd64

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers