Authentication dialog freezes after I enter my password

Bug #444607 reported by Ivan Bartsov on 2009-10-06
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Medium
Unassigned

Bug Description

Sometimes upon a request to authenticate me for a privileged action (bug-report, partition mount, etc.) authentication does not occur (however, I'm pretty sure I enter the password right, and no notification says I mistyped it), instead the Authenticate dialog pops up ("Authentication is required to mount the device") with both Cancel and Authenticate buttons unresponsive (the buttons are animate, but do nothing when I click them).

I noticed that at least for Add/Remove Applications if I do not kill the dialog for a while a message appears that states that the corresponding daemon appears to be shut down and proposes to close the app. I'm not sure whether this is about the auth daemon or some kind of privileged procedure daemon.

After this happens, I cannot get the dialog to appear again (like, when I try to access a partition which requires a privileged mount, I just get a message, that the partition cannot be mounted because authentication is required)

This doesn't happen all the time, though. Sometimes authentication works, sometimes it doesn't.

I'm running Karmic amd64, up to date with updates.

ProblemType: Bug
Architecture: amd64
Date: Tue Oct 6 21:34:32 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: seahorse 2.28.0-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: seahorse
Uname: Linux 2.6.31-11-generic x86_64

Ivan Bartsov (whitething) wrote :
Ivan Bartsov (whitething) wrote :

Oh, and one more thing, the Authentication dialog which pops up (or, maybe, just stays) after I enter the password has no password field. This looks just like the moment when an invalid password has just been entered - the dialog lacks the password field for a little while (I assume it checks the pass) and then it kinda shudders and shows the password field again and states that the password I entered is not valid - but in case of the described bug the field doesn't appear and the dialog stops responding to button clicks.

Scott Ritchie (scottritchie) wrote :

I've seen this too - for me I get it when I mount my other hard drive from the places menu (I do this first thing at login)

Changed in ubuntu:
status: New → Confirmed
Ivan Bartsov (whitething) wrote :

Yeah, I also got this several times while installing stuff through Add/Remove Packages.

The quickest workaround I found is (after the bug occured) to log off, login back and try again (this way you get the authentication routine to run again instead of just giving you the error message).

Luke Faraone (lfaraone) on 2009-10-07
affects: ubuntu → gksu (Ubuntu)
Changed in gksu (Ubuntu):
importance: Undecided → Medium

Same thing happens for me - this was giving trouble with Update Manager and more recently with Administration>Login Screen.
For me, if I type in the password and hit enter, the password field vanishes and the authentication dialog becomes unresponsive.
However, if I type in the password and then click on the Authenticate button instead of hitting enter, it works fine.

Ivan Bartsov (whitething) wrote :

Found another workaround - after the dialog freezes, you can hit the close button (X) to close the auth dialog and countinue running your privileged app.

stinkinrich88 (stinkinrich88) wrote :

This happens for me, too. Except I have no workarounds. Pressing "authenticate" doesn't work. Closing the authentication dialog works but doesn't unlock the app. However, I can use software centre fine if I sudo the command. This is not the case for login screen, though...........

tags: added: regression

Hello Customer

Go to that cocktail party with this, and be sure to catch people’s attention.
All watches are packed in plain boxes and shipped discretely. They are delivered fast and in excellent condition. In case of some damage, we will reship your order.

*******************************************************
As requested, I just want to verify that I have finally received my package, and I must say it was well worth the wait! Thanks for such a high quality product! I look forward to conducting business with you again in the future.
Give thanks
                     Pierre Rossi
*******************************************************

Click here ---> http://moung.ru

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers