Translate message with apostrophe deny update

Bug #279734 reported by costales on 2008-10-07
2
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

Hi!
In Asturian language (ast), Update-manager not update when I push the button Install.

In english or spanish updates!

I was debugging the application.
The error is when the update command is created in run_synaptic method:

The asturian list for the command is this:
/usr/bin/update-manager
['/usr/bin/gksu', '--desktop', '/usr/share/applications/update-manager.desktop', '--', '/usr/sbin/synaptic', '--hide-main-window', '--non-interactive', '--parent-window-id', '39845891', '-o', 'Synaptic::closeZvt=true', '--progress-str', 'Por favor, aguarde; esto pue llevar un tiempu.', '--finish-str', "L'autualizaci\xc3\xb3n complet\xc3\xb3se", '--set-selections-file', '/tmp/tmp4YBL1S']

The apostrophe of "L'autualiza..." break the update command for terminal, and update-manager not update!

 "L'autualiza..." is the translation for asturian language:
https://translations.edge.launchpad.net/ubuntu/hardy/+source/update-manager/+pots/update-manager/ast/+translate?batch=10&show=all&search=l%27autualizaci%C3%B3n+comple

Update-manager never update when a tranlate message has an apostrophe!!!
I thing this is a high or critical bug!
Best regards!

costales (costales) wrote :
description: updated
Changed in update-manager:
status: New → Confirmed
costales (costales) on 2008-10-07
description: updated
costales (costales) on 2008-10-07
Changed in update-manager:
status: Confirmed → New
description: updated
description: updated
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

What version of ubuntu do you run? And what version of gksu? We fixed a quoting problem like this a while ago, I wonder if it has come back.

Changed in update-manager:
assignee: nobody → mvo
status: New → Incomplete
costales (costales) wrote :

Hi! In Hardy ;) (Intrepid isn't translate yet. We're translating now).
I didn't know the gksu now, I need go to home ;) (In 8 hours I will put it).
Best regards.

ivarela (ivarela) wrote :

I have Hardy too. I have seen the video "out.ogg" , and I have the same problem. The version installed of gksu is 2.0.0.5-ubuntu3.
Update-manager doesn't update packages.

costales (costales) wrote :

Hi, my version for update-manager ;)

marcos@marcos-desktop:~$ dpkg -p update-manager |grep Version
Version: 1:0.87.30
Python-Version: 2.4, 2.5
marcos@marcos-desktop:~$

costales (costales) wrote :

What's happen with this bug? Why is "incomplete"?
I change the translation (I remove the apostrophe) for works the Update manager in asturian, but the bug persist.
Please, change it to Confirme! Thanks very much!

Jean-Baptiste Lallement (jibel) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in update-manager:
importance: Undecided → Medium
status: Incomplete → Triaged
Michael Vogt (mvo) wrote :

This should be fixed in the intrepid version (and later ones) of gksu

Michael Vogt (mvo) on 2009-03-19
Changed in gksu (Ubuntu):
status: Triaged → Fix Released
costales (costales) wrote :

Thanks very much! :D

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments