gksu not in sudo mode

Bug #27636 reported by Jib on 2005-12-27
18
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Medium
Michael Vogt

Bug Description

When I graphically appeal update-manager a pop-up error window explains :

Received:
 su : Authentication failure
erreur de configuration - élément « QUOTAS_ENAB » inconnu (avertissez
l'administrateur)
erreur de configuration - élément « NOLOGIN_STR » inconnu (avertissez
l'administrateur)
erreur de configuration - élément
While expecting:
 gksu: waiting

In english :
Received:
configuration error - element « QUOTAS_ENAB » unknown (warn the administrator)
configuration error - element « NOLOGIN_STR » unknown (warn the administrator)
configuration error - element
While expecting:
 gksu: waiting

If I type in a shell "sudo update-manager", I get this error :
(synaptic:4185): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion
`gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

(synaptic:4185): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion
`gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
jib@naugnim:~$ sudo update-manager
Password:
/usr/lib/python2.4/site-packages/apt/__init__.py:17: FutureWarning: apt API not
stable yet
  warnings.warn("apt API not stable yet", FutureWarning)
/usr/lib/python2.4/site-packages/UpdateManager/MetaRelease.py:164:
DeprecationWarning: Class MetaRelease is already GObject-registered; Please note
that classes containing any of the attributes __gtype_name__, __gproperties__,
or __gsignals__ are now automatically registered.
  gobject.type_register(MetaRelease)

(update-manager:4516): libglade-WARNING **: Error loading image: L'ouverture du
fichier « /usr/share/update-manager/glade/synaptic.xpm » a échoué : No such file
or directory

(update-manager:4516): libglade-WARNING **: could not convert string to type
`GdkPixbuf' for property `icon'
current dist not found in meta-release file

But then, update-manager works perfectly...

This bug likely reffered to bug # 27640 .

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Can you please run the following command:
$ LANG=C gksu update-manager

and tell me if you get the same error/information window?
And the exact english error message?

Thanks,
 Michael

Michael Vogt (mvo) wrote :

*** Bug 27640 has been marked as a duplicate of this bug. ***

jib@naugnim:~$ LANG=C gksu update-manager
 error - unknown item 'CHFN_AUTH' (notify administrator)
configuration error - unknown item 'CLOSE_SESSIONS' (notify administrator)
Sorry.

And the pop-up "Failed to run update-manager as user root:
 Wrong password."
The same password with "sudo update-manager" works. I try three time with your
command-line, to ensure i typed my password right.

An important point : the window asking me for my password is different when it
fails than when it succeeds. A new pop-up, with a "remember-code" option that i
desactivate, bugs. The usual pop-up window still succeeds what it's designed for...

I hope it was helpfull.

moramarth.

Michael Vogt (mvo) wrote :

Can you please run:
$ gconf-editor

and check if /apps/gksu/sudo-mode is set to true.

This should do the trick.

Cheers,
 Michael

Michael Vogt (mvo) wrote :

If comment #5 dosn't help, can you please create a screenshot with the window
that asks you for the password?

I notch the /apps/gksu/sudo-mode key.

This is the small password pop-up, which lock the screen (screenshots
unavailable) and without "remember password" option.

It works...

Michael Vogt (mvo) wrote :

So after turning "/apps/gksu/sudo-mode" on in gconf-editor it works again?

Great. It should have been turned automatically during the upgade, wonder what
happend there.

Cheers,
 Michael

Michael Vogt (mvo) wrote :

One more question, is this a breezy or a dapper system?

dapper

The updates solve the bug.

Thanks.

Michael Vogt (mvo) wrote :

Thanks for confirming it, I close the bug now.

Changed in gksu:
status: Needs Info → Fix Released
Fionn (fbe) wrote :

I updated from dapper to edgy yesterday and I experienced something similar: Several configuration apps like update-manager and software-properties are being launched via gksu instead of gksudo. Nevertheless, a gconf-entry for sudo-mode was not installed. I had to explore the problem by myself and added the gconf key manually.

This issue should probably be checked inside some Ubintu base package!! Ubuntu will ALWAYS want to use gksu in sudo mode no matter what so some config script should make sure that the sudo-mode switch for gksu is properly set in gconf!

Normal users would almost certainly give up on this because gksu will keep giving them "wrong password" errors! I recommend to shift the importance of this issue.

Michael Vogt (mvo) wrote :

@Fionn: Thanks for your bugreport. Can you please attach the files in /var/log/dist-upgrade to this bugreport? That will makes analying what went wrong easier.

Fionn (fbe) wrote :

Unfortunately I can not do that, because I did not do a "dist-upgrade". update-manager told me that a dist-upgrade would be impossible, which - AFAIR - was related to the fact that I had no "ubuntu-desktop" package installed (probably because I got rid of some unneeded packages which are a dependency for the desktop package somewhen in the past).
So, all I did was manually changing my sources.list and apt prefs to edgy and then tell synaptic to update everything. I did that two or three times until nothing updatable was found anymore.
The only package I have NOT updated to latest edgy yet is "ubuntu-minimal" (held at version 0.120) because I was afraid that upstart could break my custom boot setup. So I postponed this package update for further analysis.

So I had - as written above - an "update", not an "upgrade". Which means, that all I have in /var/log/dist-upgrade is a file that will explain to you why my dist-upgrade failed. If you want that I can mail it to you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.