gksudo lacks frame

Bug #23988 reported by Juanjo Garcia-Ripoll on 2005-10-15
20
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Low
Michael Vogt

Bug Description

The modal window produced by gksudo lacks a window title and frame.
I am using the default Ubuntu theme. This way of presenting the
window is most annoying as one is sometimes unable to recognize
the presence of the modal dialog when displayed on top of, say,
a webbrowser, or evolution.

To reproduce: open a terminal window and type "gkusdo emacs"

What happens: a modal dialog without title and window frame appears

What should happen: the dialog should have a frame and a title.

David Chart (ubuntu-davidchart) wrote :

I see the same behaviour under powerpc.

Michael Vogt (mvo) wrote :

*** Bug 24529 has been marked as a duplicate of this bug. ***

Lars Ljung (larslj) wrote :

In the Breezy preview gksudo made the whole screen go greyish (or maybe b/w?), I kind of liked that behaviour. As it is now it's quite confusing when gksudo steals your mouse and keyboard without showing any clear signs of what's going on.

Michael Vogt (mvo) on 2006-03-31
Changed in gksu:
status: Unconfirmed → Confirmed
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Currently we ship with the "whole-screen-goes-gray" mode in dapper. This may change, but for now I mark the bug as "fix-released" because it is no longer a bug in dapper.

Cheers,
 Michael

Changed in gksu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.