Comment 5 for bug 23917

TRiSS (triss) wrote :

I can confirm this to! I run ubuntu dapper, dist-upgraded from breezy. It occurs with both gksu and gksudo, wether using sudo-mode or not. It's only a problem when running graphical applications, pure terminal ones do not seem to trigger the warning. This is very inconvenient since also the system-tools seem to use this, and therefore do not work (when called from the menu, they always give a wrong password error, when called from a terminal, they show this warning in the terminal: Warning: Tried to connect to session manager, Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed)

a few examples (same results with gksu or gksudo) :
gksu xterm: warning + root rights
gksudo whoami: no warning, root rights
gksu time-admin: warning, password error, NO root rights
time-admin: asks for password and root rights (WITHOUT gksu or gksudo)

a bugfix or workaround would be most welcome...