gksudo does not work after changing computer name

Bug #237662 reported by Leroy Wolins on 2008-06-05
6
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Undecided
Unassigned

Bug Description

Update Version 2.6.24.18.20 fails to install on Ububntu 8.04 LTS AMD64. The CPU Is an Intel Core2. After clicking on the update icon, the list of updates appears, but when I click on install, the small ball rotates indefinitely. I have tried rebooting, and removing some of the checked updates and get the same result. When I boot the Update Manager while disconnected from the internet, the list of updates appear, and the incessantly rotating ball appears just as it does when I am connected when I click on install. The only way to get rid of the rotating ball is to reboot. But the update icon appears almost immediately. When I click on install, the whole process begins again. If, after reboot, i click on install, all other programs seem to work correctly but the system slows down. However, if I ignore this beckoning icon, the system seems to function normally.

EDITED (TAK, 9th June '08) to make summary more helpful.

Thomas Kluyver (takluyver) wrote :

Can you try performing the upgrade from a command line, by running:
"sudo aptitude update" to update the list of available software, then
"sudo aptitude safe-upgrade" to make the upgrades.

What happens if you do this?

Leroy Wolins (corlee) wrote :

I did it and some very nice things happened. It appears that all the downloads are installed, but that pesky download icon still appears on the tool bar after a reboot, and the little rotating ball does not go away after I click on install. The attached file is what appeared in the terminal.

It seems to me that, in every possible way, the Hardy Heron would have been better named the Frazzled Phoenix.

Thomas Kluyver (takluyver) wrote :

Well, the proximate reason why it's still offering you updates is that aptitude didn't upgrade some things (the bits it said had been "kept back")--aptitude can be a bit picky about some upgrades. There will be some way of forcing it to install these using aptitude or apt-get, if you particularly need them.

The ultimate reason for the problem is presumably that update-manager is hanging somewhere--it may be failing to connect to the server, for example (is there anything odd about your internet connection, such as a proxy server?). I've marked the bug as affecting update-manager.

Leroy Wolins (corlee) wrote :

I had suspected the update manager earlier. I attempted to uninstall and reinstall, but Ubuntu would not allow that. Immediately before this bug emerged, I had successfully configured the printer attached to this computer to be used by a windows computer via the network. When the bug emerged, I attempted to remove all access to the other computers on this local network. I do not know how to do this. However, when this computer is the only computer turned on, the bug still occurs. The wireless internet connection consists of a wireless modem. One of the three windows computers, located far from the modem is wired directly to the modem. The remaining computers connect directly through a wireless card. All the other computers, including this one and another Ubuntu computer that I am preparing for someone else, function properly.

The attachment seems to indicate that the update manager is attempting to install the same set of updates as it did when the problem started. Since the problem occurs even when the computer is not attached to the internet, this file is stored somewhere in this computer. It would seem, to this naive programmer, that if one could find the file and the execute file that elicits it, one could find a fix. But I understand tha this is not an easy task --way too much for me.

Thomas Kluyver (takluyver) wrote :

Hi Leroy

Hmmm...I can't see how setting up a shared printer could affect it, but if the problem appeared just after you did that, then it's probably related. Do you know what you did in order to configure it? Did you follow some instructions online?

The way updates work in APT (the packaging system in Ubuntu) is that your computer downloads a list of packages from the internet, which has the names and version numbers of every available package. This list-downloading step was what you did with "sudo aptitude update". The lists are stored in /var/lib/apt/lists. APT can compare the version numbers from that to the version numbers it knows are installed, and where there's a newer version available, it will offer you an update. When you tell it to upgrade, it attempts to get the new package from the internet (the lists contain the information on where it is), and install it.

I think that your update-manager has failed at the stage where it tries to get the new package. But I don't know why it might be doing that, I'm afraid. Can you install a package in synaptic?

Leroy Wolins (corlee) wrote :

I tried to use the "hint" you gave me and found that synaptic wont boot. I have used it successfully several times.

I would be tempted to reinstall everything (that's what I would do if MSWIN behaved this way), if it were not for the fact that you people might want to learn from my mistakes. But, just say the word, and I'll do it.

Thomas Kluyver (takluyver) wrote :

It's not seriously affecting your computer use, so I think we'll keep investigating, if that's OK. If you do decide you need the relevant packages, we can work out a way to get them, I'm sure.

Does synaptic say anything when you try to launch it? If not, can you try running it from a command prompt, and seeing what output is generated?

Leroy Wolins (corlee) wrote :

Synaptic didn't respond at all when I try to launch it by clicking on it , and it still doesn't. But some nice things happened when I launched it from the terminal. (Again, thanks for the hint.) I entered in the terminal:
"sudo synaptic --upgrade-mode" and got a dialog box listing nine files -- perhaps the same ones appearing when I clicked on the pesky icon (which is no longer is pestering me). This elicted a dialog box containing the nine files, some for installation, and others to download. I clicked on "MARK" and again on (something else ?). Apparently, synaptic downloaded and installed those programs. So things have improved. I don't know what the future will bring but I expect that I will no longer get pesky icons on the tool bar telling me to upgrade. Rather, I must remember to invoke synaptic in order to get upgrades. I can live with that. I will keep you posted on this, or any other of your "hints."

Leroy Wolins (corlee) wrote :

The download icon appeared on the toolbar. I clicked on it. This produced "From icon.jpg." As before, I played solitaire for about 15 minutes while the ball rotated and then went to the terminal. (see terminal.jpg).Executing that command produced "Synaptic from terminal.jpg." Here, I clicked on "Mark all Upgrades and then "Apply." As before, the icon went away, along with "From icon."

That dialog box in "From terminal" is so slick that it suggests to me that this was intended as an upgrade to Synaptic and somehow got screwed up.

Thomas Kluyver (takluyver) wrote :

Ah, I think I might see where the problem is...

Can you try, from a command line, running "gksudo synaptic" (rather than "sudo synaptic"). Gksudo is the GNOME dialog to give you sudo access--if something is wrong with that, then that will block any program that attempts to bring up that password dialog--producing exactly the results you see.

Leroy Wolins (corlee) wrote :

The terminal freezes after "gksudo synaptic."

I think I know how I created the problem. I started with Ubuntu with 7.04. I put it in an old PIII and was impressed, so I purchased a new motherboard, P5K, and the rest of the stuff, and built a new computer. I worked at obtaining a dual boot system, but was unsuccessful. However, since the BIOS on this new system allowed me to indicate which one of two physically installed hard drives is recognized by the BIOS, I installed Ubuntu on one and Windows Vista on the other. When I wanted to change OS, I had to go to the BIOS -- clumsy, but it worked. Then, I bought a new printer and plugged it into this machine. I was able to access this printer from either a windows machine or another Ubuntu machine when Ubuntu was the OS running. However it didn't work when Vista was running. So i decided to change the name of the new machine to P5KU when Ubuntu was running and leave the name P5K when Vista was running. Then this problem occurred and I never got back to working with sharing the printer. Apparently, I didn't get the name completely changed.

Thomas Kluyver (takluyver) wrote :

OK, let's reassign this to the package containing gksudo.

I can't see why changing the computer's name should affect it, but it seems it did. It may be worth trying "sudo dpkg-reconfigure gksu". Hopefully someone will know more now it's correctly filed.

Leroy Wolins (corlee) wrote :

I did it. Nothing changed. I did it prior to responding to the "pesky Icon" and got the usual result -- only the rotating ball. Using the terminal command (see attachment) still works --16 updates (14.2 MB) were downloaded and installed.

I am tempted to try, in the terminal, "gksudo synaptic." I am also tempted to change the name of the computer back to P5K. But I recognize I don't know what I am doing so I'll control myself at least until you (all) rescue me or give up and tell me to reinstall.

Thomas Kluyver (takluyver) wrote :

It's noteworthy, I think, that running sudo also gives "sudo: unable to resolve host P5KU." It's definitely related to the network name, just that where sudo manages to carry on, gksudo hangs completely.

I've changed the summary line to be more accurate now that we know more.

description: updated
Leroy Wolins (corlee) wrote :

You asked me earlier how I configured the printer. I got side-tracked and never responded. So, this time, for the record, the way I changed the name (see attachment). I doubt,at this point,if you are really interested in how I configured the printer, but, if you are, just ask. I can print here from all my computers. I doubt if it works when Vista is booted, but I don't care enough to find out.Thanks!

Michael Vogt (mvo) wrote :

The hostname issue should be fixed with the updated version of libgksu in hardy-updates. Please test and give us feedback.

Thanks,
 Michael

Kshiteesh (kmh-putta-hotmail) wrote :

Even I had the same problem. I didn't know that the cause for gksu's misbehaviour was name change.
After trial and error, I discovered the solution. Here it is.
1. Go to System > Administration > Network.
2. Unlock the dialog box.
3. Goto Hosts tab.
4. Delete the entry with the IP address 127.0.1.1
5. Make a new entry with the IP address 127.0.1.1 and enter the new computer name in the "Aliases" area.
That's it.
Hope I was of some help.
Kshiteesh

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers