nautilus-gksu stopped working in hardy

Bug #201462 reported by Christoph Langner on 2008-03-12
52
Affects Status Importance Assigned to Milestone
gksu (Baltix)
Undecided
Unassigned
gksu (Ubuntu)
Medium
Michael Vogt
Hardy
Medium
Michael Vogt
Intrepid
Medium
Michael Vogt

Bug Description

Binary package hint: gksu

In older version of GNOME you had a "Open as administrator" entry inside the right click menu of nautilus, after the installation of the package nautilus-gksu. But this entry doesn't show up in hardy.

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 12 17:29:51 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: nautilus-gksu 2.0.0-5ubuntu1
PackageArchitecture: amd64
SourcePackage: gksu
Uname: Linux 2.6.24-12-generic x86_64

Related branches

Christoph Langner (chrissss) wrote :
Christoph Langner (chrissss) wrote :
DeJe (djenett) wrote :

I can confirm this as missing.

detlef@PC-AcerLinux:~# uname -r
2.6.24-12-generic

detlef@PC-AcerLinux:~# dpkg -l | grep nautilus
ii libnautilus-burn4 2.22.0-0ubuntu1 Nautilus Burn Library - runtime version
ii libnautilus-extension1 1:2.22.0-0ubuntu1 libraries for nautilus components - runtime
ii nautilus 1:2.22.0-0ubuntu1 file manager and graphical shell for GNOME
ii nautilus-cd-burner 2.22.0-0ubuntu1 CD Burning front-end for Nautilus
ii nautilus-data 1:2.22.0-0ubuntu1 data files for nautilus
ii nautilus-gksu 2.0.0-5ubuntu1 privilege granting extension for nautilus us
ii nautilus-open-terminal 0.8-1ubuntu2 nautilus plugin for opening terminals in arb
ii nautilus-sendto 0.13.2-0ubuntu1 integrates Evolution and Pidgin into the Nau

Matthias Metzger (macellarius) wrote :

Confirmed. The package is installed, but the menu entry is missing on Hardy.

I can confirm this too.

daklicker (klicker) wrote :

Confirmed.

Matthias Metzger (macellarius) wrote :

I found a solution for this issue. You can fix it with the following commands in the terminal:
$ sudo cp /usr/lib/nautilus/extensions-1.0/libnautilus-gksu.so /usr/lib/nautilus/extensions-2.0/
$ killall nautilus

Now you have the entry again.

Regards,
Matthias

daklicker (klicker) wrote :

nice! this works! thx!! :)

Luke12 (luca-venturini) wrote :

Workaround confirmed as working for me. Why has it not become standard in the Ubuntu packages? :-/

NoOp (glgxg) wrote :

Today's updates (April 10, 2008) broke nautilus-gksu again. Re-applying

$ sudo cp /usr/lib/nautilus/extensions-1.0/libnautilus-gksu.so /usr/lib/nautilus/extensions-2.0/

resolved the problem. Not sure which upgrade was the problem - there were about 80 of them.

Chow Loong Jin (hyperair) wrote :

The upgrade was the nautilus-gksu package itself. The bug is similar to bug #186938. But that bug is to do with nautilus-wallpaper. I'm in the midst of updating my pbuilder for Ubuntu Hardy. When I'm done I'll patch the deb and upload it to my ppa: http://edge.launchpad.net/~hyperair/+archive

Changed in gksu:
assignee: nobody → desktop-bugs
status: New → Confirmed
Chow Loong Jin (hyperair) wrote :

I've uploaded the patched packages already. Attached is the debdiff.

Chow Loong Jin (hyperair) wrote :

Sorry, wrong command for the debdiff. Correct debdiff is attached.

Changed in gksu:
assignee: desktop-bugs → mvo
pelle.k (pele2) wrote :

I made a link instead of copying. Thanks for the tip. I works very well.

"""
sudo ln -s /usr/lib/nautilus/extensions-1.0/libnautilus-gksu.so /usr/lib/nautilus/extensions-2.0/
"""

This package is in main, not universe. MOTU-Release should be un-subscribed. Subscribing Ubuntu-Release.

Martin Pitt (pitti) wrote :

Not too critical for the release, but fine for an SRU. If you manage to test/upload it by tomorrow, we might slip it into the final, too.

Chow Loong Jin (hyperair) wrote :

I've uploaded the package to my PPA and tested it already. It works fine on my computer. Build logs can be found from my PPA too. Here's the link: http://edge.launchpad.net/~hyperair/+archive

Here's the output of "dpkg -L nautilus-gksu" with the package included:
/.
/usr
/usr/lib
/usr/lib/nautilus
/usr/lib/nautilus/extensions-2.0
/usr/lib/nautilus/extensions-2.0/libnautilus-gksu.so
/usr/share
/usr/share/doc
/usr/share/doc/nautilus-gksu
/usr/share/doc/nautilus-gksu/copyright
/usr/share/doc/nautilus-gksu/README
/usr/share/doc/nautilus-gksu/changelog.Debian.gz
/usr/share/doc/nautilus-gksu/AUTHORS

Please also see Bug #219121

This is an issue common to all Nautilus extensions.

Chow Loong Jin (hyperair) wrote :

New debdiff with a more comprehensive changelog message and version 2.0.0-5ubuntu3.

Martin Pitt (pitti) wrote :

Thanks, hyperair! Approved for SRU. Michael, do you want to test/upload it to hardy-proposed?

Martin Pitt (pitti) on 2008-04-28
Changed in gksu:
importance: Undecided → Medium
milestone: none → ubuntu-8.04.1
Michael Vogt (mvo) wrote :

Thanks, uploaded to hardy-proposed.

Changed in gksu:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Stefano Angeleri (weltall) wrote :

seems to work fine for me

Alessandro Biasi (envysoft) wrote :

It works for file, but folders open doubles.

Chow Loong Jin (hyperair) wrote :

That's an old bug filed somewhere else. Unfortunately gksu doesn't seem to be in development anymore (this is my speculation, because the changelog seems rather old).

Stefano Angeleri (weltall) wrote :

yes alessandro biasi is right it seems to open the user home (not the root user the current user) and the requested window

Martin Pitt (pitti) wrote :

I confirm the previous statements. Opening files works fine, opening folders, too, but the latter produces an extra nautilus window.

Martin Pitt (pitti) wrote :

Needs to go to intrepid ASAP.

Changed in gksu:
milestone: ubuntu-8.04.1 → intrepid-alpha-1
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gksu:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied hardy-updates version to intrepid.

Changed in gksu:
milestone: intrepid-alpha-1 → none
status: Confirmed → Fix Released
DanielRoesler (diafygi) wrote :

I can confirm that the update fixes the bug. Nice work and thanks a bunch!

DanielRoesler (diafygi) on 2008-10-08
Changed in gksu:
status: New → Fix Released
Rafik Ouerchefani (rafik) wrote :

Nautilus-gksu is not working for me in both Intrepid (2.0.0-5ubuntu3) and Jaunty (2.0.0-5ubuntu4).
Can anyone confirm that ?

Rafik Ouerchefani (rafik) wrote :

I tried installing 2.0.08 it from Debian (http://packages.debian.org/lenny/nautilus-gksu) and it worked after cp /usr/lib/nautilus/extensions-1.0/libnautilus-gksu.so /usr/lib/nautilus/extensions-2.0/

NoOp (glgxg) wrote :

WFM:
Intrepid (2.0.0-5ubuntu3)
and
Hardy 2.0.0-5ubuntu3.8.04.1

'Nautilus-gksu is not working for me' is pretty vague. Specifically what isn't working for you?

Same symptom described in this bug report : no "Open as administrator" in
the contextual menu.

Chow Loong Jin (hyperair) wrote :

On Tue, 2009-03-03 at 22:38 +0000, Rafik Ouerchefani wrote:
> Same symptom described in this bug report : no "Open as administrator" in
> the contextual menu.
>
Works for me. 2.0.0-5ubuntu3. Did you do anything funky to Nautilus
recently?
--
Chow Loong Jin

Rafik Ouerchefani (rafik) wrote :

> Works for me. 2.0.0-5ubuntu3. Did you do anything funky to Nautilus
recently?

I just tried in another computer under Intrepid and it worked, weird. I
haven't done anything other than the regulars updates.
Anyway, sorry for the false alert ^^

MikeEagling (mikeeagling) wrote :

I have just installed nautilus-gksu, version 2.0.0-5ubuntu3 (described as "latest" in Synaptic), on Intrepid.
I too had to run "killall nautilus" to get the link in the context menu and I also get a second window displaying my home directory when attempting to open a folder.

The only "funky" thing I've done to Nautilus prior to this is add a couple of scripts (from the Ubuntu Community Documentation page on the subject) into my nautilus-scripts folder.

Chow Loong Jin (hyperair) wrote :

On Mon, 2009-03-23 at 20:25 +0000, MikeEagling wrote:
> I have just installed nautilus-gksu, version 2.0.0-5ubuntu3 (described as "latest" in Synaptic), on Intrepid.
> I too had to run "killall nautilus" to get the link in the context menu and I also get a second window displaying my home directory when attempting to open a folder.
That's to be expected. Nautilus only loads new extensions when starting
up. As for the second window, it's been noted further up the thread.
> The only "funky" thing I've done to Nautilus prior to this is add a
> couple of scripts (from the Ubuntu Community Documentation page on the
> subject) into my nautilus-scripts folder.
That's not funky enough to cause any trouble, really.
--
Chow Loong Jin

MikeEagling (mikeeagling) wrote :

hyperair wrote 3 hours ago:
> That's to be expected. Nautilus only loads new extensions when starting up.

Ah, I see. That makes sense after an explanation, although it's not clear from the package installation.

> As for the second window, it's been noted further up the thread.

Yeah, I know. I was trying to be verbose with my details. I wasn't sure whether 2.0.0-5ubuntu3 was supposed to have fixed this or not. I'm still very much at the stage where Launchpad is confusing.

> That's not funky enough to cause any trouble, really.
I didn't seriously think it was ;)

matil (lamedym) wrote :

Thanks!
Mati

________________________________
From: MikeEagling <email address hidden>
To: <email address hidden>
Sent: Tuesday, March 24, 2009 2:24:56 AM
Subject: [Bug 201462] Re: nautilus-gksu stopped working in hardy

hyperair wrote 3 hours ago:
> That's to be expected. Nautilus only loads new extensions when starting up.

Ah, I see. That makes sense after an explanation, although it's not
clear from the package installation.

> As for the second window, it's been noted further up the thread.

Yeah, I know. I was trying to be verbose with my details. I wasn't sure
whether 2.0.0-5ubuntu3 was supposed to have fixed this or not. I'm still
very much at the stage where Launchpad is confusing.

> That's not funky enough to cause any trouble, really.
I didn't seriously think it was ;)

--
nautilus-gksu stopped working in hardy
https://bugs.launchpad.net/bugs/201462
You received this bug notification because you are a direct subscriber
of a duplicate bug.

Status in “gksu” source package in Ubuntu: Fix Released
Status in gksu in Ubuntu Hardy: Fix Released
Status in gksu in Ubuntu Intrepid: Fix Released
Status in “gksu” source package in Baltix: Fix Released

Bug description:
Binary package hint: gksu

In older version of GNOME you had a "Open as administrator" entry inside the right click menu of nautilus, after the installation of the package nautilus-gksu. But this entry doesn't show up in hardy.

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 12 17:29:51 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: nautilus-gksu 2.0.0-5ubuntu1
PackageArchitecture: amd64
SourcePackage: gksu
Uname: Linux 2.6.24-12-generic x86_64

philip.evans (pevans1) on 2010-05-04
Changed in gksu (Ubuntu):
status: Fix Released → Fix Committed
Chow Loong Jin (hyperair) wrote :

On Tuesday 04,May,2010 08:18 AM, philip.evans wrote:
> ** Changed in: gksu (Ubuntu)
> Status: Fix Released => Fix Committed
>

What was the status change for? The fix for this was released ages ago. Please
don't change the status without an appropriate comment.

  affects ubuntu/gksu
  status fixreleased

--
Kind regards,
Chow Loong Jin

Changed in gksu (Ubuntu):
status: Fix Committed → Fix Released

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Rafik Ouerchefani

Rafik Ouerchefani
Student at Université de Monastir
Tunisia

Confirm that you know Rafik Ouerchefani
https://www.linkedin.com/e/isd/1345718160/xUSNNIjY/

------
(c) 2010, LinkedIn Corporation

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers