Ubuntu

gksu crashed with SIGSEGV in gdk_window_set_opacity()

Reported by yannis on 2008-01-13
This bug affects 273 people
Affects Status Importance Assigned to Milestone
GKSu
New
Undecided
Unassigned
gksu (Debian)
New
Undecided
Unassigned
gksu (Ubuntu)
High
Unassigned
Nominated for Karmic by Kirill Afonshin
Nominated for Lucid by Linus Hoppe

Bug Description

can't add new users

ProblemType: Crash
Architecture: i386
Date: Sun Jan 13 18:34:36 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/gksu
Package: gksu 2.0.0-5ubuntu1
PackageArchitecture: i386
ProcCmdline: /usr/bin/gksu --desktop /usr/share/applications/synaptic.desktop -- /usr/sbin/synaptic --hide-main-window --non-interactive -o Synaptic::closeZvt=true --parent-window-id 23068675 --set-selections-file /tmp/tmpeHSTcC
ProcCwd: /home/yaya
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gksu
Stacktrace:
 #0 0xb7afd24c in gdk_window_set_opacity () from /usr/lib/libgdk-x11-2.0.so.0
 #1 0xb7f5a96c in ?? () from /usr/lib/libgksu2.so.0
 #2 0x61706573 in ?? ()
 #3 0x00000000 in ?? ()
StacktraceTop:
 gdk_window_set_opacity () from /usr/lib/libgdk-x11-2.0.so.0
 ?? () from /usr/lib/libgksu2.so.0
 ?? ()
 ?? ()
Title: gksu crashed with SIGSEGV in gdk_window_set_opacity()
Uname: Linux juju-laptop 2.6.24-3-generic #1 SMP Thu Jan 3 23:30:29 UTC 2008 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev scanner video
SegvAnalysis:
 Segfault happened at: 0xb7afd24c <gdk_window_set_opacity+44>: mov (%edi),%edx
 PC (0xb7afd24c) ok
 source "(%edi)" (0x61706573) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA

yannis (yannis-lg) wrote :

StacktraceTop:IA__gdk_window_set_opacity (window=0x61706573, opacity=0.5)
fadeout_callback (fadeout=0x83951d8) at libgksu.c:321
g_idle_dispatch (source=0x8393568, callback=0x806bcd0,
IA__g_main_context_dispatch (context=0x8070c60)
g_main_context_iterate (context=0x8070c60, block=1,

Changed in gksu:
importance: Medium → High
status: New → Triaged
Per Kongstad (p-kongstad) wrote :

Using VMware 6.5 build-99530.

Rolando F. Blanco C:. (rolando) wrote :

[testing intrepid ibex]

I have this error, I did check the syslog file and this one say.

rolando@defiant:~/reporting$ cat /var/log/syslog | grep gdk

Sep 16 08:01:03 defiant kernel: [ 2778.976473] gksudo[6298]: segfault at 616c2f65 ip b7bfc3ac sp bfb54760 error 4 in libgdk-x11-2.0.so.0.1400.1[b7ba3000+88000]

rolando@defiant:~/reporting$

Andrea Caminiti (nrayever) wrote :

i was trying to use a more eye friendly color theme for gnome-terminal and it crashed

moob (milan-jaros-gmail) wrote :

I was adding/removing applications and it tels me something like: "I can't catch a mouse."

 gksu[26092]: segfault at 616c2f65 ip b7ad8e7c sp bfa3cda0 error 4 in libgdk-x11-2.0.so.0.1400.3[b7a80000+88000]

smmalis37 (smmalis37) wrote :

Tried to open Synaptic. Got the "can't catch your mouse" error and the following in syslog:

kernel: [44686.864979] gksudo[24197]: segfault at 736e6153 ip b7ad5e7c sp bfa2ef80 error 4 in libgdk-x11-2.0.so.0.1400.4[b7a7d000+88000]

I also have this bug. After boot I clicked on Synaptic icon and error message appeared.

Ubuntu 9.04 Alpha4 amd64

bazzdee (bazz-dee) wrote :

Also got this bug. I clicked on synaptic and while administrive program was starting i did other stuff in the ubuntu menu.

Yesterday I upgraded form 8.10 to 9.04 Beta. There were a few error messages, but the system seems to work and be stable at the moment. Today, I booted, started update manager to see if there any updates needed, then right clicked on the desktop to change my background image to something else. And that is when the error occurred.

mabab (mabab) wrote :

Using System-Update (Aktualisierungsupdate), then error message

I tried to block the screen, but missed the icon and pressed the icon of Synaptic instead. Then, pressed block the screen.

When I deblock the screen I saw apport with this bug report ready.

PS amd64 Ubuntu 9.04

Paul Jimenez (pjz) wrote :

My machine slowed down and I hadn't noticed so I clicked several places. Then apport showed up telling me about the crash of 'an application'.

also amd64 (Dell 1521 laptop) with 9.04 (pre, I guess)

Kees Cook (kees) on 2009-09-16
description: updated
digc16 (tribletsurvivor) wrote :

My error told me that the terminal in root crashed and I should report it.

Irvine (irvine) wrote :

Same as digc16: the terminal in root crashed...
I opened Software Sources.

Steve McGrath (smcgrath23) wrote :

I can provide definitive steps to reproduce this, at least on my system:

1) Attempt to launch an administrative app from the menu, something that will use a gksudo prompt
2) Immediately, before gksudo has a chance to appear, click on the main menu and leave it open
3) Gksudo will crash.

There's some interaction with the Gnome menus.

Akoley Marc (ekomak) wrote :

I get this error with the same step describe by Steve McGrath

Andrey Voronov (voronov84) wrote :

+ 1 on Lucid Lynx amd64

siknasa9 (randy-curry666) wrote :

Also got this on Lucid Lynx amd64

Nicolas DERIVE (kalon33) wrote :

Still happens into latest Maverick.

Tuomas Lähteenmäki (lahtis) wrote :

I was updating applications and it tels me something like: "I can't catch a mouse."

dmiranda (dmiranda) wrote :

The bug happens on Precise too.

tags: added: hardy jaunty karmic lucid maverick natty oneiric precise
Michał Krawczyk (mkkrawiec) wrote :

Xubuntu 12.04

userdce (userdce) wrote :

 on Precise

Installed ntop & htop, restarted laptop, when desktop loaded put in keyring pw then it happened for me
dmesg |tail said [ 125.209561] gksu[2709]: segfault at 4e7 ip 00007fa7ad992f29 sp 00007fff0833fca0 error 4 in libgdk-x11-2.0.so.0.2400.11[7fa7ad921000+ad000]

just reported here -
https://bugs.launchpad.net/ubuntu/+source/gksu/+bug/1041452

David Gerard (dgerard) wrote :

Also affected me in Xubuntu 12.10.

Rajiv Shah (compukid) on 2013-06-03
affects: gksu → ubuntu-ubuntu-server
affects: ubuntu-ubuntu-server → gksu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers