Ubuntu

gksu dialog box hangs when xfce compositing is on

Reported by arrrghhh on 2007-10-15
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Medium
Unassigned

Bug Description

so i use xubuntu 7.10 (just upgraded from 7.04) and the password dialog box hangs after you enter your password and hit 'enter'... it takes a while to authenticate it seems! i checked out GNOME to see if it was the same and it is not - was no problem in GNOME.

one interesting thing I noticed - before in 7.04, when I was watching video on my second monitor & a password dialog box appeared for whatever reason, the video on the second screen would stop and the screen would dim, but the audio would continue. now, the audio and video continue until you hit 'enter' after you have entered your password. then the same old song and dance - while it takes forever to make sure my password is correct, it pauses the video and continues the audio. thanks!

i also have 2 xubuntu computers at work, these are not experiencing this issue... so it is either hardware i have at home, or an issue with my initial installation. i might just do a clean install to see if that fixes the problem.

arrrghhh (arrrghhh) on 2007-10-15
description: updated
arrrghhh (arrrghhh) wrote :

this is really bothering me, as my systems at work are much less powerful than my system at home - and the system at home is the one having the problem!

it seems a clean install is in order, unless someone has a fix or another solution?

arrrghhh (arrrghhh) wrote :

so i'm on install #3 of gutsy on this machine, and the password dialog box STILL hangs after i enter my password and hit 'enter'. this still does not happen to my 2 machines at work (a laptop and desktop)

first i upgraded fesity to gutsy, it hung. so i wiped it and tried 64-bit, it still hung and i couldn't get flash working right. so then i wiped it again with a clean xubuntu 7.10 32-bit, and it STILL HANGS! i'm guessing it's hardware related, but this machine by far has the nicest hardware of any of my machines... please someone help, this is driving me NUTS since i use this computer as a media distribution device, and when i watch shows and have to enter my root password, it is annoying to say in the least. thanks!

Thank you for your bug report. By password dialog box you mean the one that appears when launching synaptic (for example) ?

Changed in xubuntu-meta:
importance: Undecided → Medium
status: New → Incomplete
John Doe (jdoe231) wrote :

yes he does im working with him in the ubuntu forums

Changed in xubuntu-meta:
status: Incomplete → In Progress
arrrghhh (arrrghhh) wrote :

Yes that is correct. It was suggested I remove two pieces of hardware that I don't use (a PCI netgear wifi card and a tv tuner that is of very poor quality). This hardware was present in Feisty, and this problem was not. I will remove the hardware and post back.

arrrghhh (arrrghhh) wrote :

Removed 2 unused cards in question. No change. I started a stopwatch the exact same time that I hit enter after typing my root password correctly. It was about 15.5 seconds before the screen was 'undimmed' and synaptic started loading.

Ok thank you, this might be a problem with the gksu package, I'm setting this to this package.

Changed in xubuntu-meta:
status: In Progress → New
arrrghhh (arrrghhh) wrote :

ok thank you. let me know if you would like any more info from me or if i can test anything. i'd love to get this resolved!

arrrghhh (arrrghhh) wrote :

so i switched to KDE because XFCE was slowing my systems down. i originally tried it because it was supposed to be for low-end computers, so i figured it would run like a dream - it hasn't, and KDE has been much more responsive (especially the password dialog boxes)

so thanks, you can close this bug report.

Telecaster72 (olovfh) wrote :

I have the same problem so please dont close this bugreport.
This occurs on a clean install of Xubuntu 7.10 (separate /home partition)

It never happened for me until i did the Xubuntu install, worked fine in Edgy, Feisty and Gutsy (all Gnome) but since my hardware is outdated i rather use the xfce enironment.

Telecaster72 (olovfh) wrote :

Just want to add a thread on this from Ubuntuforums.
http://ubuntuforums.org/showthread.php?p=3799023#post3799023

Telecaster72 (olovfh) wrote :

Changing the graphics driver from nvidia-glx to the "nv" driver solved the delay for me, strange that this only happened in xfce though.

arrrghhh (arrrghhh) wrote :

Telecaster72 - i can't use the 'nv' driver - as i recall X wouldn't even load with that driver. for whatever reason every reboot on this machine i would have to redo the video setup - with nvidia's official installer with no window manager running. now i don't have to do that any more... i'm not sure what's changed other than switching to kde.

arrrghhh (arrrghhh) wrote :

oh yes and here's my thread from ubuntu forums...

http://ubuntuforums.org/showthread.php?t=590566

that's like thread #3 or 4 over there related to that issue... yours got by far the most attention tho!

Telecaster72 (olovfh) wrote :

It is not the Nvidia driver that is the cause, it might be the composite manager of xfce, it works using the nvidia driver if i have composite turned off, and with the "nv" driver the same thing happens, so that leads me to believe it has something to do with XFCE' s composite manager.
That would also explain why this did not occur in GNOME for me, if i am not missinformed compiz use a different composite manager than the native one in Xubuntu?

arrrghhh (arrrghhh) wrote :

ok i will experiment with that now.

compiz uses a different manager than the one in xubuntu, yes indeed - i remember reading about all that somewhere, although i don't remember the specifics.

arrrghhh (arrrghhh) wrote :

after testing, display compositing is definitely the source of this problem. tested with it off and on, and when it is off, no problems. when it's on, the dialog box hangs as it did before.

Telecaster72 (olovfh) wrote :

It seems this happens when composite is on and the option 'Display shadows under popup windows'is turned on, leave that option unchecked and it works as it should, one user in above mentioned thread also noticed replacing gksudo with gksudo -g worked.

Telecaster72 (olovfh) wrote :

user tw1ggy.ramir3z at ubuntuforums solved this by running "gksu-properties" changed "Capture mode" from enable to disable, viola!

Is this still an issue for you in Hardy (8.04)? Thanks.

arrrghhh (arrrghhh) wrote :

I haven't used XFCE in a while, I'll have to install it to check this out in the Heron. I've been using KDE for a long time now, and I haven't looked at XFCE since...

Fabian A. Scherschel (fabsh) wrote :

I can confirm that this still happens in Hardy. I am running up-to-date Xubuntu 8.04 (32bit) with enabled compositing and an external TFT on a Dell XPS m1330.

Changed to confirmed based on comments; three users have reproduced this bug.

Changed in gksu:
status: New → Confirmed
Fabu (geilviech) wrote :

This is still / again an issue in Xubuntu 11.10.

Fabu (geilviech) wrote :

On 11.10 this seems to be the only workaround to fix the bug:

"I disabled Compositing in 'Window manager Tweaks' and it blew right through. Of course that has other repercussions). So I tested further and I find that the key is 'Display shadows under popup windows'. So either it's not playing nice with gksudo's UI takeover, or gksudo isn't."

http://ubuntuforums.org/showthread.php?t=616290&page=2
Post #16

Still / again problem in Xubuntu 13.10!!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers