Ubuntu

gksu doesn't use locking on nfs /home

Reported by Shish on 2005-03-25
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Wishlist
Unassigned

Bug Description

Bug 13387 says lockfile writing was fixed in 1.2.3-2ubuntu4, this is 1.2.4-1ubuntu4.

The first time I run somehting with gksu, the window pops up OK, but this
message is output:

** (gksu:8732): WARNING **: Not using locking for nfs mounted lock file
/home/shish/.gksu.lock

Then all further times there's no window, just this message:

** (gksu:8748): CRITICAL **: fcntl error

** (gksu:8748): WARNING **: Lock taken by pid: -1. Exiting.

When manually removing ~/.gksu.lock, it works one more time, then leaves another
stale lock.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I uploaded gksu_1.2.4-1ubuntu5 today that will fix this problem. It will not use
locking at all when it runs on a FS with no locks available (and cleans the
stale lockfiles).

I leave this bug open as a reminder to add locking support even when run on NFS
homedirs, but I'm kind of scared to fix it now so close before the release.

Laurent Bigonville (bigon) wrote :

What the status of this bug?

Michael Vogt (mvo) wrote :

This is still not fixed in gksu

nipuL (lucas-die) wrote :

Still get this problem on Edgy Eft 6.10...

I get around it by doing the following

mv ~/.gksu.lock /tmp/gksu-lucas.lock
ln -s /tmp/gksu-lucas.lock ~/.gksu.lock

Perhaps the code could be patched to change the lockfile location?

Michael Vogt (mvo) on 2009-06-09
Changed in gksu (Ubuntu):
assignee: Michael Vogt (mvo) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.