[Gutsy] memory corruption due to late invocation of g_thread_init() in tribe 2 installer

Bug #125619 reported by Grzegorz Galezowski on 2007-07-12
2
Affects Status Importance Assigned to Milestone
gksu (Ubuntu)
Low
Unassigned

Bug Description

When I tried to install tribe 2 gutsy on my disk, it seemed to hang always when I manually edited partitions in installer. I then invoked it from terminal and got the following message:
ubuntu@ubuntu:~$ ubiquity --desktop %k gtk-ui

***MEMORY-WARNING***: gksudo[15678]: GSlice: g_thread_init() must be called before all other GLib functions; memory corruption due to late invocation of g_thread_init() has been detected; this program is likely to crash, leak or unexpectedly abort soon...

then i ran the installer without the gtk-ui switch and everything went smoothly - there was no error and I installed gutsy on my disk.

Colin Watson (cjwatson) wrote :

The hang is a different problem and will be worked around in Tribe 3. The error message you see is due to something in gksu or one of the libraries it uses.

Nanley Chery (nanoman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in gksu:
assignee: nobody → nanoman
status: New → Incomplete
Grzegorz Galezowski (spectral) wrote :

Hi, Nanley.

No, it's not an issue anymore and I managed to successfully install
Gutsy stable a while ago. Feel free to mark this bug as fixed.

Regards,
Grzegorz Galezowski

Changed in gksu (Ubuntu):
assignee: Nanley Chery (nanoman) → nobody
importance: Undecided → Low
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers