Gnome-shell will not install due to depends issues

Bug #629631 reported by John Vivirito on 2010-09-03
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gjs (Ubuntu)
Medium
Micah Gersten

Bug Description

Binary package hint: gnome-shell

I am unable to install gnome-shell from official archives and PPA. i disabled the PPA since it has same issue

here is the output that might help:

gnomefreak@Development:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu maverick (development branch)
Release: 10.10
Codename: maverick
gnomefreak@Development:~$ uname -a
Linux Development 2.6.35-19-generic #28-Ubuntu SMP Sun Aug 29 06:36:51 UTC 2010 i686 GNU/Linux
gnomefreak@Development:~$ policy gnome-shell
gnome-shell:
  Installed: (none)
  Candidate: 2.31.5-2ubuntu1
  Version table:
     2.31.5-2ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages

gnomefreak@Development:~$ install gnome-shell
[sudo] password for gnomefreak:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-shell : Depends: gjs but it is not going to be installed
               Depends: libgjs0a (>= 0.7.1) but it is not going to be installed
E: Broken packages

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-shell (not installed)
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Sep 3 12:13:02 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=C
 SHELL=/bin/bash
SourcePackage: gnome-shell

Related branches

Micah Gersten (micahg) wrote :

This will be fixed once we fix bug 576991.

Changed in gnome-shell (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
status: New → Triaged
Harry (harry33) wrote :

John,

This is a workaround.

You probably have too new xulrunner (=1.9.2.9+build1) installed.
Package libgjs0a depends on xulrunner_1.9.2.8, and conflicts with > 1.9.2.9+.
So, downgrade xulrunner.
You also need to create a symlink into the directory /urs/lib/ which points to file /usr/lib/xulrunner-1.9.2.8/libmozjs.so
or
copy the file /usr/lib/xulrunner-1.9.2.8/libmozjs.so into the directory /usr/lib/

And that's it.

 That's a bad workaround as that will open people up to security
vulnerabilities in the future if they forget it. The most you want to
do is symlink to libmozjs. This will be fixed in maverick shortly.

On 09/03/2010 12:08 PM, Harry wrote:
> John,
>
> This is a workaround.
>
> You probably have too new xulrunner (=1.9.2.9+build1) installed.
> Package libgjs0a depends on xulrunner_1.9.2.8, and conflicts with >
1.9.2.9+.
> So, downgrade xulrunner.
> You also need to create a symlink into the directory /urs/lib/ which
points to file /usr/lib/xulrunner-1.9.2.8/libmozjs.so
> or
> copy the file /usr/lib/xulrunner-1.9.2.8/libmozjs.so into the directory
/usr/lib/
>
> And that's it.
>

Micah Gersten (micahg) wrote :

This is actually caused by gjs not being installable, so moving the bug there.

affects: gnome-shell (Ubuntu) → gjs (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gjs - 0.7.1-1ubuntu2

---------------
gjs (0.7.1-1ubuntu2) maverick; urgency=low

  * fix LP: #576991 - Make gjs not need a rebuild for each xulrunner release;
    Use dh_xulrunner to add binary depends on xulrunner for libgjs0a;
    Add binary depends on xulrunner-dev (>= 1.9.2) for libgjs-dev
    - update debian/control
    - update debian/rules
  * fix LP: #629631 - gnome-shell will not install due to depends issues; fixed
    by the above changes
  * Add back chrpath as a build-dep and delete the rpath in libgjs; Any rdepends
    of libgjs will now need a wrapper script to find libmozjs
    - update debian/rules
    - update debian/control
  * Add a wrapper around gjs-console so it can find libmozjs; install wrapper
    in override_dh_install
    - update debian/rules
 -- Micah Gersten <email address hidden> Sat, 04 Sep 2010 21:03:36 -0500

Changed in gjs (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions