[SRU] 1.54.3

Bug #1804641 reported by Iain Lane on 2018-11-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gjs (Ubuntu)
Undecided
Unassigned
Cosmic
Undecided
Iain Lane

Bug Description

Description
-----------

Update cosmic from 1.54.1 to 1.54.3. This will be a no-change backport from disco. There are some changes in debian/, but I think they should be OK.

NEWS. The upstream changes are covered by https://wiki.ubuntu.com/StableReleaseUpdates/GNOME:

Version 1.54.3
--------------

- Closed bugs and merge requests:
  * object: Fix write-only properties [!246, Philip Chimento]
  * SIGSEGV when exiting gnome-shell [#212, !247, Andrea Azzarone]
  * SelectionData.get_targets crashes with "Unable to resize vector" [#201,
    !241, Philip Chimento]
  * Gnome-shell crashes on destroying cached param specs [#213, !240, Marco
    Trevisan]
  * GType memleak fixes [!244, Marco Trevisan]
  * Fix build with --enable-dtrace and create CI job to ensure it doesn't break
    in the future [#196, !253, Philip Chimento]

Version 1.54.2
--------------

- Closed bugs and merge requests:
  * context: Defer and therefore batch forced GC runs [performance] [!236,
    Daniel van Vugt]
  * context: use timeout with seconds to schedule a gc trigger [!239, Marco
    Trevisan]
  * fundamental: Check if gtype is valid before using it [!242, Georges Basile
    Stavracas Neto]

- Backported a fix for a crash in the interactive interpreter when executing
  something like `throw "foo"` [Philip Chimento]

- Backported various maintenance from 3.31 [Philip Chimento]

Test Case
---------
GNOME Shell is written in gjs so let's test GNOME Shell. After installing the update, reboot.

Also check some of these apps:
gnome-characters
gnome-documents
gnome-maps
gnome-sound-recorder
gnome-sushi
gnome-weather
polari

All of them except for gnome-sound-recorder and polari are included in Ubuntu GNOME and Ubuntu Budgie.

Regression Potential
--------------------
Well if gjs has a problem, it could leave Ubuntu GNOME users unable to log in to their computer at all since gdm uses part of gnome-shell to work. But I did test build, install and reboot before uploading this update to Ubuntu.

Iain Lane (laney) on 2018-11-22
Changed in gjs (Ubuntu):
status: New → Fix Released
Changed in gjs (Ubuntu Cosmic):
status: New → In Progress
assignee: nobody → Iain Lane (laney)

Hello Iain, or anyone else affected,

Accepted gjs into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gjs/1.54.3-1~ubuntu18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gjs (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Daniel van Vugt (vanvugt) wrote :

Verified on cosmic in gjs version 1.54.3-1~ubuntu18.10.1

As an added bonus, bug 1803271 (!236) is now also fixed :)

tags: added: verification-done verification-done-cosmic
removed: verification-needed verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gjs - 1.54.3-1~ubuntu18.10.1

---------------
gjs (1.54.3-1~ubuntu18.10.1) cosmic; urgency=medium

  * No-change SRU backport from unstable / disco to cosmic (LP: #1804641)
  * Also fixes crash on `gnome-shell --replace' (LP: #1796238)

gjs (1.54.3-1) unstable; urgency=medium

  * Team upload
  * New upstream release
  * Force time zone to UTC when running tests.
    This hopefully fixes FTBFS in the pathological time zone used to test
    reproducible builds.

gjs (1.54.2-1) unstable; urgency=medium

  * Team upload
  * Upload to unstable (starts transition: #906016)
  * d/watch: Only watch for versions from a stable branch
  * New upstream release
  * Bump Standards-Version to 4.2.1 (no changes required)
  * Use dpkg's default.mk to get upstream version number for dependencies.
    This avoids relying on the differently-named variables in
    gnome-get-source.mk, and also does the right thing if gjs ever gains
    an epoch.
  * d/rules: Remove gnome-get-source.mk (please use uscan instead)

 -- Iain Lane <email address hidden> Thu, 22 Nov 2018 12:21:13 +0000

Changed in gjs (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gjs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers