Activity log for bug #1803271

Date Who What changed Old value New value Message
2018-11-14 04:36:50 Daniel van Vugt bug added bug
2018-11-14 04:37:16 Daniel van Vugt gjs (Ubuntu): status New Fix Released
2018-11-14 04:37:23 Daniel van Vugt nominated for series Ubuntu Cosmic
2018-11-14 04:37:23 Daniel van Vugt nominated for series Ubuntu Bionic
2018-11-14 04:39:19 Daniel van Vugt tags performance regression-release bionic cosmic disco performance regression-release
2018-11-14 05:07:18 Daniel van Vugt gjs (Ubuntu): assignee Daniel van Vugt (vanvugt)
2018-11-14 05:07:59 Daniel van Vugt description Since fixing bug 1672297 we experience much higher CPU during gnome-shell JavaScript operations, such as the icon spring animation. The fix for this regression is https://gitlab.gnome.org/GNOME/gjs/merge_requests/236 Since fixing bug 1672297 in release 18.04 we experience much higher CPU during gnome-shell JavaScript operations, such as the icon spring animation. The fix for this regression is https://gitlab.gnome.org/GNOME/gjs/merge_requests/236
2018-11-19 09:24:33 Daniel van Vugt gjs (Ubuntu): importance High Medium
2018-11-19 09:26:34 Daniel van Vugt description Since fixing bug 1672297 in release 18.04 we experience much higher CPU during gnome-shell JavaScript operations, such as the icon spring animation. The fix for this regression is https://gitlab.gnome.org/GNOME/gjs/merge_requests/236 [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation. The fix for this regression is https://gitlab.gnome.org/GNOME/gjs/merge_requests/236
2018-11-19 09:30:57 Daniel van Vugt description [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation. The fix for this regression is https://gitlab.gnome.org/GNOME/gjs/merge_requests/236 [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation. [Test Case] Use 'top' to measure the CPU usage of the gnome-shell process while tapping Super+A repeatedly. It should be much lower with the fix than without. [Regression Potential] Low/Medium. This particular fix (https://gitlab.gnome.org/GNOME/gjs/merge_requests/236) has been released and used in a couple of upstream gjs versions already without issue. The real regression potential comes from other bug fixes included in version 1.54.2 (https://gitlab.gnome.org/GNOME/gjs/blob/gnome-3-30/NEWS). Although they are only bug fixes. [Other Info] The fix is already released to 19.04 as part of gjs version 1.54.2-1.
2018-11-19 09:36:49 Daniel van Vugt description [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation. [Test Case] Use 'top' to measure the CPU usage of the gnome-shell process while tapping Super+A repeatedly. It should be much lower with the fix than without. [Regression Potential] Low/Medium. This particular fix (https://gitlab.gnome.org/GNOME/gjs/merge_requests/236) has been released and used in a couple of upstream gjs versions already without issue. The real regression potential comes from other bug fixes included in version 1.54.2 (https://gitlab.gnome.org/GNOME/gjs/blob/gnome-3-30/NEWS). Although they are only bug fixes. [Other Info] The fix is already released to 19.04 as part of gjs version 1.54.2-1. [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation. [Test Case] Use 'top' to measure the CPU usage of the gnome-shell process while tapping Super+A repeatedly. It should be much lower with the fix than without. [Regression Potential] Low. This particular fix is tiny (https://gitlab.gnome.org/GNOME/gjs/merge_requests/236) and has been released and used in a couple of upstream gjs versions already without issue. [Other Info] The fix is already released to 19.04 as part of gjs version 1.54.2-1.
2018-11-19 10:03:02 Daniel van Vugt attachment added gjs_1.54.1-1ubuntu1.debdiff https://bugs.launchpad.net/ubuntu/+source/gjs/+bug/1803271/+attachment/5214115/+files/gjs_1.54.1-1ubuntu1.debdiff
2018-11-19 10:03:54 Daniel van Vugt bug added subscriber Ubuntu Sponsors Team
2018-11-23 04:56:04 Chris Halse Rogers bug task added gjs (Ubuntu Bionic)
2018-11-23 04:56:10 Chris Halse Rogers bug task added gjs (Ubuntu Cosmic)
2018-11-23 04:56:59 Daniel van Vugt gjs (Ubuntu Cosmic): status New In Progress
2018-11-23 04:57:01 Daniel van Vugt gjs (Ubuntu Cosmic): importance Undecided Medium
2018-11-23 04:57:04 Daniel van Vugt gjs (Ubuntu Cosmic): assignee Daniel van Vugt (vanvugt)
2018-11-23 04:57:10 Daniel van Vugt gjs (Ubuntu Bionic): status New Confirmed
2018-11-23 04:57:13 Daniel van Vugt gjs (Ubuntu Bionic): status Confirmed Triaged
2018-11-23 04:57:16 Daniel van Vugt gjs (Ubuntu Bionic): importance Undecided Medium
2018-11-23 04:57:19 Daniel van Vugt removed subscriber Ubuntu Sponsors Team
2018-11-23 04:57:28 Daniel van Vugt bug added subscriber Ubuntu Sponsors Team
2018-11-28 01:27:35 Daniel van Vugt removed subscriber Ubuntu Sponsors Team
2018-11-28 01:28:07 Daniel van Vugt gjs (Ubuntu Cosmic): assignee Daniel van Vugt (vanvugt)
2018-11-28 01:28:11 Daniel van Vugt gjs (Ubuntu Cosmic): status In Progress Fix Committed
2018-11-28 02:07:09 Daniel van Vugt description [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation. [Test Case] Use 'top' to measure the CPU usage of the gnome-shell process while tapping Super+A repeatedly. It should be much lower with the fix than without. [Regression Potential] Low. This particular fix is tiny (https://gitlab.gnome.org/GNOME/gjs/merge_requests/236) and has been released and used in a couple of upstream gjs versions already without issue. [Other Info] The fix is already released to 19.04 as part of gjs version 1.54.2-1. [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation [1]. Even just moving the mouse is a little more expensive now [2]. [1] https://gitlab.gnome.org/GNOME/gnome-shell/issues/349 [2] https://gitlab.gnome.org/GNOME/mutter/issues/283 [Test Case] Use 'top' to measure the CPU usage of the gnome-shell process while tapping Super+A repeatedly. It should be much lower with the fix than without. [Regression Potential] Low. This particular fix is tiny (https://gitlab.gnome.org/GNOME/gjs/merge_requests/236) and has been released and used in a couple of upstream gjs versions already without issue. [Other Info] The fix is already released to 19.04 as part of gjs version 1.54.2-1.
2018-12-11 14:36:24 Sebastien Bacher gjs (Ubuntu Bionic): assignee Daniel van Vugt (vanvugt)
2018-12-12 02:18:33 Daniel van Vugt gjs (Ubuntu Cosmic): status Fix Committed Fix Released
2018-12-12 02:24:05 Daniel van Vugt description [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation [1]. Even just moving the mouse is a little more expensive now [2]. [1] https://gitlab.gnome.org/GNOME/gnome-shell/issues/349 [2] https://gitlab.gnome.org/GNOME/mutter/issues/283 [Test Case] Use 'top' to measure the CPU usage of the gnome-shell process while tapping Super+A repeatedly. It should be much lower with the fix than without. [Regression Potential] Low. This particular fix is tiny (https://gitlab.gnome.org/GNOME/gjs/merge_requests/236) and has been released and used in a couple of upstream gjs versions already without issue. [Other Info] The fix is already released to 19.04 as part of gjs version 1.54.2-1. [Impact] Since fixing bug 1672297 in release 18.04 we experience much higher (almost double) CPU usage during gnome-shell JavaScript operations, such as the icon spring animation [1]. Even just moving the mouse is a little more expensive now [2]. [1] https://gitlab.gnome.org/GNOME/gnome-shell/issues/349 [2] https://gitlab.gnome.org/GNOME/mutter/issues/283 [Test Case] Use 'top' to measure the CPU usage of the gnome-shell process while tapping Super+A repeatedly. It should be much lower with the fix than without. [Regression Potential] Low. This particular fix is tiny (https://gitlab.gnome.org/GNOME/gjs/merge_requests/236) and has been released and used in a couple of upstream gjs versions already without issue. [Other Info] The fix is already released to 19.04 as part of gjs version 1.54.2-1. And already released to 18.10 as part of gjs version 1.54.3-1~ubuntu18.10.1.
2018-12-14 08:14:08 Daniel van Vugt gjs (Ubuntu Bionic): assignee Daniel van Vugt (vanvugt)
2018-12-19 19:40:14 Marco Trevisan (Treviño) gjs (Ubuntu Bionic): assignee Marco Trevisan (Treviño) (3v1n0)
2018-12-19 21:53:26 Andrew Hayzen bug added subscriber Andrew Hayzen
2018-12-19 22:32:28 Launchpad Janitor merge proposal linked https://code.launchpad.net/~3v1n0/ubuntu/+source/gjs/+git/gjs/+merge/361167
2018-12-20 02:02:33 Jeremy Bicha gjs (Ubuntu Bionic): status Triaged In Progress
2019-01-08 20:39:07 Brian Murray gjs (Ubuntu Bionic): status In Progress Fix Committed
2019-01-08 20:39:09 Brian Murray bug added subscriber Ubuntu Stable Release Updates Team
2019-01-08 20:39:12 Brian Murray bug added subscriber SRU Verification
2019-01-08 20:39:15 Brian Murray tags bionic cosmic disco performance regression-release bionic cosmic disco performance regression-release verification-needed verification-needed-bionic
2019-01-09 04:47:26 Daniel van Vugt tags bionic cosmic disco performance regression-release verification-needed verification-needed-bionic bionic cosmic disco performance regression-release verification-done verification-done-bionic
2019-01-15 23:38:22 Launchpad Janitor gjs (Ubuntu Bionic): status Fix Committed Fix Released
2019-01-15 23:38:28 Chris Halse Rogers removed subscriber Ubuntu Stable Release Updates Team
2019-02-01 01:45:41 Daniel van Vugt gjs (Ubuntu Bionic): milestone ubuntu-18.04.2