Remove gjs from s390x

Bug #1794721 reported by Iain Lane on 2018-09-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gjs (Ubuntu)
Undecided
Unassigned

Bug Description

Same deal as bug #1712083. This time it is for mozjs60:

  https://launchpad.net/ubuntu/+source/mozjs60/60.2.1-1

  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=909536

We want to upgrade to the final gjs release for GNOME 3.30, which depends on the new mozjs. Currently we're at the version just before the switch over was made.

I think the list is: ( please excuse the following horror...)

> for pkg in $(reverse-depends -l -a s390x src:gjs | xargs apt-cache show | grep-dctrl -n -sPackage -\! -FArchitecture all | sort -u); do echo "${pkg}"; reverse-depends -l -a s390x ${pkg} | xargs apt-cache show | grep-dctrl -n -sPackage -\! -FArchitecture all; done | sort -u
cortina
gdm3
gnome
gnome-characters
gnome-core
gnome-documents
gnome-maps
gnome-session
gnome-shell
gnome-shell-mailnag
gnome-shell-pomodoro
gnome-sound-recorder
gnome-sushi
polari
ubuntu-desktop
ubuntu-session

Jeremy Bicha (jbicha) wrote :

I'd prefer that we consider moving ubuntu-desktop to a separate source package so that we can easily fully drop s390x support there if we want without having incorrect automatic changelog entries like this one. In that version, ubuntu-desktop wasn't actually built for s390x:

https://launchpad.net/ubuntu/+source/ubuntu-meta/1.406

I'm not sure that I'm willing to take on the task of doing that metapackage split now though.

Iain Lane (laney) wrote :

Thanks for the suggestion, but I'm not going to do that either.

I will probably simply regenerate the metapackage after the removals have happened. This will mean that there is no gnome-shell in ubuntu-desktop on s390x, so the package will be a bit of a lie (doesn't provide a "desktop") but it will still exist.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gjs (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2018-10-03
description: updated
Iain Lane (laney) on 2018-10-03
description: updated
Iain Lane (laney) on 2018-10-03
description: updated
Iain Lane (laney) wrote :

This is done now. I was planning to look into some followup uploads to make sure things don't build uninstallable binaries (BD: gjs or similar)

Changed in gjs (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :

infinity wants new uploads of all the packages that have had removed binaries on s390x so that 1) the build log shows correctly as dep-wait or failed and 2) so that the s390x binaries don't accidentally get copied back to the archive.

I uploaded some of these to the cosmic unapproved queue already.

Iain Lane (laney) wrote :

Some coordination would have been nice.

Iain Lane (laney) wrote :

OK, I just read a half uninformed rant in #ubuntu-release from last night. It would be good to have those rants in future with some of the parties involved up to that point. We could have avoided that mix up with the provides, for example.

Jeremy Bicha (jbicha) wrote :

The provides mixup didn't hurt since I didn't upload to the archive and the Vcs revert was handled quickly. The rebuilds are ok to do though, right?

Jeremy Bicha (jbicha) wrote :

Someone (probably didrocks?) will need to look into the ubuntu-make autopkgtest on s390x. It depends on ubuntu-desktop and tries to use gdm.

Iain Lane (laney) wrote :

I think I would have pushed back on doing no-change rebuilds. I'm not sure there's a precedent for that when doing arch-specific removals.

And I was planning to handle fixing packages that need it (in Debian, then syncing/merging) to Build-Depend on gjs or something properly, after we got the transition in.

(Given how late we are in the release, it was more time sensitive to get the mozjs version switched over than it might otherwise have been.)

It's not *hurting* anything, but I think it could have been done a little bit easier if people had waited instead of rushing around and getting worked up.

Iain Lane (laney) wrote :

Given that it happened the way it did, though, thanks for handling those things. ;-)

Jeremy Bicha (jbicha) wrote :

I believe infinity (or someone like him) had a similar request the last time we removed gjs/390x.

Iain Lane (laney) wrote :

Please make sure to forward any deltas added for this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers