[upgrade request] gjots2 is missing user manual

Bug #257842 reported by codeslinger
0
Affects Status Importance Assigned to Milestone
gjots2 (Debian)
Fix Released
Unknown
gjots2 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gjots2

this is for Hardy 8.04 with gjots 2.3.4

Problem: User Manual is missing

Steps to Reproduce:
1) Install gjots2 using synaptic
2) run gjots2 (Applications/Accessories)

3) click on Help menu
4) click on "Read Manual"

Result: Nothing happens

Expected: Should Open Manual in new window (or perhaps launch web browser??)

Notes: I checked to see if there is a separate gjots2-doc package. There isn't one. And since the manual is a very small file it probably does not make sense to create a separate package for it.

I suspect that this bug could be solved by upgrading the package to the newest version of gjots. There are also several other bugs with have been filed such as bug #115132 which would also be fixed by upgrading to the newest version.

License: GPL
Source: http://bhepple.freeshell.org/gjots/download.html

Changed in gjots2 (Debian):
status: Unknown → New
Revision history for this message
Rolf Leggewie (r0lf) wrote :

Confirming. Still present even in 2.3.8 private package.

Changed in gjots2 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
codeslinger (codeslinger) wrote :

this bug and several others much more serious, caused me to give up on gJots a long time ago. I did have some brief email correspondence with the author a long time ago. I believe this one-man project has been abandoned due to the lack of time on his part and a lack of volunteers to take it over.

TuxCards provides all the same functionality plus additional functionality, and has fewer/no? bugs. I would suggest that TuxCards (www.tuxcards.de) be adopted as the primary app in this category.

Revision history for this message
Detlef Lechner (detlef-lechner) wrote :

This problem still persists.
'~$ uname -a
Linux T43 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux'

Revision history for this message
Rolf Leggewie (r0lf) wrote :

tuxcards is not in Debian (or Ubuntu)

Revision history for this message
Rolf Leggewie (r0lf) wrote :

... and looks pretty dead upstream

Revision history for this message
Rolf Leggewie (r0lf) wrote :

codeslinger, upstream is still cutting new releases. I just uploaded 2.3.9 to mentors.debian.net. I hope it will be sponsored into unstable soon.

Revision history for this message
Rolf Leggewie (r0lf) wrote :

The source code itself doesn't contain any documentation apart from the manpages. So there are three options.

1) patch out the entry from the menu
2) call a shell and open the manpage
3) open a browser with http://bhepple.freeshell.org/gjots/readme2.html

I'm leaning towards #3

Revision history for this message
Rolf Leggewie (r0lf) wrote :

Well, I poked around the code a bit. We ship /usr/share/doc/gjots2/gjots2.gjots.gz. Apparently, that's neither the place nor the format that gjots2 is looking for to display the manual that upstream ships. There's a few other shortcomings, too. One is that the icon for the menu entry is not found. Second, opening another will leave the user without an obvious and easy way to go back to the original document in gjots2. So, there's a number of issues that need to be addressed to fix this properly.

As a stop-gap measure, I'm currently leaning towards #1

Revision history for this message
Rolf Leggewie (r0lf) wrote :
Changed in gjots2 (Ubuntu):
status: Confirmed → In Progress
Changed in gjots2 (Debian):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gjots2 - 2.3.9-2

---------------
gjots2 (2.3.9-2) unstable; urgency=low

  * debian/control:
    - drop build-time dependency on python-all-dev and make lintian happy
    - bump policy to 3.8.4
  * add debian/README.source
  * debian/patches: disable manual entry under Help menu.
    (Closes: #470536, LP: #257842)
  * debian/rules: make sure that quilt actually patches the source

gjots2 (2.3.9-1) unstable; urgency=low

  * New upstream release
 -- Rolf Leggewie <email address hidden> Mon, 15 Feb 2010 15:47:53 +0000

Changed in gjots2 (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Rolf Leggewie (r0lf) wrote :

FWIW, that hack is still needed for 2.3.12

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.