gjots2 side toolbar doesn't have all icons

Bug #115132 reported by Kevin J Brown on 2007-05-16
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gjots2 (Debian)
Fix Released
Unknown
gjots2 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gjots2

The side toolbar for GJots2 only has five icons loaded, though all the buttons work. The five missing icons are from /usr/share/gjots2. The icons load in all other appropriate places. I'm working in feisty.

Esa Oikari (ezuli) wrote :

This bug is still available in Gutsy.

Changed in gjots2:
status: New → Confirmed
Lechuan (lechuan) wrote :

View > Toolbars > Show Icon Text
And you'll get all the icons. It is not pretty, but should serve as a workaround.

Lechuan (lechuan) wrote :

Oops... I might have answered too quickly.
It is the action of enabling/disabling icon texts, rather than the status of icon texts, that causes the icons to show up.
With 'show icon text' enabled, close the application, and reopen it, you'll still get no icons; but than you disable the option, icons appear again.
Kinda weird...

Henrik Nilsen Omma (henrik) wrote :

Still happening on Hardy Beta.

Changed in gjots2:
importance: Undecided → Medium
status: Confirmed → Triaged
Henrik Nilsen Omma (henrik) wrote :

Looks like this is fixed in v. 2.3.7 upstream, but we are only at 2.3.4, as is Debian. http://bhepple.freeshell.org/gjots/new.html

David Schaller (bach-leipzig) wrote :

I can confirm this bug in 2.3.4 with Ubuntu 7.10 (Gutsy). I have six icons missing on the left-side tool bar. This seems to be a regression as a previous version I was using under Ubuntu 6.10 worked fine.

codeslinger (codeslinger) wrote :

In Hardy 8.04 with gjots2 version 2.3.4

I have 3 icons missing. and the suggested work-around does not work as described above.

Instead what works is to display the icon text and then hide the icon text, But without exiting the program. The icons are visible immediately.

Once you exit and restart the program you are back to having missing icons again. In other words you must do the reset every time that you run the program, very annoying.

Nick Hale (nhale25) wrote :

I'm still seeing this in Intrepid 8.10 with gjots version 2.3.4

When is a 2.3.7 likely to be make it to the repositories?

Changed in gjots2 (Debian):
status: Unknown → New
Changed in gjots2 (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gjots2 - 2.3.8-1

---------------
gjots2 (2.3.8-1) unstable; urgency=low

  * Take over maintenance of gjots2 from Khalid El Fathi (Closes: #547057)
    and acknowledge previous NMU uploads. Thank you, Khalid and Sandro for
    your work on this package.
  * New Upstream Version (LP: #406574)
    - display sidebar icons properly (Closes: #446696, LP: #115132)
  * move changes currently made directly to the source into proper patches,
    but don't actually use 20_seascape.patch
  * debian/control
    - recommend instead of depending on mpage and gv (Closes: #475404)
    - fix description, gjots is not a mindmap tool (Closes: #424724)
    - update to standard 3.8.3 and debhelper 5
    - set Vcs information
 -- Ubuntu Archive Auto-Sync <email address hidden> Mon, 30 Nov 2009 23:45:26 +0000

Changed in gjots2 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.