Ubuntu

post-update path changed during karmic upgrade makes the hook a stale link

Reported by Pietro Battiston on 2010-03-10
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gitosis (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gitosis

I started using gitosis in jaunty, and in

~gitosis/repositories/gitosis-admin.git/hooks

which is a fundamental directory (since all gitosis activity is concentrated in what it does when you push a change in configuration), I (automatically) had the link

post-update -> /usr/share/python-support/gitosis/gitosis/templates/admin/hooks/post-update

. Unfortunately, when upgrading to karmic (gitosis 0.2+20080825-15), that file moved to

/usr/share/pyshared/gitosis/templates/admin/hooks/post-update

so the link became stale. This is _very_ unfortunate, since when post-update hook is not run, one can do _nothing_ (in particular I was not able do add a new user), not even enable debug! Moreover, the push of the gitosis-admin repository gives no error, so it is not easy to understand where the problem is (all you get can be for instance a clueless "ERROR:gitosis.serve.main:Repository read access denied" when the user that you think you have enabled tries to access).

As far as I can imagine, this will affect _all_ gitosis users upgrading (the first time they happen to make some configuration change). The only way I can interpret the fact that this bug has not been filed is that either gitosis is really not much used, or that not many servers have been upgraded to karmic.

description: updated
description: updated
summary: - gitosis path changed in karmic upgrade: post-update hook stale link
+ post-update path changed during karmic upgrade makes the hook a stale
+ link
Ron Vaughn (rjv) wrote :

I hit this EXACT same bug tonight. And I just happened to have upgraded to 9.10, and then was trying to get a new mysysgit (windows client) to run. So I spent hours thinking it was windows, not that the symlink was bad. By manually fixing the symlink as described, the gitosis.conf file would properly update itself, and the issue went away.

agent 8131 (agent-8131) wrote :

I ran into this tonight. Luckily having had problems with the post-update hook I thought to check it relatively quickly and noticed it was pointing to the wrong location. This fixed it:

go to your gitosis directory
cd repositories/gitosis-admin.git/hooks
ln -sf /usr/share/pyshared/gitosis/templates/admin/hooks/post-update

This is a difficult thing to fix as peoples repositories will be in different locations. Still it's definitely a usability issue, and seemingly an ongoing one.

Changed in gitosis (Ubuntu):
status: New → Confirmed

I upgraded months ago to Karmic. Just confronted with the bug because adding another repo didn't work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers