libghc-filestore-data dependency not installed

Bug #957402 reported by Matthew Lawson on 2012-03-16
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gitit (Ubuntu)
Undecided
Unassigned

Bug Description

Installing the amd64 version of the gitit package on Ubuntu 12.04 (Beta 1) no longer seems to pull in libghc-filestore-data as a dependency. The program then complains of a missing file (found in libghc-filestore-data) when run to create a repository:

$ gitit
gitit: /usr/share/filestore-0.4.0.4/extra/post-update: openBinaryFile: does not exist (No such file or directory)

Installing the libghc-filestore-data package manually resolves the issue: gitit creates a repository and starts as normal.

# aptitude install libghc-filestore-data
The following NEW packages will be installed:
  libghc-filestore-data
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 7,674 B of archives. After unpacking 59.4 kB will be used.
Get: 1 http://gb.archive.ubuntu.com/ubuntu/ precise/universe libghc-filestore-data all 0.4.0.4-2 [7,674 B]
Fetched 7,674 B in 0s (50.6 kB/s)
Selecting previously unselected package libghc-filestore-data.
(Reading database ... 54200 files and directories currently installed.)
Unpacking libghc-filestore-data (from .../libghc-filestore-data_0.4.0.4-2_all.deb) ...
Setting up libghc-filestore-data (0.4.0.4-2) ...

$ gitit
Created repository in wikidata
Added Front Page.page to repository
Added Help.page to repository
Added Gitit User's Guide.page to repository
Created static/css/custom.css
Created static/img/logo.png
Created templates/footer.st
^C

For reference:

$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

$ apt-cache policy gitit
gitit:
  Installed: 0.8.1-1build1
  Candidate: 0.8.1-1build1
  Version table:
 *** 0.8.1-1build1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Giovanni Mascellani (giomasce) wrote :

I don't know why, but apparently libghc-filestore-data dependency is present on i386 but not on amd64:

http://packages.ubuntu.com/precise/gitit

Giovanni Mascellani (giomasce) wrote :

BTW, I forgot to remind it here, but this problem should be fixed in latest sid version.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gitit (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers