git gui shows error "Spell checking" is unavailable

Bug #890783 reported by Raul SA on 2011-11-15
48
This bug affects 11 people
Affects Status Importance Assigned to Milestone
git (Ubuntu)
Undecided
Unassigned

Bug Description

gitk -> file -> start git gui

Error:

Spell checking is unavailable:
No word list can be found for the languaje "es_ES".

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gitk 1:1.7.5.4-1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Nov 15 18:02:43 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: git
UpgradeStatus: No upgrade log present (probably fresh install)

Raul SA (raulsiguenza) wrote :
Anders Kaseorg (andersk) wrote :

Go to System Settings → Language Support (or equivalently, run gnome-language-selector) and check whether it prompts you to install additional packages. If it does, that should fix your problem. I think the additional package you need in this case is ‘wspanish’.

Changed in git (Ubuntu):
status: New → Invalid
tombo (thomaspreindl) wrote :

In my case the package aspell-de was missing. Try installing aspell-es:
sudo apt-get install aspell-es

SamuelB. (bw-sammy) on 2013-03-26
Changed in git (Ubuntu):
status: Invalid → Opinion
status: Opinion → Invalid
Robbert Korving (robkorv) wrote :

Just had this problem on 12.04.

I would be nice if an install of git-gui would inform check-language-support that it needs aspell and the aspel dictionary of your language.

Changed in git (Ubuntu):
status: Invalid → Confirmed
Robbert Korving (robkorv) wrote :

So the bug is:

When I install git-gui, check-language-support doesn't report that aspell and the aspel dictionary of my language is needed.

aexl (aexl) wrote :

I can confirm this bug.

* language-support didn't report something missing
* yet after manually installing aspell-de the problem was gone

Bernd Kreuss (prof7bit) wrote :

> and check whether it prompts you to install
> additional packages. If it does, that should
> fix your problem.

It doesn't. Although this will install some language related packages it will not fix the problem with git-gui.

Steps to reproduce:

* Install fresh xubuntu 16.04 (choose non-english language during install)
* install git and git-gui
* $ git gui
  -> modal warning about missing spell check pops up every time

* open language settings
  -> some additional packages will be automatically installed
  -> git gui warning still pops up

* install aspell-de (or whatever other language you have)
  -> git gui warning disappears

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers