faulty bash_completion: tags+dirs

Bug #853081 reported by Rolf Leggewie on 2011-09-18
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
git
Unknown
Unknown
git (Ubuntu)
Medium
Unassigned

Bug Description

I use git-buildpackage for maintaining my packages. That means, not only do I have a debian/ directory but also debian/XXX tags. Bash-completion for example for "git log" or "git diff" stops on files, directories and tags. But "git diff debiTAB" will complete to "git diff debian/1.4.9-" instead of "git diff debian/" as it should. The git repository in question has a tag debian/1.4.9-1 and debian/1.4.9-2

git-core package 1:1.7.0.4-1ubuntu0.2 from lucid.

Rolf Leggewie (r0lf) on 2011-10-01
description: updated
Rolf Leggewie (r0lf) on 2011-10-01
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in git (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) on 2012-05-02
Changed in git (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Rolf Leggewie (r0lf) on 2012-05-02
description: updated
Rolf Leggewie (r0lf) wrote :

also forwarded to http://thread.gmane.org/gmane.comp.version-control.git/196823 where I believe the git devs hang out.

Rolf Leggewie (r0lf) on 2013-01-06
summary: - faulty bash_completion
+ faulty bash_completion: tags+dirs
rahmadani (rahmadani) on 2017-04-07
Changed in git (Ubuntu):
assignee: nobody → rahmadani (rahmadani)
status: Triaged → Fix Released
Rolf Leggewie (r0lf) on 2017-04-07
Changed in git (Ubuntu):
assignee: rahmadani (rahmadani) → nobody
status: Fix Released → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.