FFe: Merge git 1:2.17.0-1 (main) from Debian unstable (main)

Bug #1748984 reported by Jonathan Nieder on 2018-02-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
git (Ubuntu)
Undecided
Unassigned

Bug Description

Please merge git 1:2.16.1-1 (main) from Debian unstable (main)

Changelog entries since current bionic version 1:2.15.1-1:

git (1:2.16.1-1) unstable; urgency=low

  * new upstream release (see RelNotes/2.16.txt, RelNotes/2.16.1.txt).
  * debian/control: Breaks: openssh-client (<< 1:6.8) since the latter
    lacks support for the "-G" option (thx Bryan Turner; see
    https://crbug.com/git/7).
  * debian/patches/git-gui-Sort-entries-in-optimized-tclIndex.diff:
    remove; applied upstream.
  * debian/rules: do not install contrib/**/.gitattributes to
    /usr/share/doc (thx Paul Wise and Bastien Roucaries for suggesting
    it through lintian).

 -- Jonathan Nieder <email address hidden> Mon, 05 Feb 2018 12:27:37 -0800

git (1:2.15.1-3) unstable; urgency=low

  * debian/rules: remove remnants of git-core package that prevented
    building twice in a row (thx Andreas Beckmann; closes: #884890).

 -- Jonathan Nieder <email address hidden> Fri, 22 Dec 2017 17:13:42 -0800

git (1:2.15.1-2) unstable; urgency=low

  * gitweb: Recommends: 'apache2 (>= 2.4.6-4~) | lynx | httpd' instead
    of ... | lynx-cur | ... (thx Łukasz Zemczak; see #490265).
  * debian/control: Standards-Version: 4.1.2.0.

 -- Jonathan Nieder <email address hidden> Mon, 18 Dec 2017 09:45:31 -0800

As described in https://bugs.launchpad.net/ubuntu/+source/git/+bug/1729075, Ubuntu's git package is forked from Debian to work around https://bugs.launchpad.net/ubuntu/+source/pcre2/+bug/1636666. The changes to be merged should be minimal.

tags: added: needs-debian-merge upgrade-software-version

Ping. 2.16.2 is now available as well.

summary: - Merge git 1:2.16.1-1 (main) from Debian unstable (main)
+ Merge git 1:2.16.2-1 (main) from Debian unstable (main)
Jonathan Nieder (jrnieder) wrote :

Ping. As described in https://lists.ubuntu.com/archives/ubuntu-devel/2017-December/040080.html, I'm happy to help with making git consumable by Ubuntu on the Debian side in any way I can. Is there anything I can do to help?

summary: - Merge git 1:2.16.2-1 (main) from Debian unstable (main)
+ Merge git 1:2.16.3-1 (main) from Debian unstable (main)
summary: - Merge git 1:2.16.3-1 (main) from Debian unstable (main)
+ Merge git 1:2.17.0-1 (main) from Debian unstable (main)
Matthias Klose (doko) on 2018-04-06
summary: - Merge git 1:2.17.0-1 (main) from Debian unstable (main)
+ FFe: Merge git 1:2.17.0-1 (main) from Debian unstable (main)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers