git ppa build failing on arm

Bug #1957120 reported by Sam Darwin
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
git-core (Ubuntu)
Undecided
Unassigned

Bug Description

The git-core ppa is failing to install on arm architecture.

git : Depends: git-man (< 1:2.33.1-.) but 1:2.34.1-0ppa1~ubuntu18.04.1 is to be installed

The issue is reconfirmed by the message "Failed to build: arm64" , appearing on this page:

https://launchpad.net/~git-core/+archive/ubuntu/ppa

Revision history for this message
Eli Schwartz (eschwartz) wrote :

You seem to have accidentally reported this against the wrong launchpad project.

affects: calibre → git
affects: git → git-core (Ubuntu)
Revision history for this message
Chris Guiver (guiverc) wrote (last edit ):

Thank you for taking the time to report this bug and helping to make Ubuntu better.

You've NOT provided any release details; but there is mention of bionic in your initial post.

If you look at https://launchpad.net/~git-core/+archive/ubuntu/ppa/+packages the builds for bionic & xenial for arm64 & armhf failed; thus problems should have been expected if using either of those releases.

The following will complete the missing details from your report.

Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1957120

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Revision history for this message
Sam Darwin (samueldarwin) wrote :

> thus problems should have been expected if using either of those releases.

Yes, that is the case.

To retest, I launched a brand new instance in AWS. bionic, arm.

Tried to install the ppa and git again. A similar error appeared:

The following packages have unmet dependencies:
 git : Depends: git-man (> 1:2.33.1) but 1:2.17.1-1ubuntu0.9 is to be installed
E: Unable to correct problems, you have held broken packages.
root@ip-172-31-4-136:~#

Then, ran apport-collect.

Not sure if it worked because it said "ignoring..". Here's the output.

# apport-collect 1957120
Package git-core not installed and no hook available, ignoring

*** Updating problem report

No additional information collected.

Press any key to continue...

No pending crash reports. Try --help for more information.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers