git-core doesn't install bindings for emacsen

Bug #188218 reported by Eddy Mulyono on 2008-02-01
6
Affects Status Importance Assigned to Milestone
git-core (Debian)
Fix Released
Unknown
git-core (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: git-core

git distributes contrib/emacs/*.el

These files ended up in /usr/share/doc/*

Probably we can have debian/rules perform dh_installemacsen?

Eddy Mulyono (eddymul) wrote :

interdiff patch for gutsy.

Will work on hardy next.

Daniel Holbach (dholbach) wrote :

Could somebody of the Kernel Team please take a look at this?

Daniel Holbach (dholbach) wrote :

Tim: can you please take a look at it?

Eddy Mulyono (eddymul) wrote :

steps to reproduce:
1. apt-get install emacs git-core
2. open emacs
3. M-x git-status

expected: (emacs prompts for a path, then) magic happens

observed: no such command.

new patch fixes this issue in hardy.

Eddy Mulyono (eddymul) wrote :

PPA was able to succesfully build the package. Results at http://ppa.launchpad.net/eddymul/ubuntu

Eddy Mulyono (eddymul) wrote :

Upstream prefers not to depend on debhelper. I'm "inlining" some of the debhelper commands, but currently, this only works for emacs (vs. other emacsen).

Resulting package is in my PPA version 1.5.4.3-1ubuntu3~ppa2. Works for emacs.

Changed in git-core:
status: Unknown → Incomplete
Eddy Mulyono (eddymul) wrote :

Apparently, my patch in comment 6 doesn't work in a fresh Hardy install. :p

I will delete 1.5.4.3-1ubuntu3~ppa2 and rebuild with debhelper for now, while I learn to unravel debhelper's wonders to satisfy upstream's request.

Eddy Mulyono (eddymul) wrote :

Works now for ubuntu.

I wouldn't mind porting this patch (if there's any extra work at all) to Debian sid, but can someone give me pointers as to what to do? (or what docs to read..)

Alexander Sack (asac) wrote :

when building i get this:
E: git-core: file-in-etc-not-marked-as-conffile /etc/emacs/site-start.d/50git-core.el

i think the right way to do this is to use dh_installemacsen. Since that debian maintainer doesnt want to use debhelper we would need to mimic its behaviour. consider to look at /usr/bin/dh_installemacsen to see what it does. From what i can see its a combination of installing thef iles in /usr/share and adding some postinst/prerm snippets.

e.g. this is what i see in /var/lib/dpkg/info/quilt-el.postinst

if [ "$1" = "configure" ] && [ -x /usr/lib/emacsen-common/emacs-package-install ]
then
        /usr/lib/emacsen-common/emacs-package-install quilt-el
fi

Please adjust your patch accordingly.

Changed in git-core:
status: New → Incomplete
Changed in git-core:
status: Incomplete → New
Bryce Harrington (bryce) on 2008-11-04
Changed in git-core:
importance: Undecided → Wishlist
Changed in git-core:
status: New → Fix Released
Steve Langasek (vorlon) wrote :

AIUI, there is no sponsor-ready patch in this bug, so unsubscribing ubuntu-main-sponsors.

Steve Langasek (vorlon) wrote :

Actually, it looks like this bug is fixed in the version of git-core in jaunty:

$ dpkg -c /home/lp_archive/ubuntu/pool/main/g/git-core/git-core_1.6.0.4-1ubuntu1_i386.deb |grep emacs/site
drwxr-xr-x root/root 0 2008-11-14 00:08 ./etc/emacs/site-start.d/
-rw-r--r-- root/root 10392 2008-11-14 00:08 ./etc/emacs/site-start.d/50git-core.el
$

(technically there's a Debian policy violation because this references files installed under /usr/share/doc instead of moving the .el files somewhere sensible, but that's neither here nor there.)

Changed in git-core:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.