gbp does not support 2nd orig tarball

Bug #668849 reported by Rolf Leggewie on 2010-10-30
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
git-buildpackage (Debian)
Fix Released
Unknown
git-buildpackage (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: git-buildpackage

using a self-compiled, backported 0.5.4 package here (the latest I could backport to lucid)

DebSrc3.0 allows for a second orig tarball [1], but gbp does not appear to support that yet. Try building http://oss.leggewie.org/deb/isdnutils_3.9.20060704+dfsg.2-7.dsc which has an *orig-capi20.tar.bz2 tarball. "gitb-buildpackage --git-ignore-new" won't recreate that tarball.

[1] http://raphaelhertzog.com/2010/09/07/how-to-use-multiple-upstream-tarballs-in-debian-source-packages/

Rolf Leggewie (r0lf) on 2010-10-30
description: updated

On Sat, Oct 30, 2010 at 07:00:33PM -0000, Rolf Leggewie wrote:
> Public bug reported:
>
> Binary package hint: git-buildpackage
>
> using a self-compiled, backported 0.5.4 package here (the latest I could
> backport to lucid)
>
> DebSrc3.0 allows for a second orig tarball, but gbp does not appear to
> support that yet. Try building
> http://oss.leggewie.org/deb/isdnutils_3.9.20060704+dfsg.2-7.dsc which
> has an *orig-capi20.tar.bz2 tarball. "gitb-buildpackage --git-ignore-
> new" won't recreate that tarball.

Gbp deosn't currently handle multiple tarballs at all. I do have some
patches for this though.
 -- Guido

setting status to wip

Changed in git-buildpackage (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Rolf Leggewie (r0lf) wrote :

Any news?

The isdnutils package I maintain is quite complicated and I can no longer support it with gbp in lucid

summary: - gbp does not recreate 2nd orig tarball
+ gbp does not support 2nd orig tarball
Rolf Leggewie (r0lf) wrote :

isdnutils in Debian experimental has this 2nd tarball now if you need a place to have a look. Git repo is at http://git.debian.org/?p=collab-maint/isdnutils.git

On Wed, Feb 02, 2011 at 07:45:01AM -0000, Rolf Leggewie wrote:
> isdnutils in Debian experimental has this 2nd tarball now if you need a
> place to have a look. Git repo is at http://git.debian.org/?p=collab-
> maint/isdnutils.git
I'll try to have a look during fosdem. #561071 has some more discussion.
It'd be great if you could read through this and tell me if it makes
sense to you.
Cheers,
 -- Guido

Rolf Leggewie (r0lf) wrote :

most of the discussion made sense to me. I'll gladly leave worrying about the technical details to others, though.

I believe you mentioned this in that ticket already, so I think it's on your radar. It's my understanding that DebSrc3.0 now unpacks the source with patches applied. One example is the scim package. "git-buildpackage --git-ignore-new;git status" will show a dirty tree (status of patches applied) for that repo. Not sure if the tree should be stored in patched or unpatched state, but git-import-dsc currently imports as unpatched and that leads to the above inconsistency.

Changed in git-buildpackage (Debian):
status: Unknown → New
description: updated
Éric Piel (Delmic) (piel) wrote :

Can anyone suggest a manual workaround to use multiple orig tarballs? I've tried to follow the workflow descibed in the upstream bug [1]. It seems to do the trick for keeping the sources and tarballs, but building fails ("dpkg-source aborting due to unexpected upstream changes").

So far is what I do:
# import the main orig tarball
git-import-dsc PKG.dsc --pristine-tar

# import the next orig tarball in a separate branch into a subdirectory named the same
cd PKG

git checkout --orphan upstream
git rm -rf .
git commit --allow-empty -m 'Initial upstream branch for PKG-ADD.'
git checkout -f master

tar xf PKG_VER-PKG-ADD.orig.tar.gz ../tmp
git-import-orig --upstream-version=VER --upstream-branch=upstream-PKG-ADD --upstream-tag=upstream-PKG-ADD/VER ../tmp

# add the tarball
pristine-tar checkout PKG_VER-PKG-ADD.orig.tar.gz

However it fails to build:
git-buildpackage --git-ignore-new -S
:
dpkg-source: info: local changes detected, the modified files are:
 comedilib/comedi-calibrate/configure
 comedilib/comedi-calibrate/man/comedi_calibrate.8
 comedilib/man/comedi_config.8
dpkg-source: error: aborting due to unexpected upstream changes, see /tmp/comedilib_0.10.0-3ubuntu1.diff.AtK0c1
dpkg-source: info: you can integrate the local changes with dpkg-source --commit
dpkg-buildpackage: error: dpkg-source -i -I -b comedilib gave error exit status 2

Is there some specific trick to do for building too? Could it be due to some weird trick in the package I'm trying to build? (It's comedilib-0.10.0 from Debian unstable)

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=561071#36

On Tue, Jun 04, 2013 at 12:53:14PM -0000, Éric Piel wrote:
> Can anyone suggest a manual workaround to use multiple orig tarballs?
> I've tried to follow the workflow descibed in the upstream bug [1]. It
> seems to do the trick for keeping the sources and tarballs, but building
> fails ("dpkg-source aborting due to unexpected upstream changes").
>
> So far is what I do:
> # import the main orig tarball
> git-import-dsc PKG.dsc --pristine-tar
>
> # import the next orig tarball in a separate branch into a subdirectory named the same
> cd PKG
>
> git checkout --orphan upstream
> git rm -rf .
> git commit --allow-empty -m 'Initial upstream branch for PKG-ADD.'
> git checkout -f master
>
> tar xf PKG_VER-PKG-ADD.orig.tar.gz ../tmp
> git-import-orig --upstream-version=VER --upstream-branch=upstream-PKG-ADD --upstream-tag=upstream-PKG-ADD/VER ../tmp
>
> # add the tarball
> pristine-tar checkout PKG_VER-PKG-ADD.orig.tar.gz
>
> However it fails to build:
> git-buildpackage --git-ignore-new -S
> :
> dpkg-source: info: local changes detected, the modified files are:
> comedilib/comedi-calibrate/configure
> comedilib/comedi-calibrate/man/comedi_calibrate.8
> comedilib/man/comedi_config.8
> dpkg-source: error: aborting due to unexpected upstream changes, see /tmp/comedilib_0.10.0-3ubuntu1.diff.AtK0c1
> dpkg-source: info: you can integrate the local changes with dpkg-source --commit
> dpkg-buildpackage: error: dpkg-source -i -I -b comedilib gave error exit status 2

You should check what's actually in the diff. git-buildpackage shouldn't
try any tarball generation if it already finds one.
Cheers,
 -- Guido

>
> Is there some specific trick to do for building too? Could it be due to
> some weird trick in the package I'm trying to build? (It's
> comedilib-0.10.0 from Debian unstable)
>
> [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=561071#36
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/668849
>
> Title:
> gbp does not support 2nd orig tarball
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/git-buildpackage/+bug/668849/+subscriptions

Changed in git-buildpackage (Debian):
status: New → Confirmed
Changed in git-buildpackage (Debian):
status: Confirmed → Fix Committed
Changed in git-buildpackage (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.