gksu dependency not met for gisomount

Bug #1799323 reported by spike speigel on 2018-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gisomount (Ubuntu)
Undecided
Unassigned

Bug Description

The program gisomount requires the gksu package which was apparently dropped as of 18.04.

I ran into an issue with 18.10 where I installed gisomount, but it fails to start due to the lack of gksu package present. The default application launch command is, "gksudo gisomount". The package dependencies need to be fixed and the package installation should be modified to use some other means instead of relying on a dropped package dependency that is unmet.

Modifying the launch command to "gisomount admin://" will not work. There was an error message stating I require root to run gisomount.

Modifying the launch command to "pkexec gisomount" will not work effectively. It worked once after 5 or 6 crashes.

The only reliable way to start gisomount is to use "sudo gisomount" from a terminal.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: gisomount 1.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
Date: Mon Oct 22 18:47:20 2018
InstallationDate: Installed on 2018-05-10 (165 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gisomount
UpgradeStatus: Upgraded to cosmic on 2018-10-20 (2 days ago)

Revision history for this message
spike speigel (frail-knight) wrote :
tags: added: bionic cuttlefish
tags: removed: cuttlefish
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers