File selected is not an ISO

Bug #105299 reported by Diego Gaustein on 2007-04-10
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gisomount (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gisomount

When trying to mount a game image, I get a "File selected is not an ISO", though mounting it manually works. I can't upload it for debugging, since it's 700mb, and gisomount has no command line options to upload a debug log, so I'd appreciate any hints on how to debug it.

Thanks

Revision history for this message
tosoth (tosoth) wrote :

I have exactly the same problem.

Changed in gisomount:
status: Unconfirmed → Confirmed
Revision history for this message
jimhayes (jthayes) wrote :

When I run gisomount as my administrative user I get the reported problem "-----not an ISO". Running as root I got no display, then the seg fault. Hopes this helps.
  Jim Hayes

Revision history for this message
jimhayes (jthayes) wrote :

to clarify:

sudo gisomount gives the display and the "not an ISO".

su -l
gisomount no display and seg fault.

Also fractured the syntax on those irregular transitive verbs,
but too far off topic.

  Jim

Revision history for this message
Oren (ramico1) wrote :

I had the same problem.

Moving the iso file to different directory solved it.

Revision history for this message
Marcel (marcel-vd-berg) wrote :

Since I converted a Nero-image with nrg2iso (v0.4), all other ISO-images, no longer can't be mounted by gisomount (v1.0.1) "File selected is not an ISO".

Moving the ISO files does not solve the problem.

Revision history for this message
Pete Savage (petesavage) wrote :

I will look into this bug as soon as I can....I apologise for the bug. Can you give me a listing of /media/ please. And the output of file <filename>.

Revision history for this message
Marcel (marcel-vd-berg) wrote :

There's no need for apologies. It could be a bug in nrg2iso as well.
I send the file "media" with the listing as requested.

I never saw the (vcd) entries before, I'll delete these.
Also I didn't notice .hal-mtab, but I guess it should be there.

Revision history for this message
Marcel (marcel-vd-berg) wrote :

I did some additional tests and the results are stunning!

1. Mounting an ISO-file with space(s) in the path, will result in "File selected is not an ISO", but mounting without spaces in the path, will mount as expected.

2. Mounting with spaces and "ISO" in the path ( ~/ISO/with space/image.iso), produces an unexpected error dialog (see attached image)

3. The use of single/double quotes in the path field, does not give an error, but does not mount either.

4. After 3 successful mounts, the 4th will make gISOMount behave unexpectedly.

So I guess these results 1-3 will give a clue where to start. ;-)
I'm afraid #4 could be an other bug.

Revision history for this message
Pete Savage (petesavage) wrote :

OK, I think I know what at least 2 of those are. I will hopefully have some time this week to fix these issues. Not sure how we'll get them put into Intrepid, but I can release an updated package to you in a PPA until then. Once again I do apologise for this, gisomount has been around for a while and was actually the first GUI app I ever wrote in python. :)

I'll get them sorted. There are several other bugs that need fixing too.

Revision history for this message
osiris (michael-gomboc) wrote :

I have the same problem with a lot of my iso files.
There are no spaces in my file names. I made a few tests and I always get
this error when I try to mount DVD iso's generated with k9copy.
A "sudo mount -o loop -t iso9660" is working fine"!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers