Ubuntu

Opening a file on an SMB share gave an error

Reported by Jeramy Rutley on 2004-11-08
8
Affects Status Importance Assigned to Milestone
The Gimp
Fix Released
Wishlist
gimp (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

I used Nautilus to open a jpeg (warning.jpg) located on a Windows machine
(right-click, Open with "The GIMP") and GIMP returned two error dialog boxes:

Jpeg Message
Could not open '/home/jeramy/smb://jrutley/shared/From%20Me/warning.jpg' for
reading: No such file or directory

and I got

GIMP Message
Opening '/home/jeramy/smb://jrutley/shared/From%20Me/warning.jpg' failed:
Plug-In could not open image

I tried moving it to smb://jrutley/shared instead, but I got the same messages
(could not open... smb://jrutley/shared/warning.jpg ...).
I also tried using Eye of Gnome, and it opened there no problem, so we know that
GIMP is the culprit.

http://bugzilla.gnome.org/show_bug.cgi?id=157770: http://bugzilla.gnome.org/show_bug.cgi?id=157770

Matt Zimmerman (mdz) wrote :

I assume this is the same as bug #9768, meaning that gimp can't open files via
gnomevfs

Sebastien Bacher (seb128) wrote :

Yes, apparently gimp doesn't have a vfs support. I've opened a bug upstream
about this:
http://bugzilla.gnome.org/show_bug.cgi?id=157770

Daniel Holbach (dholbach) wrote :

------- Additional Comment #5 From <email address hidden> 2005-03-08 12:11 UTC -------

Very basic (and quite hackish) gnome-vfs support is now in CVS. Optimistically
setting the milestone to 2.4.

Lionel Dricot (ploum) wrote :

confirmed on Dapper 2006-03-30

Changed in gimp:
status: Unconfirmed → Confirmed
Changed in gimp:
status: Unconfirmed → Confirmed
Changed in gimp:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

fixed upstream

Changed in gimp:
assignee: seb128 → desktop-bugs
status: Confirmed → Fix Committed
Timo Aaltonen (tjaalton) wrote :

..and marking as fixed, since the new version has been in Ubuntu for a while already.

Changed in gimp:
status: Fix Committed → Fix Released
Changed in gimp:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.