Ubuntu

Gimp uses all my memory and swap space when opening this small image

Reported by Lakin Wecker on 2007-03-30
10
Affects Status Importance Assigned to Milestone
The Gimp
Unknown
Critical
libexif
Unknown
Unknown
gimp (Ubuntu)
Medium
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Medium
Unassigned
libexif (Ubuntu)
Undecided
Unassigned
Hardy
High
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: gimp

Whenever I open this image in the Gimp is uses up all my available memory (1gb) and Swap Space 3GB before the Gimp is killed by the kernel.

imagemagick's Convert seems to handle it fine and can convert it to a png that is loadable with the gimp. Interestingly enough, if image magick is used to convert this png back to a jpg, the gimp still has problems loading it.

Lakin Wecker (lakin) wrote :

I forgot to add that this is on an up do date install of Feisty. It's an AMD 64 laptop. and I can provide more technical details if necessary.

Jere Kupari (jere-kupari) wrote :

My gimp didn't crash. It made a notice: "raw image plug-In could not open image"
(I have ufraw-plugin installed)

I also am using amd64, but gutsy.

I also tried to exifprobe the picture (don't know if this is relevant):
Software = 'QuickTime 7.1.5\0'
HostComputer = 'Mac OS X 10.3.9\0'
ImageDescription = 'OLYMPUS DIGITAL CAMERA \0'
Model = 'E-500 \0'

kamereon (kamereon) wrote :

This Picture made GIMP 2.4.2 crash on my system, too, while Firefox displayed it correctly. (amd64 Gutsy)
I hope it's ok if i set 'confimed' on this.

Changed in gimp:
status: New → Confirmed
Daniel Hahler (blueyed) on 2008-03-09
Changed in gimp:
importance: Undecided → Medium
status: Confirmed → Triaged
Saša Bodiroža (jazzva) wrote :

The same is happening here, just more frequently. It usually happens when I create a new image. It can also eat up swap space when I just start Gimp.

sam tygier (samtygier) wrote :

still happening with gimp 2.6.0 in intrepid
i let the 'file-jpeg-load' process get to 4GB before killing it

sam tygier (samtygier) wrote :

i ran gimp in gdb, CTRL+Z while it was eating RAM, and made a backtrace

sam tygier (samtygier) wrote :

marked as dupe upstream

sam tygier (samtygier) wrote :

upstream says
"Known bug in libexif. Fixed in CVS, but that fix has still not been released."

Changed in gimp:
status: Unknown → Confirmed
sam tygier (samtygier) wrote :

i have created a debdiff following https://wiki.ubuntu.com/Bugs/HowToFix
please check carefully.

Changed in gimp:
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

This should be fixed in hardy, too, since it crashes the machine very thoroughly.

Changed in libexif:
importance: Undecided → High
status: New → In Progress
Changed in gimp:
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libexif - 0.6.16-2.1ubuntu1

---------------
libexif (0.6.16-2.1ubuntu1) intrepid; urgency=low

  * Fix reading Olympus EXIF tags (LP: #98851) patch from upstream CVS Aug 16 2007

 -- Sam Tygier <email address hidden> Thu, 09 Oct 2008 11:45:51 +0100

Changed in libexif:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libexif:
status: In Progress → Fix Committed
Cesare Tirabassi (norsetto) wrote :

Package in -proposed allows test image to be loaded into gimp.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in libexif:
status: Fix Committed → Fix Released
Changed in gimp:
status: Confirmed → Invalid
spike1 (spike1) wrote :

I don't know if this is the same bug.
But it sounds similar.
Distro: Ubuntu 8.04 LTS. Up to date on patches.
open "memory" in Applications -> other.
put in a digital camera compact FLASH card or memory stick containing jpegs.
Double click on the icon, to get up the file manager, highlight all images and "open with ->" gimp.
Once all images are open, watch the memory monitor as the memory slowly diminishes.
Eventually even swap gets eaten up and OOM killer kicks in.
Close all the images and gimp before this occurs and the memory is not released.
Looking at top shows xorg is holding on to over 1 gig of RAM. The only way to release this is to logout and log back into X.

If this IS the same bug reported in this thread, when will the fix be released?
It's over 6 months since the last message in this thread.
I've included an example pic from my camera. Rename it a few times and open them all in the way described. Watch that ram just fly away.

sam tygier (samtygier) wrote :

spike,
this bug was triggered by opening one small image, and was specific to certain olympus cameras. yours requires opening many images. please can you file a new bug against gimp.

Changed in gimp:
importance: Unknown → Critical
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.