Ubuntu

Wacom Bamboo One tablet random coordinate malfunctions

Reported by Łukasz Zemczak on 2011-09-30
476
This bug affects 99 people
Affects Status Importance Assigned to Milestone
MyPaint
Unknown
Unknown
The Gimp
Unknown
Medium
Xf86 Input Wacom
New
Undecided
Unassigned
gimp (Ubuntu)
Low
Unassigned

Bug Description

The tablet in overall seems to work correctly, with all pressure-features working. But quite frequently, while drawing, GIMP seems to wrongly read the coordinates of the stylus (as zeros, or negative values?), resulting in frequent, random 'line-peaks' in the direction of the left and upper image edges. With this bug it is hard to even use the tablet, since these problems are very frequent (see the exemplary image attached).

The tablet works with no problems in MyPaint. The bug is reproducible in both Unity-2d and Unity-3d.

I also notice the CPU usage increasing dramatically during drawing with any brush.

Steps to reproduce:
1. Connect the Wacom Bamboo One tablet
2. Open GIMP
3. Start drawing longer strokes with any brush

Expected result:
The brush stroke as intended by moving the stylus

Actual result:
The brush stroke as intended with frequent, random line-strokes towards image edges

System: Ubuntu 11.10 oneiric (development branch)
GIMP version: 2.6.11 (package version: 2.6.11-2ubuntu3)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gimp (Ubuntu):
status: New → Confirmed
Lisje (kleinewereld) wrote :

I would like to add that this bug also persists on a Wacom Graphire 4 using Gimp in Unit3D on an Ubuntu Oneiric (fully updated) . I tried to activate / deactivate both my intel and nvidia card hoping to see a difference, but it persists on both cards, leading me to think it is unrelated to my graphics card/driver.

Lisje (kleinewereld) wrote :

I forgot to mention that the tablet works just fin in inkscape

robert shearer (bdaggg) wrote :

Using a Wacom bamboo pen and touch-fun and have the exact same behavior when using the stylus in Gimp.

Using application mypaint the Wacom tablet behaves correctly.

Matthew Meyer (osarusan) wrote :

I've had this bug too, since upgrading to Oneiric. I also get this bug on a clean install of Oneiric.

Not only does it happen in Gimp, but if I drag the stylus on the desktop as well -- to select files on the desktop for example -- it jumps to the corner and selects all of the items. Likewise, if I try to drag a window using the stylus, it jumps and takes the window nearly off of the screen.

diggao (rodrigosr-rio) wrote :

Not only in the wacom tablets that the problem happens.

I have the same problem in a tablet MousePen Genius.

zdenek (4zdenek) wrote :

I have a same problem when using Wacom Bamboo Fun tablet with Gimp. I'm running 11.10 with Gnome Shell .
It seems to work fine in Inkscape.

Deevad (deevad) wrote :

Same problem here ; dramatic case for me as Gimp-painter 2.6 is my main tool for work , makes all the distro unusable for me.
( img : http://img685.imageshack.us/img685/1631/ubuntuoneiricocelotgimp.png )

Here is what I tried without success :
- Update xorg via ppa to xorg edgers
- Update linux-wacom
- Unactivate compiz
- Use Gnome Classic / Gnome Shell / etc...

filsd (filsdd) on 2011-10-17
tags: added: oneiric
diggao (rodrigosr-rio) wrote :

I verified the same problem using only the mouse. I recorded a video:

http://youtu.be/9rDf6_FwKEY

Deevad (deevad) wrote :

I tested also here with this tablet now, and it affect the same :
- Wacom Bamboo Fun A5
- Intuos4 A5 Medium
- Wacom Cintiq 21Ux
- Wacom Intuos3 A4
Gimp 2.7.3+Git compiled from source with Gimp-razor ( http://blog.zanshine.com/blog/stephane-richard/2011-05-10/cutting-edge-gimp-in-latest-ubuntu/ ) seams to not suffer of this, but it really slow and got some 'missed strokes' or 'empty strokes' ( you paint , and nothing appear, as if the brush engine get freezed ).

Deevad (deevad) wrote :

I installed another ubuntu based distrib, Ubuntu Studio 11.10 ( witch is XFCE based ) and ran the same issue.

But this time, after a lot of test, I get it fixed ; and it was after installing sources from Xorg edgers, and upgrade all xorg package via synaptic ( + restart ) , https://launchpad.net/~xorg-edgers/+archive/ppa . This new upgrades made my system use nouveau/mesa/gallium instead of Nvidia proprietary ( I see it running 'glxinfo' inside a terminal ) ...so, maybe nvidia proprietary driver being guilty.

So, I presume I 'sort of' got it fixed ( at least I hope ) and did a 20min painting without any ghost lines problems. I still have to inspect if 3D performances are enough good to run Blender , games , etc... , I don't know a lot this new driver "nouveau/mesa/gallium" . My experience always lead me to had the reflex to install "additional proprietary driver" at first start after a fresh install...

[ info : Test run for Gimp 2.6 - Gimp-painter, from Mizuno ppa + Xorg Edger upgrade + Ubuntu Studio 11.10 ( witch is XFCE based ) ]

Michal Predotka (mpredotka) wrote :

I use ATI graphics card without proprietary driver and still have this issue, so I don't thing it's graphics driver related .
There's a bug reported upstream for this problem: https://bugzilla.gnome.org/show_bug.cgi?id=661872

mrbean71 (m-marti) wrote :

Same here after upgrade from 11.04. before my wacom bamboo pen was perfectly working.

mrbean71 (m-marti) wrote :

Hmmm, it seems is the same using the mouse with painthbrush, at this point I'm not sure is related to wacom maybe, maybe is related to input devices in general?

Alexia Death (alexiade) wrote :

m-marti, is your mouse for some reason enabled as an extended device? If yes, disable it. You wont lose anything as mouse does not provide any extra info for extended devices.

As far as I am aware from my testing with mmiicc, it only affects extended devices and a specific event deliver mechanism known as event history buffer that is provided by X. It's a known source of trouble. According to my tests with mmiicc 2.7 does not exhibit this problem because of this commit: http://git.gnome.org/browse/gimp/commit/?id=dbf844c012894166e312470f0d98560d5e426613 With this I disabled the history buffer use because there are plenty of cheap tablet drivers that get it permanently wrong and 2.7 has event fill that prevents even mice from drawing polygons when moved fast, so milking every single event out of the device is no longer essential.

Alexia Death (alexiade) wrote :

Oh, problems with the event history buffer can originate pretty much anywhere below GIMP, so wacom driver to X to GTK can be the cause... And I don't know of any other application outside gimp that uses it... If you do, let me know.

Alexia Death (alexiade) wrote :

@Deevad the commit I linked can probably very easily ported to painter.

mrbean71 (m-marti) wrote :

Thank you Alexia, hmmmm, I have to check, I'll try and add a comment asap. I'm waiting gimp 2.8 ever more anxiously

Deevad (deevad) wrote :

@Alexia : Thanks a lot for the infos, thanks also for pointing the commit, but I think I'll not try to maintain Gimp-painter 2.6 or support it anymore. At least thats the idea for the moment ( can change in few hours XD ) , I decided to adapt myself to the Gimp dev version , or last realease ( as 2.7.3 , for exemple) .
No textured brushes and no smudgy mixbrush will be the main 2 features I'll drop off in the change ( I also liked 'reduce update frequency' , witch made in Gimp-painter the display faster and improved performance of painting ).
Anyway, compare to many improvement I noticed with time and testing the last dev version , it will be easier to have good mood to update. : )

@all : I tested upgrading to Xorg edgers package and adopt Nouveau driver for a Ubuntu 11.10 main edition. Bug is not happening with this if you use Gimp 2.6. Tested with Gnome Shell desktop mainly . But I'll not keeping this last solution test ; performances are so slow and make it unusable for my taste... Xfce Ubuntu studio 11.10 distro was really faster for displaying the painting strokes.

Łukasz Zemczak (sil2100) wrote :

Thanks everyone for looking into this problem in more detail! I will try the solution given by Alexia as soon as possible. It would be great having a working GIMP with a typically-configured Ubuntu 11.10, since for me, this problem is quite severe.

Alexia Death (alexiade) wrote :

@devaad The reduce update frequency patch was in concept ported to 2.7 long ago along with several other performance boosts. 2.7 is a lot faster than 2.6 was even with large brushes.

naleves (naleves) wrote :

Also affects me in Xubuntu 11.10, with a Bamboo Pen.

thrischan (cvargas-z) wrote :

Hi everybody,

Just got a bamboo connect ctl-470 and was having the same problem. I am using oneiric so a installed the new driver as explained in this post :

https://sourceforge.net/mailarchive/forum.php?thread_name=CAG1eVf398pnsDJ%2Bfm-hzUwyqJqxBCxVt5E1B%2Bi5wyb2LVj8eEg%40mail.gmail.com&forum_name=linuxwacom-discuss

Then ubuntu finally recognized the wacom tablet but got the same problem you are getting.

 I found that if I removed Compiz ( sudo apt-get remove compiz, sudo apt-get remove compiz-core )and reboot, the tablet works just fine in gimp.

Im kind of new to Linux and dont know what exactly does Compiz do. I have been working one day and havent noticed a difference since I removed it ( just a grey background when im logging in for a cople of seconds ) Everything else seems fine. Im using this as a temporary solution to my problem.

Can somebody explain what problems can I possible get because of this solution?

Alexia Death (alexiade) wrote :

That sounds like window manager needs to be added to the list of things that can screw up the history buffer.

Łukasz Zemczak (sil2100) wrote :

@cvargas-z compiz is a compositing manager that uses 3D graphics hardware to create good looking and fast compositing effects on your desktop. In the newer Ubuntu versions, it is primarily used by the Unity graphical shell. When using 11.10 without compiz, your system probably fell back to Unity-2D, which is a Qt/QML based version of the Unity shell. This is not really a bad thing. For better graphics cards, using Unity/compiz makes your shell (the windows, launchers etc.) have better effects and run faster, but the difference is not that big (I am personally using Unity-2D all the time).

thrischan (cvargas-z) wrote :

@sil2100 Thank you very much for explaining this so clearly, So I guess I will be using Unity-2d until this problem is solved.

Michal Predotka (mpredotka) wrote :

Removing compiz does not solve this problem for me. But in fact, the bug appears less often than before.

Deevad (deevad) wrote :

Here I finally ended to remove all , even if updating Xorg edgers and use last Nouveau driver solved my problems, the performance of painting were horrible. Also very slow painting strokes in _all_ 2D programs....

I fallback to a Linux Mint 11 Katya main , based on Natty system with a downgraded compiz ( http://www.webupd8.org/2011/05/how-to-downgrade-to-compiz-086-in.html ) and a downgraded Xorg ( sudo apt-get install xserver-xorg-core=2:1.10.1-1ubuntu1 ) . So a version in between Maverick and Natty , compatible with Natty Ppa :) Works perfectly and damn fast. My laptop will be ready for the conferences I have to do next weeks.

I also get issue with lake of customization / functionality with new Gnome 3 ( I liked the base GUI, and ergonomy , btw ) ; it makes me use too much terminal / GSettings / Tweaks and various code to access to basic customization where Gnome 2 series were fast and mostly GUI tweaks. ( login screen/ place icons on the dockbar/ nautilus script / startup script / etc.... ) So, I felt a real regression. I don't blame Gnome team, new product is young compare to old 9 years old one, and there is very good job in the 3. I blame modern distribution who pack it while it's not a ready solution... imo.

Matthew Meyer (osarusan) wrote :

Are all of you having this problem not only in GIMP but also in the desktop? Try moving a window with your wacom stylus. When you let go of the window, does it jump across the screen?

thrischan (cvargas-z) wrote :

@mpredotka : You are right, I dont know why, I removed compiz at work and I got no problems. I did the same thing at home and the problem considerably less, but was still there.

@osarusan : Yes it happens in the desktop in my computers.

Anybody knows if it is possible to do what deevad did in oneiric? I mean downgrading compiz ( http://www.webupd8.org/2011/05/how-to-downgrade-to-compiz-086-in.html ) and a downgrading Xorg ( sudo apt-get install xserver-xorg-core=2:1.10.1-1ubuntu1 )

Matthew Meyer (osarusan) wrote :

In theory, you might be able to downgrade them using Synaptic and the "force version" option, but there's a very strong possibility that would cause everything to stop working altogether.

But we've already got 20 people on this bug... we should really try to get someone assigned to this if possible. Like some of you, I am a professional artist who uses GIMP, so I have to do my work on a spare computer not running Oneiric until this problem is fixed.

Matthew Meyer (osarusan) wrote :

Also, I think we should update this bug to reflect that it isn't a GIMP bug, but a GTK bug. There's a little more information here: https://bugzilla.gnome.org/show_bug.cgi?id=661872

Basically, since it goes away if you disable the input events in GIMP, and since it affects the desktop too, it can't be a GIMP-specific bug.

thrischan (cvargas-z) wrote :

It seems we will hace to wait Meanwhile, and since this bug doen't affect gimp 2.7 I think this might be a good opportunity to give it a try.

If you are a Linux newbie like me here it is a nice tutorial on how to compile 2.7 it its very easy

http://www.gimpusers.com/tutorials/compiling-gimp-for-ubuntu

Just adding myself into the mix. I've decided to drop WINE+Photoshop and go full on with GIMP and I run into this.

Deevad (deevad) wrote :

*Gimp 2.7+Git compilation info :

 I advice this script : http://blog.zanshine.com/blog/stephane-richard/2011-05-10/cutting-edge-gimp-in-latest-ubuntu/

Here I did local change to the script to make it cleaner :
l.52
opt_dir="/opt"
( to build in opt and keep 2.6 , I also create a 'gimp' folder with 777 right in this /opt/ folder )

l.55
src_dir="$HOME/source-to-compile/gimp-razor/"
(the place I keep the source )

l.186
sudo make install || exit_with "while executing 'make install' for $name"
( I add 'sudo' )

Then I run the script and it work alone automagically. Same to update.
To launch Gimp : it's in a 'bin' folder inside /opt/gimp ... easy to create a launcher.

Matthew Meyer (osarusan) wrote :

I've noticed another bit of strange behavior.

While the bug always seems to be occuring in GIMP, it doesn't appear on the desktop until run xsetwacom to set the range of my stylus for my left monitor (I have a 2-monitor setup).

When I first log in, the stylus covers both screens in absolute mode, and dragging windows creates no strange problems. After I run xsetwacom to set the range, moving windows causes them to jump off the screen after I lift the stylus from the tablet.

Łukasz Zemczak (sil2100) wrote :

I can confirm now that the bug does not appear in GIMP 2.7.3 on Ubuntu 11.10 for me.

Matthew Meyer (osarusan) wrote :

That's good news... however as 2.7.3 won't install on 64bit systems I hope we can get a fix for this asap.

Changed in gimp (Ubuntu):
importance: Undecided → Low
33 comments hidden view all 113 comments
Hannes J (hannesbln) wrote :

Thanks for pointing that out.
After switching my mouse-mode to "Disabled", the mouse behaves now correctly.
So I turned the Pen and Eraser to "Disabled" - and now the tablet lost it's pressure-sensitivity, but the erratic behaviour disappeared. :-/
Pen/Eraser back to Window or Screen - and the problem re-occurs. :-(

PS: I have a dual-screen setup.

YAFU (yafu) wrote :

@alexiade, I think most of the persons that have referred to "mouse" in screen mode has been to point out that the problem occurs with any device in screen mode (mouse or any tablet), not only with the Wacom tablet.
Regards.

diggao (rodrigosr-rio) wrote :

@yafu, @alexiade

Yes, this bug occurs using both the tablet and the mouse. And in different models.
I use a 8x6 Genius MousePen and I'm having the same problem.

thorwil (t-w-) wrote :

Re #73: the bug, or at least the underlying problem is not GIMP-specific. While GIMP will react with drawing a straight line to the edge of the canvas, at least some Krita beta builds crashed due to out-of-range coordinates.

Serial Wacom Intuos 2 here, so the report title and Affects is not accurate.

This makes successful use of any (?) tablet impossible and turns current Ubuntu into a non-option for everyone relying on working with one. I think this suggests a high importance.

sweena (sweena-z) wrote :

I have the same problem with waltop slim tablet on oneiric64 and gnome3
Works fine in inkscape.

Alexia Death (alexiade) wrote :

This is for ubuntu people: As fixing or replacing X can be complcated, there is the patch in master git tree ( http://git.gnome.org/browse/gimp/commit/?id=dbf844c012894166e312470f0d98560d5e426613 ) that could be ported to 2.6 in packaging . you would have working gimp on this broken setup without radical changes.

Favux (favux-is) wrote :

Thank you Alexia.

As I understand it this is a workaround for the bug which would enable Gimp to work in Oneiric and has a very low chance of causing regressions in Gimp. All Ubuntu would need to do is add this patch to their Gimp package to disable the history buffer and release it as an update.

I quickly slapped your link into a patch form so that Launchpad janitor would be aware a patch has been submitted. It is untested and Ubuntu packagers should follow your link to actually obtain the patch.

The attachment "app-Disable-history-buffer-via-use-of-gimprc-option.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Ingo Ruhnke (grumbel) wrote :

For those who don't want to patch and rebuild Gimp themselves, Gimp from PPA with the patch Alexia Death mentioned:

https://launchpad.net/~grumbel/+archive/gimp

Favux (favux-is) wrote :

I can confirm Ingo's PPA using Alexia's disable-history-buffer patch results in Gimp finally being usable in Oneiric. Tested with a Wacom Bamboo Pen and Touch and tablet PC.

There may be a slight problem with very light pressure strokes not coming through (stroke discontinuous) and tool selection being a little sticky. But that just might need a little fiddling. More testing would be helpful of course.

Thank you Ingo. With your PPA we now have a viable alternative while waiting for an official response.

Changed in gimp:
importance: Unknown → Medium
status: Unknown → New
YAFU (yafu) wrote :

Thanks alexiade for the patch! Thanks grumbel for the PPA!

George Fragos (fragos) wrote :

My thanks to grumbel for his PPA that finally got GIMP working with my Bamboo Connect with oneiric and input-wacom-0.12.0. As a photographer and web designer that's all Ubuntu, GIMP is a work requirement and to me "high" priority. Hopefully this all finds it's way into 12.04.

Grumbels PPA adds something more than only this patch, and it caused warning for every startup, so I decided to open my own PPA.

sudo add-apt-repository ppa:aapo-rantalainen/gimp26-noghostline
sudo apt-get update
sudo apt-get install gimp

It contains gimp from Ubuntu 11.10 and patch from post80, nothing more. Truly speaking I do not understand why this patch fixes it, but gimp seems to work now.

diggao (rodrigosr-rio) wrote :

Thank you, Aapo! It worked perfectly.

Lepto (lepto) wrote :

Same bug here, Oneiric, Gimp 2.6 and Wacom Bamboo CTH-460. After adding Aapo PPA and reinstalling Gimp it worked perfectly. Thank you !

I experienced the same issue on 11.10 (kernel 3.0.0-15-generic) with Gimp 2.6.11 under the default window manager. At the same time that I was running Gimp, I had a VirtualBox session running in seamless mode (guest OS application windows appear in the host OS's window manager directly). Upon closing the VirtualBox session and restarting Gimp, the problem disappeared.

Tony Mullins (tony-k-mullins) wrote :

Hey everybody. I had the same problem on a Genius M712X tablet (Waltop International). It now works after getting the update and reinstalling GIMP. Thanks for the great work.

sweena (sweena-z) wrote :

new news: I downgraded to natty, installed everything again, and the waltop slim tablet has worked perfectly until i've installed a new version of blender, blender 6.1 with a lot of new libraries, then the problem returns, so, could it be a library issue?

sweena (sweena-z) wrote :

mmm.. maybe the last comment is not true,
i was installing a lot of things, one of them was the last ati driver from this repository: ppa:ubuntu-x-swat/x-updates
maybe is for that and not for blender
(i've tried to delete the last comment but it's not possible)
natty 64- ati radeon hd- waltop slim tablet

sweena (sweena-z) wrote :

btw adding aapo PPA repositories it works fine!! thanks aapo, so this solution works in Natty too, ;)

Douglas Griffin (stealthdeath) wrote :

@diggao

GENIUS MOUSEPAD 8x6 TABLET FIXED

Confirmed that "sudo add-apt-repository ppa:aapo-rantalainen/gimp26-noghostline" patch worked with UBUNTU 11.10 and Genius Mousepad 8x6.

Procedure:

1. Remove GIMP with Software Center
2. Open Terminal and type the following:

sudo add-apt-repository ppa:aapo-rantalainen/gimp26-noghostline
sudo apt-get update
sudo apt-get install gimp

3. After installation, add back any other related extensions through Software Center.
4. Load GIMP.
5. Configure Input Extensions under Preferences.
6. Disable all pointing devices except for the first tablet listing which you set to SCREEN. (This activates the Pen. The second tablet listing is for the Genius Mouse which you don't need.)
7. SAVE and CLOSE the Input Dialog Box.

Your done. It works. I'm happy again. Thank you Aapo Rantalainen for your help solving a problem that has plagued so many of us. Also thanks to Alexia Death for the initial lead.

Douglas Griffin (stealthdeath) wrote :

Correction on previous post:

That's Genius MOUSEPEN 8x6, not MOUSEPAD.

Sorry if anyone got confused pertaining my bad.

Sue Maurizio (june-itech) wrote :

I can confirm that Aapo's patch also works on Wacom Graphire 4 / Ubuntu 11.10! Thank you very much!

Changed in gimp:
status: New → Unknown
Tim Hoffmann (tim-hoffmann) wrote :

I can confirm the bug in ubuntu 12.4 alpha (64bit) (xorg 1.10.4) on an Asus Eee Slate ep121 Tablet with both the build in wacom digitizer and an usb intuos4 W
As pointed out the problem is not only a gimp (2.6.11) problem. I can generate the lines with the jpen java Tablet library as well.
Since the touch input on the ep121 is currently difficult to get to work, the wacom input is crutial for usability of the device.

Is there any definite confirmation that the bug is fixed in xorg 1.11 ?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.6.11-5ubuntu3

---------------
gimp (2.6.11-5ubuntu3) precise; urgency=low

  * debian/patches/ghost-cursor.patch:
    - Backport patch from git trunk to fix Wacom tablet cursor events
      by ignoring the history buffer by default. LP: #863154
 -- Michael Terry <email address hidden> Thu, 19 Jan 2012 09:05:32 -0500

Changed in gimp (Ubuntu):
status: Confirmed → Fix Released
Michal Predotka (mpredotka) wrote :

Any chance to fix this bug for Ubuntu 11.10?

Just an update for Aiptek users: The aapo patch works for my system. I'm using an Aiptek 12000u USB hyperpad with Ubuntu Linux 11.10. I just came from Lucid and nothing I did would work until I followed stealthdeath's instructions (above) - they work like a charm - I have full functionality within what I have so far tested. Thanks to everybody for you dedicated and selfless help.

Ionflux (ionflux) wrote :

Just applied the aapo patch in Linux Mint 12 / Wacom Graphire 3, and it seems to work. Thanks!

Ian Harris (teasel) wrote :

Aapo's PPA also works with a Tevion MD 41217 tablet, under Mint 12 Lisa, using the xserver-xorg-input-aiptek driver. Thanks Aapo!

Just applied the aapo patch in Linux Mint 12 (Lisa) / Wacom Bamboo Fun (CTE-450)
works great
Thanks!

Magnes (magnesus2) wrote :

This problem occurs also in MyPaint.

Magnes (magnesus2) wrote :

WIll there be any fix soon? Because it makes me unable to work. The problem is system wide - when the jump occurs I click accidentally on Unity icons (so it's not binded to any application - like GIMP or MyPaint). I use MyPaint for my work, so fix only for GIMP isn't enough. :(

Magnes (magnesus2) wrote :

I tried aiptek, wacom, acecad drivers for my tablet and all have this problem (it's probably sth in xserver)...

Magnes (magnesus2) wrote :

Also - the pressure is not affected - only x and y are changing the pressure is registered normally (unfortunately because if the pressure was also 0 we could just filter it out).

Changed in mypaint:
importance: Undecided → Unknown
status: New → Unknown
Andrew Chadwick (achadwick) wrote :

MyPaint doesn't even use the history buffer, or at least it doesn't invoke gdk_device_get_history() anywhere I can see. Could we be seeing two separate bugs here?

Mypaint bug: https://gna.org/bugs/?19896

Anyway, sorry for the noise on a long-fixed bug.

Raymond Wells (rfw2nd) wrote :

It happens for me as well in mypaint. However, I am using a digipro wp8060.. :| Maybe it's a GTK issue?

Phantomgraph (phantomgraph) wrote :

Aapo Rantalainen's patch works with Wacom Graphire 4 (usb) / Ubuntu 11.10 with heavy Gnome 3 mods.

Link => https://bugs.launchpad.net/ubuntu/+source/gimp/+bug/863154/comments/86

It was NOT fixed in the recent gimp update from Ubuntu.

Thanks Aapo!,

PG };8>

Magnes (magnesus2) wrote :

It isn't related to GIMP. It's system wide behavior. The clicks go outside GIMP/MyPaint window - for me the tablet clicks on things in the Unity dash randomly changing x or y coordinate to 0...

Magnes (magnesus2) wrote :

It can't be related to GTK. It must be related to drivers, Compiz or Xorg - sth low level, it's system wide, not limited to apps, try using your tablet as mouse - the same problem occurs.

Magnes (magnesus2) wrote :

PS. Aparently it was fix in latest xserver-xorg-core update on Ubuntu 12.10 (the fix wasn't there in initial version for 12.10).

Displaying first 40 and last 40 comments. View all 113 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.