gimp-2.6 crashed with SIGSEGV in g_closure_invoke() (with oxygen GTK theme)

Bug #742516 reported by Markus Wall on 2011-03-25
474
This bug affects 96 people
Affects Status Importance Assigned to Milestone
gimp (Debian)
Fix Released
Unknown
gimp (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: gimp

Crashes on startup.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: gimp 2.6.11-1ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Fri Mar 25 15:47:51 2011
ExecutablePath: /usr/bin/gimp-2.6
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110303)
ProcCmdline: gimp
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
 LANGUAGE=
SegvAnalysis:
 Segfault happened at: 0x7f0b7e84796c: mov 0x50(%rbx),%rdi
 PC (0x7f0b7e84796c) ok
 source "0x50(%rbx)" (0x00000050) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gimp
StacktraceTop:
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gimp-2.6 crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (knotify4:1558): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
 (firefox-bin:1694): GLib-CRITICAL **: g_hash_table_insert_internal: assertion `hash_table != NULL' failed

Markus Wall (mwall) wrote :

StacktraceTop:
 gtk_text_view_set_attributes_from_style (widget=0x2325350, previous_style=<value optimized out>) at /build/buildd/gtk+2.0-2.24.3/gtk/gtktextview.c:6380
 gtk_text_view_style_set (widget=0x2325350, previous_style=<value optimized out>) at /build/buildd/gtk+2.0-2.24.3/gtk/gtktextview.c:3980
 g_closure_invoke (closure=0x223c2d0, return_value=0x0, n_param_values=2, param_values=0x232ec30, invocation_hint=0x7fff4ad14f40) at /build/buildd/glib2.0-2.28.4/./gobject/gclosure.c:767
 signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0x2325350, emission_return=0x0, instance_and_params=0x232ec30) at /build/buildd/glib2.0-2.28.4/./gobject/gsignal.c:3182
 g_signal_emit_valist (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>, var_args=<value optimized out>) at /build/buildd/glib2.0-2.28.4/./gobject/gsignal.c:2983

Changed in gimp (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public

solved by switching from oxygen-gtk to raleigh [and back again] in KDE GTK+ Appearance systemsettings.

nivlac (carndt) wrote :

Switching from oxygen-gtk to raleigh [and back again] in KDE GTK+ Appearance systemsettings did not help on my system. :(

mu3en (mu3en) wrote :

does it work with raleigh?

It worked for me. I had to start gimp with raleight, close it and then swith back to oxygen-gtk.

mu3en (mu3en) wrote :

so need to switch theme. load gimp once. quit. then switch theme back.

first post was probably misleading in that sense...oops

nivlac (carndt) wrote :

yeah that must be the key.
I set raleigh,
started gimp (it started fine)
reverted oxygen-gtk
tried gimp again (started fine!)

/me <grins!>

Alessandro Lanave (ingalex) wrote :

If I switch theme Gimp doesn't start too.

Markus Wall (mwall) wrote :

Switching theme, starting Gimp, switching back works for me. Guess that's the workaround until it gets properly fixed.

tags: added: bugpattern-needed
Tommy_CZ (t-kijas) wrote :

Confirmed but switch to raleight didn't help me.

Sam Rog (samrog131) wrote :

Here the "Widget style: QtCurve" seems to work. Package: gtk2-engines-qtcurve

jovan dragisic (jdragisic) wrote :

Same here, 11.04 x86. The Gtk appearance workaround does the trick.

Sandor Oroszi (godot) wrote :

Here, too. Switching to Raleigh, starting, exiting, switching back to oxygen-gtk solves the problem.
Kubuntu 11.04, x86_64

On 23/04/11 12:31, Sandor Oroszi wrote:
> Here, too. Switching to Raleigh, starting, exiting, switching back to oxygen-gtk solves the problem.
> Kubuntu 11.04, x86_64
>
Here also,

Switching to Raleigh, starting, exiting, switching back to oxygen-gtk solves the problem.
Kubuntu 11.04, x86_64

Interesting in that the workaround fixes the problem (i.e the gimp starts) but still shows errors on startup, without the seg fault though
Initial try at starting

Notebook-PC:~$ gimp

(gimp:4393): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
Segmentation fault

Then after the style switch (open and then close the gimp)
Notebook-PC:~$ gimp

(gimp:4475): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

(gimp:4475): Gimp-Widgets-WARNING **: gimp_dialog_factory_dispose: stale non-toplevel entries in factory->open_dialogs

Same GLib warning, as initially, which is still present after restoring the Oxygen style (but the gimp still works) - I don't know if this information helps any or is just a more elaborate 'me too'
Peter

Frido Otten (fridi) wrote :

I can confirm this on a fresh 32 bit natty install. The GTK workaround didn't work for me but I found a different workaround:

# mkdir ~/.gimp-2.6
# gimp

voila

Somehow it struggles about not being able to find the directory. Once it exists, there's no problem.

Onewing (williammitc) wrote :

Switch to Raleigh and back worked on my Kubuntu 11.04 x86-64. Thanks.

Ivo Anjo (knuckles) wrote :

The workaround in comment #19 worked for me.

VF (fviktor) wrote :

It is well possible that comment #19 above points out the real cause of this problem, thanks to Frido Otten. GIMP seems to be unable to create its configuration folder (~/.gimp-2.6) or the code looking for a possibly existing configuration folder is crashing due to a coincidence with another folder introduced in Ubuntu 11.04.

It would also be useful to figure out what is changed by just "switch to Raleigh and back", which worked for Onewing. A directory or another object is created somewhere, possibly, which helps GIMP to avoid executing the problematic case.

mu3en (mu3en) wrote :

relatively certain there was already a gimp folder unless the version changed from maverick to natty (and since settings remained as set, that seems unlikely?

Maarten Bezemer (veger) wrote :

Workaround of comment #19 fixed it for me as well, only the

GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

warning is still present! So it seems that there are 2 different problems?

I can confirm that creating the folder ~/.gimp-2.6 fixes the problem that I had as described in the duplicate: https://bugs.launchpad.net/ubuntu/+source/gimp/+bug/775586

If I create ~/.gimp-2.6 gimp starts fine. If I delete ~/.gimp-2.6 gimp crashes with a segfault again and re-creating ~/.gimp-2.6 fixes the problem (again).

Polemos (temp2417) wrote :

Switching to Raleigh and back worked on Kubuntu 11.04 here also.

Mark Fraser (launchpad-mfraz) wrote :

I'm also seeing this with gtk-gnutella, but the above fix of changing widget style to Raleigh, running it and then changing back to oxygen-gtk doesn't work.

Maarten Bezemer (veger) wrote :

@Mark does the create-folder workaround work for you? (see comment 19)

Patrick T. (p1703) wrote :

Why does it take so long to get one of the most important applications of this distribution working??? This bug report was made almost 2 months ago, many users out there cannot use their system. Ok, you found the real cause "only" 10 days ago - but does it take several weeks to deliver a script that creates a directory???

Create-folder workaround works for me. Thanks to Frido Otten.

dmatt (martind) wrote :

kubuntu natty 64, same segmentation fault

~/.gimp-2.6 did not exist
however, it was possible to start gimp from terminal by using sudo

workaround described in #10 worked for me, and ~/.gimp-2.6 now exists
however, warning still persists
GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

aizquier (aizquier) wrote :

I confirm the same problem running Ubuntu 11.04 32bit on a virtual machine (VirtualBox), using Kubuntu. The workaround reported by Frido did solved the issue.

This bug has a good stack trace, is indicated to affect 18 people, and has 32 duplicates (one of which, bug 757653, is indicated to affect 10 people, which might or might not overlap with the 18 people here). The bug has been extensively discussed and the circumstance under which it occurs are at least reasonably well understood and expressed. Therefore, I think there is far more than enough justification for marking this as Confirmed.

Changed in gimp (Ubuntu):
status: New → Confirmed
Changed in gimp (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
importance: High → Medium
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Pedro Villavicencio (pedro) wrote :

This seems to be a gtk2-engines-oxygen; as a workaround for now please change that theme for another and restart the app.

mu3en (mu3en) wrote :

the workaround has been well understood, documented, and tested already. think the point was to be able to start gimp without a crash in the first place, without using a workaround?..

Pedro Villavicencio (pedro) wrote :

mu3en exactly that is why i've targeted to be fixed and assigned to the team to have a look at it, moreover such comments doesn't help at all if you really want to help the bug to be fixed without using the workaround submit a patch. Thanks.

Changed in gimp (Ubuntu Natty):
importance: Medium → High
Changed in gimp (Ubuntu):
importance: Medium → High
mu3en (mu3en) wrote :

that's kinda harsh maybe. pretty sure i proposed the workaround in the first place early in testing. was more concerned that it was not documented somewhere immediately obvious for other users, since gimp should be a fairly common app. totally happy to do that or help out otherwise if asked.

Hans Joachim Desserud (hjd) wrote :

Bug 802518 describes a seg fault in ardour, and includes the same workaround (oxygen-gtk -> raleigh). Could someone check if this issue is related or not?

Martin Pitt (pitti) on 2011-07-11
Changed in gimp (Ubuntu):
importance: High → Medium
Changed in gimp (Ubuntu Natty):
importance: High → Medium
summary: - gimp-2.6 crashed with SIGSEGV in g_closure_invoke()
+ gimp-2.6 crashed with SIGSEGV in g_closure_invoke() (with oxygen GTK
+ theme)
Shaikailash (steve-doc-brown) wrote :

Same bug on Kubuntu 11.04 64bit, all updated, no external ppa, only official repos.
Bypassed with this workaround:

- set GTK theme to raleigh
- start GIMP once
- set GTK theme back to oxygen-gtk
- GIMP now works with oxygen-gtk, too

Source:
http://ubuntuforums.org/showthread.php?p=10756351

iLugo (isra) wrote :

I am also affected. Kubuntu 11.04 64 bit, up to date. Also I am using Oxygen. Note that the original installation was actually Ubuntu (with the horrible Unity) and I installed Kubuntu desktop on top of it, and was forced to use gdm (else if switched to Unity, it would not load desktop).

I have not yet tried the workarounds. I do not have at this moment the ~/.gimp-2.6 folder.

@Martin Pitt: I am wondering: Why would such a bug (a show stopper!!) have its "importance" lowered from High to Medium? What is the criteria here? A user click the gimp icon and the system does not do anything. Hello? aren't we talking about The gimp here? Is the criteria to not consider it High priority because it happens with Oxigen? so what? isn't that still critical to an user? If Photoshop would be crashing when a Windows or Mac user would be using certain window decoration, how acceptable would it be for any user whatsoever that Microsoft/Apple would not consider such bug High priority?
Why Linux would have to have this attitude towards their users? The gimp is a flagship for Linux ! don't you see that? When compared to Oxygen, who cares for Oxygen in this context?

Secondly, it has not been explained yet which one is the "best" workaround: to change window decorator or to create the missing directory? What about any other themes? I don't have Raleigh.

iLugo (isra) wrote :

Correction, I do have raleigh, I just did not look in the right place (System Settings -> Application Appearance -> GTK+ Appearance -> Widget style.
I did as in post #39, gimp now works, although still it gives the following error when launched from a terminal prompt:

(gimp-2.6:5552): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

(gimp-2.6:5552): Gimp-Widgets-WARNING **: gimp_dialog_factory_dispose: stale non-toplevel entries in factory->open_dialogs

The missing folder ~.gimp-2.6 now obviously exists.

@iLugo
I cannot speak for Martin Pitt, nor for Canonical, but I believe I can explain why this bug is (and should be) of Medium rather than High importance.

Importance for bugs in Ubuntu is assigned according to the priority in the Ubuntu project as a whole, and the effect of the bugs on Ubuntu users generally. This bug affects only a minority of Ubuntu users using GIMP, and GIMP is itself not nearly as heavily used a package as many other packages. If you search Launchpad to see what bugs *are* marked High, you'll see that they tend to be much broader in scope or have much more serious and unmitigable effects. The more bugs are marked High, the less meaningful it is for a bug to be marked High. This bug simply does not warrant that label.

There is no parallel between GIMP in Ubuntu and Adobe Photoshop running on Windows and Mac OS X, and that topic is irrelevant to what this bug's importance should be. Those operating systems do not provide Photoshop (nor hardly any applications) as a component of the system, and they take no responsibility at all for whether or not Photoshop works. Photoshop could break for *all* users of Mac OS X or Windows and it is unlikely that Apple or Microsoft would be considered responsible in the slightest. Adobe is considered to be fully responsible for whether or not Photoshop works in any particular situation. However, if Microsoft or Apple provided support for Photoshop and it stopped working for a minority of users, and the OS vendor provided information about how to easily work around the problem, it seems unlikely that anyone would criticize the OS vendor for failing to prioritize fixing the problem. Actually, it seems unlikely that anyone would expect the OS vendor to make any effort at all to fix a problem with an easy workaround that affected so few users. (Fortunately, the standard to which Ubuntu's user community holds Canonical and the Ubuntu project is much higher than the standard to which most desktop OS vendors' customers hold them.)

VF (fviktor) wrote :

With this much effort put into various posts here the actual bug could be solved multiple times...

Changed in gimp (Debian):
status: Unknown → Fix Released
Ancoron Luziferis (ancoron) wrote :

Quite funny (from a software development PoV) that...

a) ...some "theme" is able to break software
b) ...that the "theme" integration is supposed to be rock solid (otherwise would've been shielded)
c) ...that there is no fall-back mechanism

Cheers,

     Ancoron

teh603 (darth-giles) wrote :

The workaround in post 25 worked for me.

Martin Pitt (pitti) on 2012-03-13
Changed in gimp (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
teh603 (darth-giles) wrote :

I haven't had any issues related to this bug in a long time, so is there any reason why its still in the tracker?

noamik (spam-noamik) wrote :

This problem affects me and neither of the proposed fixes helps. I'm using Xubuntu though. When starting gimp with sudo, it works as expected ...

noamik (spam-noamik) wrote :

I should add I'm not using the oxygen theme, yet I'm still affected by this bug ...

dino99 (9d9) wrote :

upstream fix

Changed in gimp (Ubuntu Natty):
status: Confirmed → Invalid
Changed in gimp (Ubuntu):
status: Confirmed → Fix Released
Tom (tom6) wrote :

Hi :)
Just had the problem again on Ubuntu 14.04. The work-around;

mkdir ~/gimp-2.8

fixed it. But then it grumbled that;

Failed to parse tag cache: No such file or directory

which didn't seem to stop gimp from working. However after closing gimp, which i had run from the command-line, i found it had grumbled about several missing sub-folders so i had to do;

cd ~/gimp-2.8
mkdir palettes
mkdir gradients
mkdir patterns
mkdir dynamics
mkdir brushes

I'm sure a more linuxy way would be something like this

mkdir ~/gimp-2.8
cd ~/gimp-2.8
mkdir palettes gradients patterns dynamics brushes

I can't help feeling i'm missing quite a lot of useful stuff in my version of gimp now but i only need it for cropping at the moment and that works fine.
Regards from
Tom :)

To post a comment you must log in.