GIMP: Embed page setup dialog functionality in the print dialog

Bug #680521 reported by Till Kamppeter on 2010-11-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Bilal Akhtar
The Gimp
Fix Released
Medium
gimp (Ubuntu)
High
Sebastien Bacher

Bug Description

Binary package hint: gimp

There is a possibility of embedding the paper size combo and orientation
combo in the print dialog since Gtk+ 2.17.4. It is activated by calling the
gtk_print_operation_set_embed_page_setup() function.

It would be nice to have this feature also in the GIMP, as photos do not have an
absolute size. You select the print size of a photo only when you actually
print it and photos are often printed on sizes which are not the standard size
of the printer (4x6 inches/10x15 cm). So the page size and orientation should
be easily accessable during the printing action, which means that they are best
placed in the printing dialog.

To implement this one only needs a small patch doing the following things:

 - Remove the "Page Setup" menu entries (and toolbar buttons)
 - Remove call-back functions to open the "Page Setup" dialog
 - Add call of gtk_print_operation_set_embed_page_setup() function to
   initialization of print dialog
 - Add calls to load page setup setting on print dialog initialization and
   save them on OK/Print/Apply in print dialog (to remember next print dialog
   call or even next session).

See the patches attached to

https://bugzilla.gnome.org/show_bug.cgi?id=614451
http://trac.yorba.org/ticket/2733

See also the Ubuntu Blueprint for improving usability of photo printing:

https://blueprints.launchpad.net/ubuntu/+spec/packageselection-desktop-n-improve-photo-printing

This is also reported upstream:

https://bugzilla.gnome.org/show_bug.cgi?id=635615

Related branches

Changed in gimp (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in gimp:
importance: Unknown → Medium
status: Unknown → New
Vish (vish) on 2010-11-24
Changed in gimp (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
status: New → Triaged
Vish (vish) on 2010-11-24
Changed in hundredpapercuts:
importance: Undecided → Medium
milestone: none → nt8-featured
Changed in gimp:
status: New → Confirmed

Does this really still count as a papercut since GIMP is no longer included in default Ubuntu?

Vish (vish) wrote :

Chris, yea, this cycle we are including applications in the featured section too :) : https://launchpad.net/hundredpapercuts/+milestone/nt8-featured

Bilal Akhtar (bilalakhtar) wrote :

Working on this one upstream.

Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → Bilal Akhtar (bilalakhtar)
status: Triaged → In Progress
Changed in hundredpapercuts:
milestone: nt8-featured → precise-9-miscellaneous
Bilal Akhtar (bilalakhtar) wrote :

Patch has been accepted in upstream master branch:
https://bugzilla.gnome.org/show_bug.cgi?id=635615

Changed in gimp:
status: Confirmed → Fix Released
Till Kamppeter (till-kamppeter) wrote :

GIMP got fixed upstream. Can the fix get backported to the GIMP package of Ubuntu Precise before Feature Freeze? Having printing working well in GIMP would be great for the LTS.

Changed in gimp (Ubuntu):
importance: Medium → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
milestone: none → ubuntu-12.04-beta-1
Sebastien Bacher (seb128) wrote :

The commit is http://git.gnome.org/browse/gimp/commit/?id=bdc3f7e7e0495b599a712c917d6ab17f05f92164 and seems sane enough to backport, I will have a look to that later

Martin Pitt (pitti) on 2012-02-13
Changed in gimp (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
Changed in gimp (Ubuntu):
status: Triaged → Fix Committed
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.6.12-1ubuntu1

---------------
gimp (2.6.12-1ubuntu1) precise; urgency=low

  * Merge from Debian unstable (LP: #925674). Remaining Changes:
    - debian/patches/02_help-message.patch,
      debian/patches/03_gimp.desktop.in.in.patch:
      + Update some strings for Ubuntu
    - debian/patches/ghost-cursor.patch: fix Wacom tablet cursor events
    - debian/control:
      + Update description
    - debian/rules:
      + Set gettext domain and update translation templates

  * Drop poppler patch as it's been applied upstream
    - drop debian/patches/poppler0.18.patch
    - update debian/patches/series
  * fix LP: #680521 - Embed page setup dialog functionality in the print dialog
    - add debian/patches/embed-page-setup-dialog.patch
    - update debian/patches/series

gimp (2.6.12-1) unstable; urgency=low

  * Imported Upstream version 2.6.12
  * Add ${misc:Depends} variables to packages that were missing it
  * Call default versioned python binary instead of just /usr/bin/python

gimp (2.6.11-8) unstable; urgency=low

  * Really add the patch this time (Closes: #651387)

gimp (2.6.11-7) unstable; urgency=low

  * poppler0.18.patch: Port file-pdf plugin to poppler 0.18 API. Patch taken
    from Fedora via Ubuntu.
    (Closes: #651387)

gimp (2.6.11-6) unstable; urgency=low

  * libpng_compile.patch:
      - Apply patch from upstream to fix compilation with libpng 1.5
        (Closes: #649972)
 -- Micah Gersten <email address hidden> Wed, 22 Feb 2012 23:47:53 -0600

Changed in gimp (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.