Ubuntu

Gimp's description is too confusing

Reported by Mohamed Amine Ilidrissi on 2010-06-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Sam L.
gimp (Debian)
Fix Released
Unknown
gimp (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gimp

Here's The Gimp description in the software center:

"GIMP lets you draw, paint, edit images, and much more! GIMP includes the functionality and plug-ins of other famous image editing and processing programs.

If you'd like to be able to open files remotely (like over HTTP or FTP), install the gvfs-backends package.

If you'd like to use a MIDI device as an input controller in GIMP, install libasound2 and read the how-to at /usr/share/doc/gimp/README.MIDI

If you'd like to be able to read and write PostScript files from GIMP, install the ghostscript package."

As you can see, the majority of the text is geeky.

[Suggested description]
-----
GIMP is an advanced picture editor. You can use it to edit, enhance,
and retouch photos and scans, create drawings, and make your own images.
Lots of tools are available; you can sharpen and resize photos, and
remove dust and red-eyes, for example.

It has a large collection of professional-level editing tools and
filters, similar to the ones you might find in PhotoShop. Numerous
fine-control settings and features like layers, paths, masks, and
scripting give you total control over your images.

Many image file formats are supported, including JPEG, PhotoShop (.psd),
and Paint Shop Pro (.psp) files. It can also be used to scan and print
photos.
-----

Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

- GIMP is no longer part of the default install , therefore not a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Vish (vish) wrote :

Oops! , that comment was meant for Bug #599079

Changed in hundredpapercuts:
status: Invalid → New
Vish (vish) on 2010-07-03
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-9-sc-metadata
status: New → Triaged
Changed in gimp (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
tags: added: metadata
Sam L. (somethinginteres) wrote :

Does the 'geeky' stuff need to be in there at all? Would it just be a matter of removing it?

Vish (vish) wrote :

The last three lines can be removed. However GIMP is a "Featured Application" too , we could improve its description. Any suggestions? ;)

Andrew (and471) wrote :

Maybe use some stuff from the GIMP website: http://www.gimp.org/about/introduction.htm ie.

GIMP lets you draw, paint, edit images, and much more! GIMP includes the functionality and plug-ins of other famous image editing and processing programs.

It has many capabilities. It can be used as a simple paint program, an expert quality photo retouching program, an online batch processing system, a mass production image renderer, an image format converter. Its inbuilt scripting interface mean even the most complex of operations are possible.

I would say that is a good idea but to perhaps avoid technical terms? Those
that need Something like "GIMP is an image manipulation program that has
been designed to be extensible to accomplish just about anything. Draw,
paint, edit images, and much more!".

On Tue, Jul 6, 2010 at 4:51 PM, Andrew <email address hidden> wrote:

> Maybe use some stuff from the GIMP website:
> http://www.gimp.org/about/introduction.htm ie.
>
> GIMP lets you draw, paint, edit images, and much more! GIMP includes the
> functionality and plug-ins of other famous image editing and processing
> programs.
>
> It has many capabilities. It can be used as a simple paint program, an
> expert quality photo retouching program, an online batch processing
> system, a mass production image renderer, an image format converter. Its
> inbuilt scripting interface mean even the most complex of operations are
> possible.
>
> --
> The Gimp's description is too confusing
> https://bugs.launchpad.net/bugs/599785
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: Triaged
> Status in “gimp” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: gimp
>
> Here's The Gimp description in the software center:
>
> "GIMP lets you draw, paint, edit images, and much more! GIMP includes the
> functionality and plug-ins of other famous image editing and processing
> programs.
>
> If you'd like to be able to open files remotely (like over HTTP or FTP),
> install the gvfs-backends package.
>
> If you'd like to use a MIDI device as an input controller in GIMP, install
> libasound2 and read the how-to at /usr/share/doc/gimp/README.MIDI
>
> If you'd like to be able to read and write PostScript files from GIMP,
> install the ghostscript package."
>
> As you can see, the majority of the text is geeky.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/599785/+subscribe
>

I would say that is a good idea but to perhaps avoid technical terms altogether to avoid scaring people off? Those that need the complex features will know they're available. Something like "GIMP is an image manipulation program that has been designed to be extensible to accomplish just about anything. With GiMP, draw, paint, edit images, and much more!".

Vish (vish) wrote :

Suggestion from Phil Bull [https://lists.ubuntu.com/archives/ubuntu-doc/2010-July/014952.html]:

GIMP is an advanced picture editor. You can use it to edit, enhance,
and retouch photos and scans, create drawings, and make your own images.
Lots of tools are available; you can sharpen and resize photos, and
remove dust and red-eyes, for example.

It has a large collection of professional-level editing tools and
filters, similar to the ones you might find in PhotoShop. Numerous
fine-control settings and features like layers, paths, masks, and
scripting give you total control over your images.

Many image file formats are supported, including JPEG, PhotoShop (.psd),
and Paint Shop Pro (.psp) files. It can also be used to scan and print
photos.

summary: - The Gimp's description is too confusing
+ Gimp's description is too confusing
Vish (vish) on 2010-07-11
description: updated
Sam L. (somethinginteres) wrote :

Phil's suggestion is good. It gives a description that is both informative and not confusing. Though I'd suggest moving "It can also be used to scan and print photos." to the top paragraph rather than having it tacked on to the end of the paragraph discussing file-type support. So, like this:

"GIMP is an advanced picture editor. You can use it to edit, enhance,
and retouch photos and scans, create drawings, and make your own images.
Lots of tools are available; you can sharpen and resize photos, and
remove dust and red-eyes, for example. It can also be used to scan and print
photos."

Changed in hundredpapercuts:
assignee: nobody → Sam L. (thelandofwa)
Vish (vish) wrote :

Thanks for sending to debian.

Changed in gimp (Ubuntu):
status: Confirmed → Triaged
Changed in gimp (Debian):
status: Unknown → New
Vish (vish) wrote :

@ Sam L. , could you attach the debdiff on lp and subscribe the sponsors?

Vish (vish) wrote :

@ Sam L. , We are nearing UIF, could you attach the debdiff on lp and subscribe the sponsors?

Sam L. (somethinginteres) wrote :

Here's the debdiff - subscribing sponsors.

Vish (vish) on 2010-08-20
Changed in hundredpapercuts:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.6.10-1ubuntu3

---------------
gimp (2.6.10-1ubuntu3) maverick; urgency=low

  [ Sam L. ]
  * Changed the description in debian/control to be less confusing.
    (LP: #599785)
 -- Robert Ancell <email address hidden> Fri, 27 Aug 2010 12:11:20 +1000

Changed in gimp (Ubuntu):
status: Triaged → Fix Released
Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in gimp (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.