the right click on image menu is missing all icons

Bug #599079 reported by benste on 2010-06-27
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Gimp
Fix Released
gimp (Ubuntu)

Bug Description

Binary package hint: gimp

IN previous version, and the windows version had small icons indicating the function as in the main tools window.
Having a list with the same functions it's very confusing to see about 20 entrys withouht icons.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gimp 2.6.8-2ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Jun 27 19:12:05 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: gimp

benste (benste) wrote :
Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

- GIMP is no longer part of the default install , therefore not a papercut.
For further information about papercuts criteria, please read

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
benste (benste) wrote :

HI Vish, thx for taking a look into it - however this isn't a GIMP specific bug - this affects ALL applications within Ubuntu which use icons in a menu also FF and others !

Changed in hundredpapercuts:
status: Invalid → New
Vish (vish) wrote :

@Benste , I believe you are referring to Bug #407621 , do note who was the reporter of that bug ;-)
The change to not show icons was a design decision.
However , the menu items indicating certain actions like Flip Horizontal/Rotate clockwise and sort , should display an icon. Hence the GIMP task is open , Kindly read the Bug #407621 and make a list the actions which are confusing due to the missing icons. It *needs* to be fixed in GIMP.

Changed in hundredpapercuts:
status: New → Invalid
benste (benste) wrote :

Vish thx for giving me the link - I've heared about this discussion but didn't find the other post.

Anyway here is my GIMP Bug:

For usability reasons the following icons in the menu should be forced to show an icon:

background color fill < IMPORTANT
foreground color fill < IMPORTANT
scale image
ALL Tools - should get the same as in the toolbox !

and some less often used ones :-)

tags: added: menu-icons
Vish (vish) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at
Once submitted upstream , do report back here with the upstream bug number.
Thanks in advance!

affects: hundredpapercuts → gimp
Changed in gimp:
status: Invalid → New
Changed in gimp (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Angel Abad (angelabad) on 2010-07-20
Changed in gimp:
importance: Undecided → Unknown
status: New → Unknown
Changed in gimp:
status: Unknown → New
Angel Abad (angelabad) wrote :

In Gnome Bugzilla Sven Neumann said:

That's a global setting of your desktop. It applies to all GTK+ applications
and you can change this system-wide.


Vish (vish) wrote :

@ Angel Abad : Thanks for sending upstream.

You have been doing a great job of forwarding several bugs upstream.One observation though, when forwarding a bug dont just send the original bug report , it often does *not* contain all the information. [like for this bug]. Try to add a little more information from the comments too. Keep up the good work!

Changed in gimp (Ubuntu):
status: Confirmed → Triaged
Angel Abad (angelabad) wrote :

Ok, Vish, I will be careful next time. Thanks for your advice!

Changed in gimp:
importance: Unknown → Medium
Changed in gimp:
status: New → Confirmed
Changed in gimp:
importance: Medium → Low
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.