gimp does not show gradients, layers and brushes

Bug #597987 reported by pijanyadmin on 2010-06-24
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Chromium Browser
Unknown
Unknown
chromium-browser (Ubuntu)
Undecided
Unassigned
gimp (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gimp

After the last update of Ubuntu. GIMP does not show the layers, brushes and color gradients

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gimp 2.6.8-2ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic i686
Architecture: i386
Date: Thu Jun 24 09:36:59 2010
EcryptfsInUse: Yes
ProcEnviron:
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: gimp

Related branches

pijanyadmin (pijanyadmin) wrote :
description: updated
summary: - gimp does not show gradients
+ gimp does not show gradients, layers and brushes
trapDoor (trapdoor) wrote :

I've got similar issues with GIMP after recent system updates and it seems that some other applications are affected in the same way too. For instance In Appearance > Background (on GNOME 2.30) I can't see correctly all the preview icons of backgrounds any more. What I see instead it's shown on attached screenshot (I've got about 20 wallpapers saved so the whole white area should be filled out with previews like it used to be).
All the resources are still available - I can change background by clicking within the white area. But even when I press the mouse button down no preview for the particular background shows up. I just see which one I've picked when it appears on my desktop. Similarly in GIMP: I still have all my brushes, gradients, palettes and other resources (including custom ones) available but no preview icons for them at all, just empty little squares. I don't appear to have an option to attach more than one file so will post GIMP-related screengrab in next post.

Just a little info about my system:

1. Ubuntu 10.04 (amd64) with recent updates (including lucid proposed and a few ppa repositories)
2. kernel 2.6.34 compiled manually (a long time before the issues occurred)
3. GNOME 2.30
4. GTK+ 2.20.1-0ubuntu2 (lucid proposed) along with these engines (I think it may be relevant):
    gtk2-engines-pixbuf 2.20.1-0ubuntu2
    gtk2-engines-murrine 0.90.3+git20100624~ppa1 (can't remember from what ppa repo)
    gtk2-engines-aurora 1.5.1-1 (as above)
    gtk2-engines-equinox 1.2-0 (as above)
5. GIMP 2.7.1+, compiled manually from git, along with babl and gegl - none in default (system) directories (not that I think GIMP 'is guilty' here at all)
6. X-related packages (including x-org-server, xserver-xorg-video-ati, libdrm) recently updated from the ~xorg-edgers ppa repository

trapDoor (trapdoor) wrote :

With regard to my previous comment I'm attaching another screenshot showing what happened to gradient icon previews in GIMP.

Harry (harry33) wrote :

Hi pijanyadmin and trapdoor,

Please take a look at the bug I reported just the other day:
bug #596192

So if you happen to have installed a development package of cairo (libcairo2-1.9.8 or libcairo2-1.9.9.) from the xorg-edgers PPA,
you have seen the same bug as I do. It is not dependant of compiz or emerald.
It is a GTK issue with the package libcairo2.
You can test this by downgrading the libcairo2 package to the stable version (libcairo2-1.8.10).

trapDoor (trapdoor) wrote :

@Harry
I did as you advised and It worked! Many thanks for indicating the source of the issue. I also locked version of libcairo after downgrading so it won't get upgraded again.

Harry (harry33) wrote :

Hi trapdoor,

OK, nice to know it worked.

pijanyadmin (pijanyadmin) wrote :

Thank you, Harry. In fact, the problem was libcairo2.

affects: gimp (Ubuntu) → cairo (Ubuntu)
Harry (harry33) wrote :

It should be noted, that this bug report does not concern the cairo package (libcairo2-1.8.10) of official lucid or maverick repositories.
It only affects the development versions in some PPA:s.

Igor Nikitin (igor-nikitin) wrote :

I have the same bug in maverick after today's update

Bowmore (bowmore) wrote :

@ Igor Nikitin
For maverick, today's uploaded package libcairo2-1.9.10-1ubuntu1 should fix that for you.

Igor Nikitin (igor-nikitin) wrote :

Yes - I have install this update, restart X, but bug still exists

Bowmore (bowmore) wrote :

Strange, because I've just verified that myself for gimp by upgrading libcairo2-1.9.10-1 to libcairo2-1.9.10-1ubuntu1 that was uploaded some 4-5 hours ago.

KaySL (kaysl13) wrote :

Upgrading the package to 1.9.10-1ubuntu1 fixed the Gnome background selection screen for me, but I too am still getting blank gradients in GIMP. This bug is also affecting the Chromium browser fairly badly, so it's not an isolated problem.

Bowmore (bowmore) wrote :

Yes, you're right.
Package libcairo2-1.9.10-1ubuntu1 fixes gimp layers, patterns and brushes but not gradients.
Also Chromium browser loading icon in the tab bar flickers.

Confirming and adding maverick

Changed in cairo (Ubuntu):
status: New → Confirmed
tags: added: maverick
KaySL (kaysl13) wrote :

Just a little extra info: from my searching around on the issue, it would appear that the remaining errors could well be down to incorrect usage of the Cairo API, rather than a bug per se. From the 1.9.10 release notes:

The last snapshot was picked up by the bleeding edge distributions and so the
    bug reports have to started to roll in. The most frequent of these are the
    introduction of rendering errors by applications that modify a surface
    without subsequently calling cairo_surface_mark_dirty(). Make sure the
    application developers are aware of increased reliance on strict use of the
    Cairo API before 1.10 is released!

KaySL (kaysl13) on 2010-07-03
tags: added: cairo x86-64
Sebastien Bacher (seb128) wrote :

somebody should probably open an upstream gimp bug about the remaining issue

Changed in cairo (Ubuntu):
importance: Undecided → Low
affects: cairo (Ubuntu) → gimp (Ubuntu)
Changed in gimp (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gimp - 2.6.8-2ubuntu2

---------------
gimp (2.6.8-2ubuntu2) maverick; urgency=low

  * debian/patches/90_git_newer_cairo_backend.patch:
    - git change to fix issue with the new cairo version (lp: #597987)
 -- Sebastien Bacher <email address hidden> Mon, 05 Jul 2010 12:08:35 +0200

Changed in gimp (Ubuntu):
status: Fix Committed → Fix Released
affects: chromium (Ubuntu) → chromium-browser (Ubuntu)
trapDoor (trapdoor) wrote :

Just FYI: libcairo2-1.9.10-1ubuntu1 & GIMP 2.7.1+ (pulled today from git) seem to like each-other. All previews of gradients, brushes, patterns, palettes and fonts are displayed correctly.

Florian Boucault (fboucault) wrote :

That chromium bug report is more detailed and points to the patch that seemingly fixes the issues and was commited to git master branch.

KaySL (kaysl13) on 2010-07-11
Changed in chromium-browser (Ubuntu):
status: New → Fix Released
Bowmore (bowmore) wrote :

@KaySL
There does not seem to be a released ubuntu version yet neither for lucid nor maverick.
If so, please specify the chromium-browser packages incl the fix per Ubuntu release.

KaySL (kaysl13) wrote :

Sorry, I'm new to the Launchpad bug tracker. I meant to indicate that the bug has been fixed in the Chromium source tree itself, not in any Ubuntu version. I'll revert my change!

Changed in chromium-browser (Ubuntu):
status: Fix Released → New
Dmitry Shachnev (mitya57) wrote :

Since Ubuntu uses the latest Chromium, it's fixed here as well.

Changed in chromium-browser (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.