GIMP set as default pdf viewer

Bug #574342 reported by Andreas Heinlein on 2010-05-03
74
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gimp (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gimp

After installing GIMP on Lucid, GIMP became the default application to open PDF files, instead of evince. While GIMP can open PDF files, this surely is not what most people want. Please fix this.

May be related to debian bug #525077, but I am not sure.

In any case, /usr/share/applications/mimeinfo.cache contains
application/pdf=gimp.desktop;evince.desktop;

Mackenzie Morgan (maco.m) wrote :

Are you using GNOME or something else as your session? You can check on your login screen in the options to see if it's some uses-GNOME-but-actually-custom thing as well.

Changed in gimp (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gimp (Ubuntu):
status: Incomplete → Invalid
turbolad (turbolad995) wrote :

I have the same problem. Installed GIMP and now it opens PDF files instead of evince.

Rafal-maj-it (rafal-maj-it) wrote :

I have same problem;
Desktop manager is Gnome; On 10.10
This happens when I open from firefox for example.

Same problem on other box, also Gnome, on 10.04. When opening in example from kmail or firefox or krusader.

Changed in gimp (Ubuntu):
status: Invalid → Confirmed

Me too. Ubuntu 10.04 LTS. Gimp 2.6 GNOME.

The workaround is to right click the pdf and choose something other than Gimp.

But, is there something we can do to reset the default to evince?

Thank you.

Max (maxmax) wrote :

After installing the following updates in 11.10 I now also have gimp as default pdf application.

2011-10-26 22:30:47 status installed libpam0g 1.1.3-2ubuntu2.1
2011-10-26 22:30:50 status installed libc-bin 2.13-20ubuntu5
2011-10-26 22:31:03 status installed man-db 2.6.0.2-2
2011-10-26 22:31:05 status installed libpam-modules-bin 1.1.3-2ubuntu2.1
2011-10-26 22:31:10 status installed man-db 2.6.0.2-2
2011-10-26 22:31:12 status installed libpam-modules 1.1.3-2ubuntu2.1
2011-10-26 22:31:16 status installed man-db 2.6.0.2-2
2011-10-26 22:31:19 status installed libpam-runtime 1.1.3-2ubuntu2.1
2011-10-26 22:31:27 status installed desktop-file-utils 0.18-0ubuntu9
2011-10-26 22:31:28 status installed gnome-menus 3.2.0-0ubuntu2
2011-10-26 22:31:28 status installed bamfdaemon 0.2.104-0ubuntu1
2011-10-26 22:31:28 status installed gconf2 3.2.0-0ubuntu1
2011-10-26 22:31:29 status installed libglib2.0-0 2.30.0-0ubuntu4
2011-10-26 22:31:43 status installed hicolor-icon-theme 0.12-1ubuntu1
2011-10-26 22:31:45 status installed shared-mime-info 0.90-1ubuntu4
2011-10-26 22:31:47 status installed menu 2.1.45ubuntu1
2011-10-26 22:31:50 status installed man-db 2.6.0.2-2
2011-10-26 22:31:51 status installed indicator-session 0.3.7-0ubuntu1
2011-10-26 22:31:51 status installed libnautilus-extension1 1:3.2.1-0ubuntu1
2011-10-26 22:31:51 status installed nautilus-data 1:3.2.1-0ubuntu1
2011-10-26 22:31:51 status installed nautilus 1:3.2.1-0ubuntu1
2011-10-26 22:31:52 status installed libc-bin 2.13-20ubuntu5
2011-10-26 22:31:52 status installed menu 2.1.45ubuntu1

In the "open with..." I cannot choose adobe pdf reader as application however acroread is installed as always.

There is also no menu option to "add custom application which is not in the list" to open a filetype with, I guess a new bug/feature request needs to be openend for that also.

Max (maxmax) wrote :

WORKAROUND:

1) Install dolphin pkg. (sudo apt-get install dolphin)
2) Start dolpin (/usr/bin/dolphin)
3) Right click on one existing pdf file in some dir
4) Open with -> Other...
5) Select -> Office -> Adobe Reader
6) Select "Remember application association for this type of file"
7) Click "OK"
8) Done

Then in nautilus also adobe reader will be used as default pdf viewer.

OTHER WORKAROUND:

From terminal (whatever it's called in Gnome):

  xdg-mime default okular.desktop application/pdf

I don't have acroread install but it would probably be:

  xdg-mime default acroread.desktop application/pdf

instead.

psamuel (persaudsamuel) wrote :

prueba a ejecutar gimp en la terminal para ver que error sale y asi poderte ayudar ;)

Still the issue with 12.04 :(

Because of this bug Zotero/Firefox opens pdf attachements in gimp. And it does so without asking which application to use - you double click on pdf file, and it opens in gimp (instead of shiny okular0.15 with really embeddable annotations). The "easy" solution which some really use is to remove gimp, others take a harder way of installing mozplugger, braves modify /usr/share/applications/mimeinfo.cache.

/usr/share/applications/gimp.desktop contains the line "mime-type", which specifies pdf filetype among others.
Please, delete it.

Still exists in 12.10.

Joachim Nuesch (joachim) wrote :

Still exists in 13.04

AS Packaging (packaging-2) wrote :

Upstream bug with relevant information

https://bugzilla.mozilla.org/show_bug.cgi?id=727422

AS Packaging (packaging-2) wrote :

On Ubuntu 12.04 at least, firefox honors what is present as default at

/usr/share/applications/defaults.list

If the application that is defined there is not present, then it picks the first one from

/usr/share/applications/mimeinfo.cache

which is build in random order.

In our systems we use KDE, but evince was present in /usr/share/applications/defaults.list as the default app. Since evince was not installed on the system Firefox locked for another option on /usr/share/applications/mimeinfo.cache and GIMP was the first.

Solution: replace evince with kde4-okularApplication_pdf and firefox will launch okular instead of GIMP.

Example:

application/pdf=kde4-okularApplication_pdf.desktop
application/postscript=kde4-okularApplication_pdf.desktop
application/x-cbr=kde4-okularApplication_pdf.desktop
application/x-cbz=kde4-okularApplication_pdf.desktop
application/x-gzpostscript=kde4-okularApplication_pdf.desktop

mmm (kontakt-podvodnik) on 2013-12-26
no longer affects: firefox (Ubuntu)
Wacha Gábor (wacha) wrote :

Still exists on Kubuntu 15.04

Uqbar (uqbar) wrote :

Still here!!!

Uqbar (uqbar) wrote :

This is a bug with GIMP, obviously.
The solution is to avoid GIMP setting itself as a PDF viewer: GIMP is not a viewer.
If the user wants so, then it'd be up to her to change settings.

Michael Schumacher (schumaml) wrote :

The previous comments (and linked bugs for e.g. Firefox) seem to disagree - this appears to be due to wrong use of the file where every application on a system is supposed to announce what mime types they can handle.

Scott Moore (scottbomb) wrote :

This is still present with Kubuntu 14.04. This (oddly enough) appears to have something to do with Firefox. If I open a PDF within Dolphin, it opens with Okular like it should. If I download a PDF and click the download button in FF to open it, it opens in Gimp.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.