Gimp statusbar missing elements

Bug #542916 reported by skyjumper
This bug report is a duplicate of:  Bug #537275: Regression: Gimp has no progressbar. Edit Remove
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
The Gimp
Fix Released
Unknown
gimp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gimp

On Ubuntu lucid using gimp 2.6.8-2ubuntu1, image window statusbars are missing a few elements. Cursor position, Zoom level, and Cancel button are the obvious ones, but there may be more.

A screenshot from my Lucid system is here: http://i.imgur.com/Go0DH.png
The correct statusbar is shown on http://mediakey.dk/~cc/wp-content/uploads/2007/09/Gimp_2.13_Ubuntu.png and http://docs.gimp.org/en/images/using/wilber-simple-nogrid.png

According to Michael Natterer, the problem is due to use of a bleeding edge Gtk. From IRC:
<mitch> skyjumper: tell them they must patch gimp and some other apps wrt to GtkStatusbar if they really want to use gtk 2.20
<mitch> skyjumper: more seriously, it would help if you told them that the fix for the problem can be copied from gimp_statusbar_init() in app/display/gimpstatusbar.c in gimp git master
<mitch> skyjumper: they can fix all affected apps along these lines

Revision history for this message
skyjumper (x-skyjumper-launchpad) wrote :
Revision history for this message
skyjumper (x-skyjumper-launchpad) wrote :
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

Changed in gimp (Ubuntu):
status: New → Invalid
Changed in gimp:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.